summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-fw-utils_2015.10.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-11-10 09:01:42 -0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-11-25 07:50:31 +0000
commita59d019372362da126f3fb4570723081d0f2359a (patch)
tree2cdadc8cf20867e0fb2f1cbd04b5d77cba404dcf /meta/recipes-bsp/u-boot/u-boot-fw-utils_2015.10.bb
parente67c5b0ccf65eba3fb1c4fb177931baa24d1767a (diff)
downloadpoky-a59d019372362da126f3fb4570723081d0f2359a.tar.gz
u-boot: Update to 2015.10 release
The U-Boot 2015.10 has been released at October 20th 2015. This also removes the GCC workaround, for the inline behavior, as this version properlu supports the GCC 5.2 as compiler. (From OE-Core rev: aebd1a87bbf960e69301bd29137aabb5dfab05fc) Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-fw-utils_2015.10.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-fw-utils_2015.10.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2015.10.bb b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2015.10.bb
new file mode 100644
index 0000000000..93c06e18c4
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2015.10.bb
@@ -0,0 +1,49 @@
1SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://Licenses/README;md5=0507cd7da8e7ad6d6701926ec9b84c95"
4SECTION = "bootloader"
5DEPENDS = "mtd-utils"
6
7# This revision corresponds to the tag "v2015.10"
8# We use the revision in order to avoid having to fetch it from the
9# repo during parse
10SRCREV = "5ec0003b19cbdf06ccd6941237cbc0d1c3468e2d"
11
12PV = "v2015.10+git${SRCPV}"
13
14SRC_URI = "git://git.denx.de/u-boot.git;branch=master"
15
16S = "${WORKDIR}/git"
17
18INSANE_SKIP_${PN} = "already-stripped"
19EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
20EXTRA_OEMAKE_class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
21
22inherit uboot-config
23
24do_compile () {
25 oe_runmake ${UBOOT_MACHINE}
26 oe_runmake env
27}
28
29do_install () {
30 install -d ${D}${base_sbindir}
31 install -d ${D}${sysconfdir}
32 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
33 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
34 install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config
35}
36
37do_install_class-cross () {
38 install -d ${D}${bindir_cross}
39 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
40 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
41}
42
43SYSROOT_PREPROCESS_FUNCS_class-cross = "uboot_fw_utils_cross"
44uboot_fw_utils_cross() {
45 sysroot_stage_dir ${D}${bindir_cross} ${SYSROOT_DESTDIR}${bindir_cross}
46}
47
48PACKAGE_ARCH = "${MACHINE_ARCH}"
49BBCLASSEXTEND = "cross"