summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-fw-utils_2015.01.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-07-20 11:10:30 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-23 08:48:39 +0100
commit51b590db259375aa6259845862ca9020ed264b05 (patch)
tree21f33b36e23c47114e9d7b956f61493fc7966655 /meta/recipes-bsp/u-boot/u-boot-fw-utils_2015.01.bb
parent99b082d0b61cecec1f4e12b3c5d54080f27281e4 (diff)
downloadpoky-51b590db259375aa6259845862ca9020ed264b05.tar.gz
u-boot: Upgrade to 2015.07 release
This upgrades the U-Boot and its related recipes for the 2015.07 release. The following recipes has been upgraded: - u-boot - u-boot-mkimage - u-boot-fw-utils The patches which were applied on top of the 2015.01 release are dropped as those are not needed in this release. The license checksum update was due minimal changes in the text, those have no impact in the license terms. (From OE-Core rev: 3157f8995e24f8a70492a261815be3a6fe51dcbd) Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-fw-utils_2015.01.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-fw-utils_2015.01.bb50
1 files changed, 0 insertions, 50 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2015.01.bb b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2015.01.bb
deleted file mode 100644
index b310b0d0aa..0000000000
--- a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2015.01.bb
+++ /dev/null
@@ -1,50 +0,0 @@
1SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919"
4SECTION = "bootloader"
5DEPENDS = "mtd-utils"
6
7# This revision corresponds to the tag "v2015.01"
8# We use the revision in order to avoid having to fetch it from the
9# repo during parse
10SRCREV = "92fa7f53f1f3f03296f8ffb14bdf1baefab83368"
11
12PV = "v2015.01+git${SRCPV}"
13
14SRC_URI = "git://git.denx.de/u-boot.git;branch=master \
15 file://0001-tools-env-fix-build-error.patch"
16
17S = "${WORKDIR}/git"
18
19INSANE_SKIP_${PN} = "already-stripped"
20EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
21EXTRA_OEMAKE_class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
22
23inherit uboot-config
24
25do_compile () {
26 oe_runmake ${UBOOT_MACHINE}
27 oe_runmake env
28}
29
30do_install () {
31 install -d ${D}${base_sbindir}
32 install -d ${D}${sysconfdir}
33 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
34 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
35 install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config
36}
37
38do_install_class-cross () {
39 install -d ${D}${bindir_cross}
40 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
41 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
42}
43
44SYSROOT_PREPROCESS_FUNCS_class-cross = "uboot_fw_utils_cross"
45uboot_fw_utils_cross() {
46 sysroot_stage_dir ${D}${bindir_cross} ${SYSROOT_DESTDIR}${bindir_cross}
47}
48
49PACKAGE_ARCH = "${MACHINE_ARCH}"
50BBCLASSEXTEND = "cross"