summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/opensbi/opensbi_1.3.bb
diff options
context:
space:
mode:
authorThomas Perrot <thomas.perrot@bootlin.com>2023-11-07 12:20:25 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-11-09 16:57:26 +0000
commitd7af718a2726da55743409965b097aac6e738e88 (patch)
tree838ddd3391856837c3abf8ec37cd361da846506a /meta/recipes-bsp/opensbi/opensbi_1.3.bb
parent7ccff117e38eaae200f32e05e29c3b0f0c2adf28 (diff)
downloadpoky-d7af718a2726da55743409965b097aac6e738e88.tar.gz
opensbi: Upgrade to 1.3.1 release
Here is list of changes in this major release https://github.com/riscv-software-src/opensbi/compare/v1.2...v1.3.1 (From OE-Core rev: 5d642c49e9354c105b1269555b646bb4afaef491) Signed-off-by: Thomas Perrot <thomas.perrot@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/opensbi/opensbi_1.3.bb')
-rw-r--r--meta/recipes-bsp/opensbi/opensbi_1.3.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-bsp/opensbi/opensbi_1.3.bb b/meta/recipes-bsp/opensbi/opensbi_1.3.bb
new file mode 100644
index 0000000000..f01cae34d1
--- /dev/null
+++ b/meta/recipes-bsp/opensbi/opensbi_1.3.bb
@@ -0,0 +1,47 @@
1SUMMARY = "RISC-V Open Source Supervisor Binary Interface (OpenSBI)"
2DESCRIPTION = "OpenSBI aims to provide an open-source and extensible implementation of the RISC-V SBI specification for a platform specific firmware (M-mode) and a general purpose OS, hypervisor or bootloader (S-mode or HS-mode). OpenSBI implementation can be easily extended by RISC-V platform or System-on-Chip vendors to fit a particular hadware configuration."
3HOMEPAGE = "https://github.com/riscv/opensbi"
4LICENSE = "BSD-2-Clause"
5LIC_FILES_CHKSUM = "file://COPYING.BSD;md5=42dd9555eb177f35150cf9aa240b61e5"
6
7require opensbi-payloads.inc
8
9inherit autotools-brokensep deploy
10
11SRCREV = "057eb10b6d523540012e6947d5c9f63e95244e94"
12SRC_URI = "git://github.com/riscv/opensbi.git;branch=release-1.3.x;protocol=https"
13
14S = "${WORKDIR}/git"
15
16EXTRA_OEMAKE += "PLATFORM=${RISCV_SBI_PLAT} I=${D} FW_PIC=n CLANG_TARGET= "
17# If RISCV_SBI_PAYLOAD is set then include it as a payload
18EXTRA_OEMAKE:append = " ${@riscv_get_extra_oemake_image(d)}"
19EXTRA_OEMAKE:append = " ${@riscv_get_extra_oemake_fdt(d)}"
20
21# Required if specifying a custom payload
22do_compile[depends] += "${@riscv_get_do_compile_depends(d)}"
23
24do_install:append() {
25 # In the future these might be required as a dependency for other packages.
26 # At the moment just delete them to avoid warnings
27 rm -r ${D}/include
28 rm -r ${D}/lib*
29 rm -r ${D}/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/payloads
30}
31
32do_deploy () {
33 install -m 755 ${D}/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_payload.* ${DEPLOYDIR}/
34 install -m 755 ${D}/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_jump.* ${DEPLOYDIR}/
35 install -m 755 ${D}/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_dynamic.* ${DEPLOYDIR}/
36}
37
38addtask deploy before do_build after do_install
39
40FILES:${PN} += "/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_jump.*"
41FILES:${PN} += "/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_payload.*"
42FILES:${PN} += "/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_dynamic.*"
43
44COMPATIBLE_HOST = "(riscv64|riscv32).*"
45INHIBIT_PACKAGE_STRIP = "1"
46
47SECURITY_CFLAGS = ""