summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/grub/grub_git.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2014-01-06 12:01:25 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-01-06 22:17:29 +0000
commitb1bf8f7f2bf7c6117c56e08b6ba667720862d3da (patch)
tree4d59020cbf37745d0370aa32d6c5f8809248db2d /meta/recipes-bsp/grub/grub_git.bb
parent2acd6174dea199917255cfe69f7504923069185e (diff)
downloadpoky-b1bf8f7f2bf7c6117c56e08b6ba667720862d3da.tar.gz
grub: add git version
Recently grub git gained support for ARM builds (using u-boot or EFI as first stage loader) and with 2 extra patches we get support for 64-bit ARM as well. Buildtested for genericarmv7a, genericarmv8 and qemux86. The genericarmv8 build fails in do_package/strip due to a binutils problem. (From OE-Core rev: b4e28912af0618755ce75d0cc27d53fa9d745b30) Signed-off-by: Koen Kooi <koen.kooi@linaro.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/grub/grub_git.bb')
-rw-r--r--meta/recipes-bsp/grub/grub_git.bb61
1 files changed, 61 insertions, 0 deletions
diff --git a/meta/recipes-bsp/grub/grub_git.bb b/meta/recipes-bsp/grub/grub_git.bb
new file mode 100644
index 0000000000..ca636f32ce
--- /dev/null
+++ b/meta/recipes-bsp/grub/grub_git.bb
@@ -0,0 +1,61 @@
1SUMMARY = "GRUB2 is the next-generation GRand Unified Bootloader"
2
3DESCRIPTION = "GRUB2 is the next generaion of a GPLed bootloader \
4intended to unify bootloading across x86 operating systems. In \
5addition to loading the Linux kernel, it implements the Multiboot \
6standard, which allows for flexible loading of multiple boot images."
7
8HOMEPAGE = "http://www.gnu.org/software/grub/"
9SECTION = "bootloaders"
10
11LICENSE = "GPLv3"
12LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
13
14DEPENDS = "autogen-native flex-native bison-native xz freetype"
15
16DEFAULT_PREFERENCE = "-1"
17DEFAULT_PREFERENCE_arm = "1"
18
19PV = "2.00+${SRCPV}"
20SRCREV = "3bc1b2daabb9b07a9c08bca386005d96f07147fe"
21SRC_URI = "git://git.savannah.gnu.org/grub.git \
22 file://0001-fdt-add-grub_fdt_create_empty_tree-function.patch \
23 file://0002-arm64-add-EFI-Linux-loader.patch \
24 file://40_custom \
25 "
26
27S = "${WORKDIR}/git"
28
29COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|aarch64.*)-(linux.*|freebsd.*)'
30
31inherit autotools
32inherit gettext
33
34PACKAGECONFIG ??= ""
35PACKAGECONFIG[grub-mount] = "--enable-grub-mount,--disable-grub-mount,fuse"
36
37# configure.ac has code to set this automagically from the target tuple
38# but the OE freeform one (core2-foo-bar-linux) don't work with that.
39
40GRUBPLATFORM_arm = "uboot"
41GRUBPLATFORM_aarch64 = "efi"
42GRUBPLATFORM ??= "pc"
43
44EXTRA_OECONF = "--with-platform=${GRUBPLATFORM} --disable-grub-mkfont --program-prefix="" \
45 --enable-liblzma=no --enable-device-mapper=no --enable-libzfs=no"
46
47do_configure_prepend() {
48 ( cd ${S}
49 ${S}/autogen.sh )
50}
51
52do_install_append () {
53 install -d ${D}${sysconfdir}/grub.d
54 install -m 0755 ${WORKDIR}/40_custom ${D}${sysconfdir}/grub.d/40_custom
55}
56
57RDEPENDS_${PN} = "diffutils freetype"
58FILES_${PN}-dbg += "${libdir}/${BPN}/*/.debug"
59
60INSANE_SKIP_${PN} = "arch"
61INSANE_SKIP_${PN}-dbg = "arch"