summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/grub/grub_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-01-12 23:43:13 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-30 11:36:58 +0000
commit047ad2c81a7ec0d59d5fb1ddf52668c29a1119c9 (patch)
tree87cbebb1238a9d20c8346b78cd6021567cd4bbfc /meta/recipes-bsp/grub/grub_git.bb
parent956be0c858b55f34e666ad2a00bd07ae61e36ae1 (diff)
downloadpoky-047ad2c81a7ec0d59d5fb1ddf52668c29a1119c9.tar.gz
grub: Backport fix for largefile detection/use
This is inspired by musl porting, where grub's configure is enabling largefile support based on glibc versions, instead an upstream patch turns it into autoconf check Update git version recipe arm platforms use this recipe to provide grub and it needed fixes from upstream so upgrade to latest tip of git and forward port patches as well as drop the ones already applied upstream (From OE-Core rev: a290429c8415042cb8c2f4258e76a3cc6815a172) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/grub/grub_git.bb')
-rw-r--r--meta/recipes-bsp/grub/grub_git.bb13
1 files changed, 8 insertions, 5 deletions
diff --git a/meta/recipes-bsp/grub/grub_git.bb b/meta/recipes-bsp/grub/grub_git.bb
index 6a0e3ee036..3ebab7f2f8 100644
--- a/meta/recipes-bsp/grub/grub_git.bb
+++ b/meta/recipes-bsp/grub/grub_git.bb
@@ -5,13 +5,14 @@ DEPENDS += "autogen-native"
5DEFAULT_PREFERENCE = "-1" 5DEFAULT_PREFERENCE = "-1"
6DEFAULT_PREFERENCE_arm = "1" 6DEFAULT_PREFERENCE_arm = "1"
7 7
8FILESEXTRAPATHS =. "${FILE_DIRNAME}/grub-git:"
9
8PV = "2.00+${SRCPV}" 10PV = "2.00+${SRCPV}"
9SRCREV = "87de66d9d83446ecddb29cfbdf7369102c8e209e" 11SRCREV = "b95e92678882f56056c64ae29092bc9cf129905f"
10SRC_URI = "git://git.savannah.gnu.org/grub.git \ 12SRC_URI = "git://git.savannah.gnu.org/grub.git \
11 file://grub-2.00-fpmath-sse-387-fix.patch \ 13 file://0001-Disable-mfpmath-sse-as-well-when-SSE-is-disabled.patch \
12 file://autogen.sh-exclude-pc.patch \ 14 file://autogen.sh-exclude-pc.patch \
13 file://grub-2.00-add-oe-kernel.patch \ 15 file://0001-grub.d-10_linux.in-add-oe-s-kernel-name.patch \
14 file://0001-Fix-build-with-glibc-2.20.patch \
15 " 16 "
16 17
17S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
@@ -30,6 +31,8 @@ GRUBPLATFORM ??= "pc"
30EXTRA_OECONF = "--with-platform=${GRUBPLATFORM} --disable-grub-mkfont --program-prefix="" \ 31EXTRA_OECONF = "--with-platform=${GRUBPLATFORM} --disable-grub-mkfont --program-prefix="" \
31 --enable-liblzma=no --enable-device-mapper=no --enable-libzfs=no" 32 --enable-liblzma=no --enable-device-mapper=no --enable-libzfs=no"
32 33
34EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'largefile', '--enable-largefile ac_cv_sizeof_off_t=8', '--disable-largefile', d)}"
35
33do_configure_prepend() { 36do_configure_prepend() {
34 ( cd ${S} 37 ( cd ${S}
35 ${S}/autogen.sh ) 38 ${S}/autogen.sh )
@@ -37,7 +40,7 @@ do_configure_prepend() {
37 40
38do_install_append () { 41do_install_append () {
39 install -d ${D}${sysconfdir}/grub.d 42 install -d ${D}${sysconfdir}/grub.d
40 43 rm -rf ${D}${libdir}/charset.alias
41} 44}
42 45
43# debugedit chokes on bare metal binaries 46# debugedit chokes on bare metal binaries