summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/grub/grub_2.04.bb
diff options
context:
space:
mode:
authorJacob Kroon <jacob.kroon@gmail.com>2020-06-22 13:43:43 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-06-23 12:31:03 +0100
commit2d740a8c710a001d7de48881fb3ec227f4e25c92 (patch)
tree679a88412e83b83aea6d174f0e25b500db111b7c /meta/recipes-bsp/grub/grub_2.04.bb
parentb58192aba2d8f6b388a073629f8d3e765a074643 (diff)
downloadpoky-2d740a8c710a001d7de48881fb3ec227f4e25c92.tar.gz
grub: Remove native version of grub-efi
The native version of grub-efi only installs the tools /usr/bin/grub-editenv /usr/bin/grub-mkimage to sysroots-components/, but equivalent tools are already provided by grub-native, the difference on x86_64 being 4 hardwired paths in grub-mkimage (values taken from grub-native): LOCALEDIR = $TMPDIR/work/x86_64-linux/grub-native/2.04-r0/recipe-sysroot-native/usr/share/locale GRUB_DATADIR = $TMPDIR/work/x86_64-linux/grub-native/2.04-r0/recipe-sysroot-native/usr/share GRUB_LIBDIR = $TMPDIR/work/x86_64-linux/grub-native/2.04-r0/recipe-sysroot-native/usr/lib GRUB_SYSCONFDIR = $TMPDIR/work/x86_64-linux/grub-native/2.04-r0/recipe-sysroot-native/etc If grub-native and grub-efi-native are built with the following patch --- grub-2.04.orig/configure.ac +++ grub-2.04/configure.ac @@ -1980,10 +1980,10 @@ grub_libdir="$(eval echo "$libdir")" grub_localedir="$(eval echo "$localedir")" grub_datadir="$(eval echo "$datadir")" grub_sysconfdir="$(eval echo "$sysconfdir")" -AC_DEFINE_UNQUOTED(LOCALEDIR, "$grub_localedir", [Locale dir]) -AC_DEFINE_UNQUOTED(GRUB_LIBDIR, "$grub_libdir", [Library dir]) -AC_DEFINE_UNQUOTED(GRUB_DATADIR, "$grub_datadir", [Data dir]) -AC_DEFINE_UNQUOTED(GRUB_SYSCONFDIR, "$grub_sysconfdir", [Configuration dir]) +AC_DEFINE_UNQUOTED(LOCALEDIR, "/non-existent", [Locale dir]) +AC_DEFINE_UNQUOTED(GRUB_LIBDIR, "/non-existent", [Library dir]) +AC_DEFINE_UNQUOTED(GRUB_DATADIR, "/non-existent", [Data dir]) +AC_DEFINE_UNQUOTED(GRUB_SYSCONFDIR, "/non-existent", [Configuration dir]) the produced grub-editenv/grub-mkimage binaries become binary equivalent, assuming reproducible builds is active. Since the unpatched values of LOCALEDIR/GRUB_DATADIR/GRUB_LIBDIR/GRUB_SYSCONFDIR point to directories that are not expected to exist at runtime, they can be ignored. Therefore: * remove grub-efi-native and instead rely on the same tools from grub-native * replace references to grub-efi-native with grub-native * remove unused grub-efi-native security flags overrides (From OE-Core rev: 7044181df7487f047d175242f7ebbc3c35bf5402) Signed-off-by: Jacob Kroon <jacob.kroon@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/grub/grub_2.04.bb')
-rw-r--r--meta/recipes-bsp/grub/grub_2.04.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-bsp/grub/grub_2.04.bb b/meta/recipes-bsp/grub/grub_2.04.bb
index 9232ea8120..df607cae14 100644
--- a/meta/recipes-bsp/grub/grub_2.04.bb
+++ b/meta/recipes-bsp/grub/grub_2.04.bb
@@ -2,9 +2,12 @@ require grub2.inc
2 2
3RDEPENDS_${PN}-common += "${PN}-editenv" 3RDEPENDS_${PN}-common += "${PN}-editenv"
4RDEPENDS_${PN} += "${PN}-common" 4RDEPENDS_${PN} += "${PN}-common"
5RDEPENDS_${PN}_class-native = ""
5 6
6RPROVIDES_${PN}-editenv += "${PN}-efi-editenv" 7RPROVIDES_${PN}-editenv += "${PN}-efi-editenv"
7 8
9PROVIDES_append_class-native = " grub-efi-native"
10
8PACKAGES =+ "${PN}-editenv ${PN}-common" 11PACKAGES =+ "${PN}-editenv ${PN}-common"
9FILES_${PN}-editenv = "${bindir}/grub-editenv" 12FILES_${PN}-editenv = "${bindir}/grub-editenv"
10FILES_${PN}-common = " \ 13FILES_${PN}-common = " \
@@ -31,3 +34,5 @@ do_install_append () {
31 34
32INSANE_SKIP_${PN} = "arch" 35INSANE_SKIP_${PN} = "arch"
33INSANE_SKIP_${PN}-dbg = "arch" 36INSANE_SKIP_${PN}-dbg = "arch"
37
38BBCLASSEXTEND = "native"