summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/grub/grub-efi-native_1.99.bb
diff options
context:
space:
mode:
authorRadu Moisan <radu.moisan@intel.com>2012-08-21 14:48:38 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-23 11:43:34 +0100
commit8e335f1da265cdb0ea2d5f95b3dfe8c856213c96 (patch)
treeda9127c7d3a1623a76aace5147d442faa3bd4d2d /meta/recipes-bsp/grub/grub-efi-native_1.99.bb
parent1192ace3185f3293508531687e1d199b03934460 (diff)
downloadpoky-8e335f1da265cdb0ea2d5f95b3dfe8c856213c96.tar.gz
grub-efi-native: Update to version 2.00
Added -Wno-unused-result because of a read() with no result, and causing error due to -Werror Updated grub recipe because of a patch name change Removed unnecessary patches (merged upstream). (From OE-Core rev: 88cd5d99918a896f515e8bb59b7238f3ad50adff) Signed-off-by: Radu Moisan <radu.moisan@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/grub/grub-efi-native_1.99.bb')
-rw-r--r--meta/recipes-bsp/grub/grub-efi-native_1.99.bb81
1 files changed, 0 insertions, 81 deletions
diff --git a/meta/recipes-bsp/grub/grub-efi-native_1.99.bb b/meta/recipes-bsp/grub/grub-efi-native_1.99.bb
deleted file mode 100644
index 9e923bd840..0000000000
--- a/meta/recipes-bsp/grub/grub-efi-native_1.99.bb
+++ /dev/null
@@ -1,81 +0,0 @@
1SUMMARY = "GRUB2 is the next-generation GRand Unified Bootloader"
2
3DESCRIPTION = "GRUB2 is the next generaion of a GPLed bootloader \
4intended to unify bootloading across x86 operating systems. In \
5addition to loading the Linux kernel, it implements the Multiboot \
6standard, which allows for flexible loading of multiple boot images. \
7This recipe builds an EFI binary for the target. It does not install \
8or package anything, it only deploys a target-arch GRUB EFI image."
9
10HOMEPAGE = "http://www.gnu.org/software/grub/"
11SECTION = "bootloaders"
12
13LICENSE = "GPLv3"
14LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
15
16# FIXME: We should be able to optionally drop freetype as a dependency
17DEPENDS = "autogen-native"
18RDEPENDS_${PN} = "diffutils freetype"
19PR = "r10"
20
21# Native packages do not normally rebuild when the target changes.
22# Ensure this is built once per HOST-TARGET pair.
23PN := "grub-efi-${TRANSLATED_TARGET_ARCH}-native"
24
25SRC_URI = "ftp://ftp.gnu.org/gnu/grub/grub-${PV}.tar.gz \
26 file://grub-1.99_fix_for_automake_1.11.2.patch \
27 file://grub-1.99-fpmath-sse-387-fix.patch \
28 file://grub-1.99-gcc-4.7.0.patch \
29 file://grub-1.99-gcc-4.7.0-uninitialized-var-errors.patch \
30 file://grub-1.99-gcc-4.7.0-strict-aliasing-errors.patch \
31 file://grub-1.99-fix-enable_execute_stack-check.patch \
32 file://grub-1.99-disable-help2man.patch \
33 "
34
35SRC_URI[md5sum] = "ca9f2a2d571b57fc5c53212d1d22e2b5"
36SRC_URI[sha256sum] = "b91f420f2c51f6155e088e34ff99bea09cc1fb89585cf7c0179644e57abd28ff"
37
38COMPATIBLE_HOST = '(x86_64.*|i.86.*)-(linux|freebsd.*)'
39
40S = "${WORKDIR}/grub-${PV}"
41
42# Determine the target arch for the grub modules before the native class
43# clobbers TARGET_ARCH.
44ORIG_TARGET_ARCH := "${TARGET_ARCH}"
45python __anonymous () {
46 import re
47 target = d.getVar('ORIG_TARGET_ARCH', True)
48 if target == "x86_64":
49 grubtarget = 'x86_64'
50 grubimage = "bootx64.efi"
51 elif re.match('i.86', target):
52 grubtarget = 'i386'
53 grubimage = "bootia32.efi"
54 else:
55 raise bb.parse.SkipPackage("grub-efi is incompatible with target %s" % target)
56 d.setVar("GRUB_TARGET", grubtarget)
57 d.setVar("GRUB_IMAGE", grubimage)
58}
59
60inherit autotools
61inherit gettext
62inherit native
63inherit deploy
64
65EXTRA_OECONF = "--with-platform=efi --disable-grub-mkfont \
66 --target=${GRUB_TARGET} --enable-efiemu=no --program-prefix=''"
67
68do_mkimage() {
69 ./grub-mkimage -p /EFI/BOOT -d ./grub-core/ \
70 -O ${GRUB_TARGET}-efi -o ./${GRUB_IMAGE} \
71 boot linux ext2 fat serial part_msdos part_gpt normal efi_gop
72}
73addtask mkimage after do_compile before do_install
74
75do_deploy() {
76 install -m 644 ${S}/${GRUB_IMAGE} ${DEPLOYDIR}
77}
78addtask deploy after do_install before do_build
79
80do_install[noexec] = "1"
81do_populate_sysroot[noexec] = "1"