summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/efivar/efivar_38.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-01-19 11:40:42 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-01-20 11:57:28 +0000
commit14e27297f4c14fdb64ce1e7c250d2c81aa766a0c (patch)
treefa7627bd224425888b4f2b8ff0737a614b4cb468 /meta/recipes-bsp/efivar/efivar_38.bb
parent80a6e76eb4cac62721a1a7d63f17bcaab25a6550 (diff)
downloadpoky-14e27297f4c14fdb64ce1e7c250d2c81aa766a0c.tar.gz
efivar: update 37 -> 38
Drop determinism.patch, resolved by https://github.com/rhboot/efivar/commit/641a1626543ca3bf0cdd5ea0bd6cc3a82462521a Drop no-werror.patch, can now be replaced by ERRORS= in make invocation. Add a patch to efibootmgr to address build failures with new version. (From OE-Core rev: 60665cdd6b1bbed29b919328ab34827c055ed729) Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/efivar/efivar_38.bb')
-rw-r--r--meta/recipes-bsp/efivar/efivar_38.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-bsp/efivar/efivar_38.bb b/meta/recipes-bsp/efivar/efivar_38.bb
new file mode 100644
index 0000000000..5d2cd470ce
--- /dev/null
+++ b/meta/recipes-bsp/efivar/efivar_38.bb
@@ -0,0 +1,40 @@
1SUMMARY = "Tools to manipulate UEFI variables"
2DESCRIPTION = "efivar provides a simple command line interface to the UEFI variable facility"
3HOMEPAGE = "https://github.com/rhboot/efivar"
4
5LICENSE = "LGPLv2.1+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=6626bb1e20189cfa95f2c508ba286393"
7
8COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
9
10SRC_URI = "git://github.com/rhinstaller/efivar.git;branch=main;protocol=https \
11 file://0001-docs-do-not-build-efisecdb-manpage.patch \
12 file://0001-src-Makefile-build-util.c-separately-for-makeguids.patch \
13 "
14SRCREV = "1753149d4176ebfb2b135ac0aaf79340bf0e7a93"
15
16S = "${WORKDIR}/git"
17
18inherit pkgconfig
19
20export CCLD_FOR_BUILD = "${BUILD_CCLD}"
21
22# Upstream uses --add-needed in gcc.specs which gold doesn't support, so
23# enforce BFD.
24LDFLAGS += "-fuse-ld=bfd"
25
26do_compile() {
27 oe_runmake ERRORS= HOST_CFLAGS="${BUILD_CFLAGS}" HOST_LDFLAGS="${BUILD_LDFLAGS}"
28}
29
30do_install() {
31 oe_runmake install DESTDIR=${D}
32}
33
34BBCLASSEXTEND = "native"
35
36RRECOMMENDS:${PN}:class-target = "kernel-module-efivarfs"
37
38CLEANBROKEN = "1"
39# https://github.com/rhboot/efivar/issues/202
40COMPATIBLE_HOST:libc-musl = 'null'