summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/efibootmgr/efibootmgr_17.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-06-12 21:35:36 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-06-14 22:48:22 +0100
commitb87f4d28f925891b2e9473cfac0d0885748f7f4f (patch)
tree460f06aef7ef4473fdceebdfe6fd53f933be4889 /meta/recipes-bsp/efibootmgr/efibootmgr_17.bb
parent8a8ae3759d4b2d3ff6c059df289d43e5f46d460f (diff)
downloadpoky-b87f4d28f925891b2e9473cfac0d0885748f7f4f.tar.gz
efibootmgr: add
This was in meta-oe but EFI is sufficiently widespread now that we need it in core. The recipe is based on the one in meta-oe but with several updates. (From OE-Core rev: 275e5e7ecf4f79b7892ae35a47902188d9905bd0) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/efibootmgr/efibootmgr_17.bb')
-rw-r--r--meta/recipes-bsp/efibootmgr/efibootmgr_17.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-bsp/efibootmgr/efibootmgr_17.bb b/meta/recipes-bsp/efibootmgr/efibootmgr_17.bb
new file mode 100644
index 0000000000..0e5a81e316
--- /dev/null
+++ b/meta/recipes-bsp/efibootmgr/efibootmgr_17.bb
@@ -0,0 +1,34 @@
1DESCRIPTION = "Linux user-space application to modify the EFI Boot Manager."
2SUMMARY = "EFI Boot Manager"
3HOMEPAGE = "https://github.com/rhboot/efibootmgr"
4SECTION = "base"
5
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
8
9DEPENDS = "efivar popt"
10
11COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
12
13SRC_URI = "git://github.com/rhinstaller/efibootmgr.git;protocol=https \
14 file://0001-remove-extra-decl.patch \
15 "
16SRCREV = "e067160ecef8208e1944002e5d50b275733211fb"
17
18S = "${WORKDIR}/git"
19
20inherit pkgconfig
21
22# The directory under the ESP that the default bootloader is found in. When
23# wic uses a subdirectory, this should use the same one too.
24EFIDIR ?= "/"
25
26EXTRA_OEMAKE += "'EFIDIR=${EFIDIR}'"
27
28CFLAGS += " -Wno-error"
29
30do_install () {
31 oe_runmake install DESTDIR="${D}"
32}
33
34CLEANBROKEN = "1"