summaryrefslogtreecommitdiffstats
path: root/meta/packages/xserver-kdrive-common
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2007-05-23 17:02:58 +0000
committerRichard Purdie <richard@openedhand.com>2007-05-23 17:02:58 +0000
commit54df65042fec4f2520936d013a6193b5c06f0ee3 (patch)
treeaa15c6e021b5cdc5f3294cdc682e59c2d2a70cbd /meta/packages/xserver-kdrive-common
parent5d1d2e63413c1ae0915847376c32eef466658297 (diff)
downloadpoky-54df65042fec4f2520936d013a6193b5c06f0ee3.tar.gz
xserver-kdrive-common: Switch to use formfactor
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1774 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/xserver-kdrive-common')
-rw-r--r--meta/packages/xserver-kdrive-common/xserver-kdrive-common/etc/X11/Xserver53
-rw-r--r--meta/packages/xserver-kdrive-common/xserver-kdrive-common_0.1.bb4
2 files changed, 15 insertions, 42 deletions
diff --git a/meta/packages/xserver-kdrive-common/xserver-kdrive-common/etc/X11/Xserver b/meta/packages/xserver-kdrive-common/xserver-kdrive-common/etc/X11/Xserver
index 244ea6dd91..efca502f7e 100644
--- a/meta/packages/xserver-kdrive-common/xserver-kdrive-common/etc/X11/Xserver
+++ b/meta/packages/xserver-kdrive-common/xserver-kdrive-common/etc/X11/Xserver
@@ -1,6 +1,8 @@
1#!/bin/sh 1#!/bin/sh
2# 2#
3 3
4. /etc/formfactor/config
5
4# note xinit needs full server path 6# note xinit needs full server path
5XSERVER=/usr/bin/Xipaq 7XSERVER=/usr/bin/Xipaq
6if [ -f /usr/bin/Xfbdev ]; then 8if [ -f /usr/bin/Xfbdev ]; then
@@ -18,14 +20,6 @@ fi
18 20
19. /etc/profile 21. /etc/profile
20 22
21fallback_screen_arg() {
22 geom=`fbset | grep geometry`
23 w=`echo $geom | awk '{ print $2 }'`
24 h=`echo $geom | awk '{ print $3 }'`
25 b=`echo $geom | awk '{ print $6 }'`
26 echo -n "${w}x${h}x${b}"
27}
28
29module_id() { 23module_id() {
30 ## used to read from assets, but sometimes assets is corrupted 24 ## used to read from assets, but sometimes assets is corrupted
31 # grep "Module ID" /proc/hal/assets | sed "s/.*://" 25 # grep "Module ID" /proc/hal/assets | sed "s/.*://"
@@ -51,49 +45,28 @@ fi
51 45
52# start off server in conventional location. 46# start off server in conventional location.
53case `module_id` in 47case `module_id` in
54 "HP iPAQ H3100" | "HP iPAQ H3800")
55 ARGS="$ARGS -dpi 100 -screen 320x240@90 -rgba vrgb" ;;
56 "HP iPAQ H3600" | "HP iPAQ H3700" | "HP iPAQ H3900")
57 ARGS="$ARGS -dpi 100 -screen 320x240@270 -rgba vbgr" ;;
58 "HP iPAQ H5400" | "HP iPAQ H2200")
59 ARGS="$ARGS -dpi 100 -rgba rgb" ;;
60 "Ramses")
61 # What is this "vt2" in aid of?
62 ARGS="$ARGS -dpi 100 -screen 320x240@90 -rgba vrgb vt2" ;;
63 # both 'Sharp-Collie' and just 'Collie' have been reported
64 *Poodle)
65 ARGS="$ARGS -screen 320x240@270 -rgba vrgb" ;;
66 *Collie)
67 ARGS="$ARGS -dpi 100 -screen 320x240@270 -rgba vrgb"
68 # Horrible hack required to enable resuming after suspend
69 rm -f /dev/apm_bios
70 killall -9 apmd
71 ;;
72 "SHARP Shepherd" | "SHARP Husky" | "SHARP Corgi")
73 ARGS="$ARGS -dpi 150 -rgba rgb" ;;
74 "SHARP Spitz" | "SHARP Akita" | "SHARP Borzoi")
75 ARGS="$ARGS -dpi 150 -rgba rgb -screen 480x640@270" ;;
76 "Simpad")
77 ARGS="$ARGS -rgba rgb" ;;
78 "Generic OMAP1510/1610/1710") 48 "Generic OMAP1510/1610/1710")
79 ARGS="$ARGS -mouse /dev/input/event0" ;; 49 ARGS="$ARGS -mouse /dev/input/event0" ;;
80 "ARM-IntegratorCP" | "ARM-Versatile PB")
81 ARGS="$ARGS -rgba vrgb" ;;
82 "Compulab CM-x270") 50 "Compulab CM-x270")
83 modprobe mbxfb 51 modprobe mbxfb
84 ARGS="$ARGS -fb /dev/fb1" 52 ARGS="$ARGS -fb /dev/fb1"
85 ;; 53 ;;
86 "Nokia N800") 54 "Nokia N800")
87 ARGS="$ARGS -dpi 150 -screen 800x480x16 -mouse tslib" ;; 55 ARGS="$ARGS -mouse tslib" ;;
88 *) 56 *)
89 # Its a device we dont know about - in which case force
90 # kdrive to use the current framebuffer geometry otherwise
91 # it will defualt to trying to achieve 1024x768
92 S=`fallback_screen_arg`
93 ARGS="$ARGS -screen $S"
94 ;; 57 ;;
95esac 58esac
96 59
60ARGS="$ARGS -screen ${DISPLAY_WIDTH_PIXELS}x${DISPLAY_HEIGHT_PIXELS}x${DISPLAY_BPP}@${DISPLAY_ORIENTATION}"
61
62if [ ! -z "$DISPLAY_DPI" ]; then
63 ARGS="$ARGS -dpi $DISPLAY_DPI"
64fi
65
66if [ ! -z "$DISPLAY_SUBPIXEL_ORDER" ]; then
67 ARGS="$ARGS -rgba $DISPLAY_SUBPIXEL_ORDER"
68fi
69
97DISPLAY=':0' 70DISPLAY=':0'
98 71
99exec xinit /etc/X11/Xsession -- $XSERVER $DISPLAY $ARGS $* 72exec xinit /etc/X11/Xsession -- $XSERVER $DISPLAY $ARGS $*
diff --git a/meta/packages/xserver-kdrive-common/xserver-kdrive-common_0.1.bb b/meta/packages/xserver-kdrive-common/xserver-kdrive-common_0.1.bb
index 59ca94ebd9..c64a3b6246 100644
--- a/meta/packages/xserver-kdrive-common/xserver-kdrive-common_0.1.bb
+++ b/meta/packages/xserver-kdrive-common/xserver-kdrive-common_0.1.bb
@@ -1,8 +1,8 @@
1DESCRIPTION = "Common X11 scripts" 1DESCRIPTION = "Common X11 scripts"
2LICENSE = "GPL" 2LICENSE = "GPL"
3SECTION = "x11" 3SECTION = "x11"
4RDEPENDS_${PN} = "xmodmap libxrandr xdpyinfo xtscal xinit" 4RDEPENDS_${PN} = "xmodmap libxrandr xdpyinfo xtscal xinit formfactor"
5PR = "r12" 5PR = "r16"
6 6
7SRC_URI = "file://etc" 7SRC_URI = "file://etc"
8S = ${WORKDIR} 8S = ${WORKDIR}