summaryrefslogtreecommitdiffstats
path: root/meta/packages/xorg-xserver
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-05-31 22:17:58 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-05-31 22:17:58 +0100
commitea26c2105d6fb5c9807efe9e558685fc89c30c3e (patch)
treea7fb2a773414ce8cd304aad3f828f1964ded065a /meta/packages/xorg-xserver
parent185d8b084a13f46b8c356dc785f49753ee107db7 (diff)
downloadpoky-ea26c2105d6fb5c9807efe9e558685fc89c30c3e.tar.gz
xserver-xf86: Split xorg.conf from main xserver package
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/xorg-xserver')
-rw-r--r--meta/packages/xorg-xserver/xserver-xf86-common.inc9
-rw-r--r--meta/packages/xorg-xserver/xserver-xf86-config/qemux86/xorg.conf (renamed from meta/packages/xorg-xserver/xserver-xf86-lite/xorg.conf)17
-rw-r--r--meta/packages/xorg-xserver/xserver-xf86-config/xorg.conf (renamed from meta/packages/xorg-xserver/xserver-xf86-dri-lite/xorg.conf)0
-rw-r--r--meta/packages/xorg-xserver/xserver-xf86-config_0.1.bb16
-rw-r--r--meta/packages/xorg-xserver/xserver-xf86-dri-lite_1.6.0.bb2
-rw-r--r--meta/packages/xorg-xserver/xserver-xf86-dri-lite_git.bb2
6 files changed, 25 insertions, 21 deletions
diff --git a/meta/packages/xorg-xserver/xserver-xf86-common.inc b/meta/packages/xorg-xserver/xserver-xf86-common.inc
index 5a10ecf994..f69efc8d67 100644
--- a/meta/packages/xorg-xserver/xserver-xf86-common.inc
+++ b/meta/packages/xorg-xserver/xserver-xf86-common.inc
@@ -11,8 +11,7 @@ PROVIDES = "virtual/xserver-xf86"
11PROVIDES += "virtual/xserver" 11PROVIDES += "virtual/xserver"
12 12
13XORG_PN = "xorg-server" 13XORG_PN = "xorg-server"
14SRC_URI = "${XORG_MIRROR}/individual/xserver/${XORG_PN}-${PV}.tar.bz2 \ 14SRC_URI = "${XORG_MIRROR}/individual/xserver/${XORG_PN}-${PV}.tar.bz2"
15 file://xorg.conf"
16 15
17S = "${WORKDIR}/${XORG_PN}-${PV}" 16S = "${WORKDIR}/${XORG_PN}-${PV}"
18 17
@@ -20,6 +19,8 @@ inherit autotools_stage pkgconfig
20 19
21PACKAGES =+ "${PN}-utils" 20PACKAGES =+ "${PN}-utils"
22 21
22RDEPENDS_${PN} += "xserver-xf86-config"
23
23FILES_${PN}-utils = "${bindir}/scanpci ${bindir}/pcitweak ${bindir}/ioport ${bindir}/in[bwl] ${bindir}/out[bwl] ${bindir}/mmap[rw] ${bindir}/gtf ${bindir}/getconfig ${bindir}/getconfig.pl" 24FILES_${PN}-utils = "${bindir}/scanpci ${bindir}/pcitweak ${bindir}/ioport ${bindir}/in[bwl] ${bindir}/out[bwl] ${bindir}/mmap[rw] ${bindir}/gtf ${bindir}/getconfig ${bindir}/getconfig.pl"
24FILES_${PN} = "${libdir}/X11/Options ${libdir}/X11/Cards ${libdir}/X11/getconfig ${libdir}/X11/etc ${libdir}/xserver/SecurityPolicy ${libdir}/xorg/modules/*.so ${libdir}/xorg/modules/*/*.so ${libdir}/xorg/modules/*/*/*.so /etc/X11 " 25FILES_${PN} = "${libdir}/X11/Options ${libdir}/X11/Cards ${libdir}/X11/getconfig ${libdir}/X11/etc ${libdir}/xserver/SecurityPolicy ${libdir}/xorg/modules/*.so ${libdir}/xorg/modules/*/*.so ${libdir}/xorg/modules/*/*/*.so /etc/X11 "
25FILES_${PN}-doc += "${libdir}/X11/doc /usr/share/X11/xkb/compiled/README.compiled" 26FILES_${PN}-doc += "${libdir}/X11/doc /usr/share/X11/xkb/compiled/README.compiled"
@@ -29,13 +30,9 @@ FILES_${PN}-dbg += "${libdir}/xorg/modules/.debug \
29 ${libdir}/xorg/modules/*/*/.debug \ 30 ${libdir}/xorg/modules/*/*/.debug \
30 " 31 "
31 32
32CONFFILES_${PN} += "${sysconfdir}/X11/xorg.conf"
33
34SRC_URI += "file://macro_tweak.patch;patch=1" 33SRC_URI += "file://macro_tweak.patch;patch=1"
35 34
36do_install_append () { 35do_install_append () {
37 install -d ${D}/${sysconfdir}/X11
38 install -m 0644 ${WORKDIR}/xorg.conf ${D}/${sysconfdir}/X11/
39 ln -sf ${datadir}/fonts/X11 ${D}/${libdir}/X11/fonts 36 ln -sf ${datadir}/fonts/X11 ${D}/${libdir}/X11/fonts
40} 37}
41 38
diff --git a/meta/packages/xorg-xserver/xserver-xf86-lite/xorg.conf b/meta/packages/xorg-xserver/xserver-xf86-config/qemux86/xorg.conf
index 44a530e0f9..da7f37cebe 100644
--- a/meta/packages/xorg-xserver/xserver-xf86-lite/xorg.conf
+++ b/meta/packages/xorg-xserver/xserver-xf86-config/qemux86/xorg.conf
@@ -35,16 +35,8 @@ Section "InputDevice"
35 Identifier "stylus" 35 Identifier "stylus"
36 Option "Device" "/dev/input/wacom" 36 Option "Device" "/dev/input/wacom"
37 Option "Type" "stylus" 37 Option "Type" "stylus"
38 Option "ForceDevice" "ISDV4" # Tablet PC ONLY
39EndSection 38EndSection
40 39
41Section "InputDevice"
42 Driver "wacom"
43 Identifier "eraser"
44 Option "Device" "/dev/input/wacom"
45 Option "Type" "eraser"
46 Option "ForceDevice" "ISDV4" # Tablet PC ONLY
47EndSection
48 40
49Section "InputDevice" 41Section "InputDevice"
50 Driver "wacom" 42 Driver "wacom"
@@ -55,9 +47,8 @@ Section "InputDevice"
55EndSection 47EndSection
56 48
57Section "Device" 49Section "Device"
58 Identifier "Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller" 50 Identifier "Graphics Controller"
59 Driver "intel" 51 Driver "vmware"
60 BusID "PCI:0:2:0"
61EndSection 52EndSection
62 53
63Section "Monitor" 54Section "Monitor"
@@ -67,7 +58,7 @@ EndSection
67 58
68Section "Screen" 59Section "Screen"
69 Identifier "Default Screen" 60 Identifier "Default Screen"
70 Device "Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller" 61 Device "Graphics Controller"
71 Monitor "Generic Monitor" 62 Monitor "Generic Monitor"
72 DefaultDepth 24 63 DefaultDepth 24
73EndSection 64EndSection
@@ -79,7 +70,7 @@ Section "ServerLayout"
79 InputDevice "Configured Mouse" 70 InputDevice "Configured Mouse"
80 71
81# Uncomment if you have a wacom tablet 72# Uncomment if you have a wacom tablet
82# InputDevice "stylus" "SendCoreEvents" 73 InputDevice "stylus" "SendCoreEvents"
83# InputDevice "cursor" "SendCoreEvents" 74# InputDevice "cursor" "SendCoreEvents"
84# InputDevice "eraser" "SendCoreEvents" 75# InputDevice "eraser" "SendCoreEvents"
85 InputDevice "Synaptics Touchpad" 76 InputDevice "Synaptics Touchpad"
diff --git a/meta/packages/xorg-xserver/xserver-xf86-dri-lite/xorg.conf b/meta/packages/xorg-xserver/xserver-xf86-config/xorg.conf
index 44a530e0f9..44a530e0f9 100644
--- a/meta/packages/xorg-xserver/xserver-xf86-dri-lite/xorg.conf
+++ b/meta/packages/xorg-xserver/xserver-xf86-config/xorg.conf
diff --git a/meta/packages/xorg-xserver/xserver-xf86-config_0.1.bb b/meta/packages/xorg-xserver/xserver-xf86-config_0.1.bb
new file mode 100644
index 0000000000..db2f199125
--- /dev/null
+++ b/meta/packages/xorg-xserver/xserver-xf86-config_0.1.bb
@@ -0,0 +1,16 @@
1DESCRIPTION = "X.Org X server configuration file"
2HOMEPAGE = "http://www.x.org"
3SECTION = "x11/base"
4LICENSE = "MIT-X"
5
6SRC_URI = "file://xorg.conf"
7
8CONFFILES_${PN} += "${sysconfdir}/X11/xorg.conf"
9
10PACKAGE_ARCH = "${MACHINE_ARCH}"
11
12do_install () {
13 install -d ${D}/${sysconfdir}/X11
14 install -m 0644 ${WORKDIR}/xorg.conf ${D}/${sysconfdir}/X11/
15}
16
diff --git a/meta/packages/xorg-xserver/xserver-xf86-dri-lite_1.6.0.bb b/meta/packages/xorg-xserver/xserver-xf86-dri-lite_1.6.0.bb
index cb23720078..75f990ec41 100644
--- a/meta/packages/xorg-xserver/xserver-xf86-dri-lite_1.6.0.bb
+++ b/meta/packages/xorg-xserver/xserver-xf86-dri-lite_1.6.0.bb
@@ -1,7 +1,7 @@
1require xserver-xf86-dri-lite.inc 1require xserver-xf86-dri-lite.inc
2 2
3PE = "1" 3PE = "1"
4PR = "r0" 4PR = "r1"
5 5
6PROTO_DEPS += "xf86driproto dri2proto" 6PROTO_DEPS += "xf86driproto dri2proto"
7 7
diff --git a/meta/packages/xorg-xserver/xserver-xf86-dri-lite_git.bb b/meta/packages/xorg-xserver/xserver-xf86-dri-lite_git.bb
index 5e08bd5dbd..73ccdd4522 100644
--- a/meta/packages/xorg-xserver/xserver-xf86-dri-lite_git.bb
+++ b/meta/packages/xorg-xserver/xserver-xf86-dri-lite_git.bb
@@ -1,7 +1,7 @@
1require xserver-xf86-dri-lite.inc 1require xserver-xf86-dri-lite.inc
2 2
3PE = "1" 3PE = "1"
4PR = "r4" 4PR = "r5"
5PV = "1.5.99.1+git${SRCREV}" 5PV = "1.5.99.1+git${SRCREV}"
6 6
7PROTO_DEPS += "xf86driproto dri2proto" 7PROTO_DEPS += "xf86driproto dri2proto"