summaryrefslogtreecommitdiffstats
path: root/meta/packages/xorg-driver
diff options
context:
space:
mode:
authorRobert Bragg <bob@openedhand.com>2008-09-22 13:33:19 +0000
committerRobert Bragg <bob@openedhand.com>2008-09-22 13:33:19 +0000
commit3de4627417e62595ce4349cb3a13c9180f8e6bfd (patch)
tree37c5f48d49ce9702fb164ca4fe47433f59cd838a /meta/packages/xorg-driver
parent9b6a24b65d840d8b207a9dfdc69e61b0c5c9ef07 (diff)
downloadpoky-3de4627417e62595ce4349cb3a13c9180f8e6bfd.tar.gz
Adds recipes to support building X servers based on the xfree86 DDX instead
of kdrive and building mesa. It's a big commit and it's still rather rough around the edges, but there is a desire to get this in early so people can review the work and help polish the changes. Some of the notable bits: • DRI support in mesa and the X server. (configured in machine conf via MACHINE_DRI_MODULES variable) • XCB backend for xlib • A fairly lite X server build with lots of legacy modules disabled. I'm sure there is plenty of other fairly low hanging fruit if we want to put more effort into reducing the size of the xserver build. Currently the server build comes in @ ~2.3MB vs a kdrive fbdev server build @ ~1MB. E.g xaa could be made conditional to save ~320K. Of course the kdrive server doesn't include glx stuff, which is a pretty big chunk. Also thanks to hrw, since I nabbed a some patches from him for this, and RP, for various bits of Poky style advice. git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5205 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/xorg-driver')
-rw-r--r--meta/packages/xorg-driver/xf86-driver-common.inc32
-rw-r--r--meta/packages/xorg-driver/xf86-input-common.inc7
-rw-r--r--meta/packages/xorg-driver/xf86-input-evdev_2.0.4.bb4
-rw-r--r--meta/packages/xorg-driver/xf86-input-keyboard_1.3.1.bb4
-rw-r--r--meta/packages/xorg-driver/xf86-input-mouse_1.3.0.bb4
-rw-r--r--meta/packages/xorg-driver/xf86-input-synaptics_0.15.0.bb4
-rw-r--r--meta/packages/xorg-driver/xf86-video-common.inc4
-rw-r--r--meta/packages/xorg-driver/xf86-video-intel_2.4.2.bb5
8 files changed, 64 insertions, 0 deletions
diff --git a/meta/packages/xorg-driver/xf86-driver-common.inc b/meta/packages/xorg-driver/xf86-driver-common.inc
new file mode 100644
index 0000000000..308d06e0b1
--- /dev/null
+++ b/meta/packages/xorg-driver/xf86-driver-common.inc
@@ -0,0 +1,32 @@
1DESCRIPTION = "X driver"
2HOMEPAGE = "http://www.x.org"
3SECTION = "x11/drivers"
4LICENSE = "MIT-X"
5
6PE = "1"
7PR = "r0"
8
9DEPENDS = "virtual/xserver-xf86 xproto randrproto"
10
11XORG_PN = "${PN}"
12SRC_URI = "${XORG_MIRROR}/individual/driver/${XORG_PN}-${PV}.tar.bz2"
13
14S = "${WORKDIR}/${XORG_PN}-${PV}"
15
16FILES_${PN} += " ${libdir}/xorg/modules/drivers/*.so"
17FILES_${PN}-dbg += " ${libdir}/xorg/modules/drivers/.debug"
18
19inherit autotools pkgconfig
20
21do_stage() {
22 autotools_stage_all
23}
24
25# AC_CHECK_FILE doesn't work when cross compiling, so we create a replacement
26# macro that simply assumes the test succeeds.
27do_configure_prepend () {
28 echo 'AC_DEFUN(CC_AC_CHECK_FILE, $2)' > configure.ac.new
29 sed 's/AC_CHECK_FILE/CC_AC_CHECK_FILE/g' configure.ac >> configure.ac.new
30 mv configure.ac.new configure.ac
31}
32
diff --git a/meta/packages/xorg-driver/xf86-input-common.inc b/meta/packages/xorg-driver/xf86-input-common.inc
new file mode 100644
index 0000000000..6fc88cf9d0
--- /dev/null
+++ b/meta/packages/xorg-driver/xf86-input-common.inc
@@ -0,0 +1,7 @@
1include xf86-driver-common.inc
2
3DEPENDS += "inputproto kbproto "
4
5FILES_${PN} += " ${libdir}/xorg/modules/input/*.so"
6FILES_${PN}-dbg += " ${libdir}/xorg/modules/input/.debug"
7
diff --git a/meta/packages/xorg-driver/xf86-input-evdev_2.0.4.bb b/meta/packages/xorg-driver/xf86-input-evdev_2.0.4.bb
new file mode 100644
index 0000000000..d1fb0f000d
--- /dev/null
+++ b/meta/packages/xorg-driver/xf86-input-evdev_2.0.4.bb
@@ -0,0 +1,4 @@
1require xf86-input-common.inc
2
3DESCRIPTION = "X.Org X server -- evdev input driver"
4
diff --git a/meta/packages/xorg-driver/xf86-input-keyboard_1.3.1.bb b/meta/packages/xorg-driver/xf86-input-keyboard_1.3.1.bb
new file mode 100644
index 0000000000..f554141c97
--- /dev/null
+++ b/meta/packages/xorg-driver/xf86-input-keyboard_1.3.1.bb
@@ -0,0 +1,4 @@
1require xf86-input-common.inc
2
3DESCRIPTION = "X.Org X server -- keyboard input driver"
4
diff --git a/meta/packages/xorg-driver/xf86-input-mouse_1.3.0.bb b/meta/packages/xorg-driver/xf86-input-mouse_1.3.0.bb
new file mode 100644
index 0000000000..39c2e05daf
--- /dev/null
+++ b/meta/packages/xorg-driver/xf86-input-mouse_1.3.0.bb
@@ -0,0 +1,4 @@
1require xf86-input-common.inc
2
3DESCRIPTION = "X.Org X server -- mouse input driver"
4
diff --git a/meta/packages/xorg-driver/xf86-input-synaptics_0.15.0.bb b/meta/packages/xorg-driver/xf86-input-synaptics_0.15.0.bb
new file mode 100644
index 0000000000..f554141c97
--- /dev/null
+++ b/meta/packages/xorg-driver/xf86-input-synaptics_0.15.0.bb
@@ -0,0 +1,4 @@
1require xf86-input-common.inc
2
3DESCRIPTION = "X.Org X server -- keyboard input driver"
4
diff --git a/meta/packages/xorg-driver/xf86-video-common.inc b/meta/packages/xorg-driver/xf86-video-common.inc
new file mode 100644
index 0000000000..4bf9c1b3b6
--- /dev/null
+++ b/meta/packages/xorg-driver/xf86-video-common.inc
@@ -0,0 +1,4 @@
1include xf86-driver-common.inc
2
3DEPENDS = "renderproto videoproto xextproto fontsproto"
4
diff --git a/meta/packages/xorg-driver/xf86-video-intel_2.4.2.bb b/meta/packages/xorg-driver/xf86-video-intel_2.4.2.bb
new file mode 100644
index 0000000000..4362baa15f
--- /dev/null
+++ b/meta/packages/xorg-driver/xf86-video-intel_2.4.2.bb
@@ -0,0 +1,5 @@
1require xf86-video-common.inc
2
3DESCRIPTION = "X.Org X server -- Intel i8xx, i9xx display driver"
4DEPENDS += " virtual/libx11 libxvmc drm xf86driproto"
5