summaryrefslogtreecommitdiffstats
path: root/meta/packages/xcb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2008-12-26 19:02:44 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2008-12-30 17:07:04 +0000
commite380b48602db316c7d12d328192eadc52e5be861 (patch)
tree78d1c6d7742c79216b01fb0b739adea44c85dc51 /meta/packages/xcb
parentf9f549d06fd787f93c9c0af607683d0521fcd827 (diff)
downloadpoky-e380b48602db316c7d12d328192eadc52e5be861.tar.gz
classes/autotools_stage.bbclass: Add autotools_stage class to simplify recipes using standard autotools
Diffstat (limited to 'meta/packages/xcb')
-rw-r--r--meta/packages/xcb/libpthread-stubs_0.1.bb6
-rw-r--r--meta/packages/xcb/libxcb.inc6
2 files changed, 2 insertions, 10 deletions
diff --git a/meta/packages/xcb/libpthread-stubs_0.1.bb b/meta/packages/xcb/libpthread-stubs_0.1.bb
index 211170a902..826bff7678 100644
--- a/meta/packages/xcb/libpthread-stubs_0.1.bb
+++ b/meta/packages/xcb/libpthread-stubs_0.1.bb
@@ -11,11 +11,7 @@ PARALLEL_MAKE = ""
11 11
12SRC_URI = "http://xcb.freedesktop.org/dist/libpthread-stubs-${PV}.tar.bz2" 12SRC_URI = "http://xcb.freedesktop.org/dist/libpthread-stubs-${PV}.tar.bz2"
13 13
14inherit autotools pkgconfig 14inherit autotools_stage pkgconfig
15
16do_stage() {
17 autotools_stage_all
18}
19 15
20RDEPENDS_${PN}-dev = "" 16RDEPENDS_${PN}-dev = ""
21RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${DEBPV})" 17RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${DEBPV})"
diff --git a/meta/packages/xcb/libxcb.inc b/meta/packages/xcb/libxcb.inc
index bdce8a2e6b..ee46f598c0 100644
--- a/meta/packages/xcb/libxcb.inc
+++ b/meta/packages/xcb/libxcb.inc
@@ -40,7 +40,7 @@ FILES_libxcb-xtest = "${libdir}/libxcb-xtest.so.*"
40FILES_libxcb-xv = "${libdir}/libxcb-xv.so.*" 40FILES_libxcb-xv = "${libdir}/libxcb-xv.so.*"
41FILES_libxcb-xvmc = "${libdir}/libxcb-xvmc.so.*" 41FILES_libxcb-xvmc = "${libdir}/libxcb-xvmc.so.*"
42 42
43inherit autotools pkgconfig 43inherit autotools_stage pkgconfig
44 44
45# XCBPROTO_XCBINCLUDEDIR is setup based on `pkg-config --variable=xcbincludedir xcb-proto` 45# XCBPROTO_XCBINCLUDEDIR is setup based on `pkg-config --variable=xcbincludedir xcb-proto`
46# but the xcbincludedir variable doesn't point into the staging area, so it needs some 46# but the xcbincludedir variable doesn't point into the staging area, so it needs some
@@ -49,7 +49,3 @@ do_configure_prepend () {
49 sed -i "s|XCBPROTO_XCBINCLUDEDIR=|XCBPROTO_XCBINCLUDEDIR=${STAGING_DIR_HOST}/|" \ 49 sed -i "s|XCBPROTO_XCBINCLUDEDIR=|XCBPROTO_XCBINCLUDEDIR=${STAGING_DIR_HOST}/|" \
50 ${S}/configure.ac 50 ${S}/configure.ac
51} 51}
52
53do_stage() {
54 autotools_stage_all
55}