summaryrefslogtreecommitdiffstats
path: root/meta/packages/vte/files/vte-pkgconfig-fixes.patch
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-03-19 16:38:20 +0000
committerRichard Purdie <richard@openedhand.com>2008-03-19 16:38:20 +0000
commite5694cf1b9eb8b5071a55478fdebc78f947c3047 (patch)
treeb9360ebd864d2c99b83474e915993de4671898ac /meta/packages/vte/files/vte-pkgconfig-fixes.patch
parentdc9026df7f693fc41e37cf265c73a8c3dbe7df57 (diff)
downloadpoky-e5694cf1b9eb8b5071a55478fdebc78f947c3047.tar.gz
vte: Merge from OE.dev, upgrade to 0.16.9 with fixes
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4070 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/vte/files/vte-pkgconfig-fixes.patch')
-rw-r--r--meta/packages/vte/files/vte-pkgconfig-fixes.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/packages/vte/files/vte-pkgconfig-fixes.patch b/meta/packages/vte/files/vte-pkgconfig-fixes.patch
new file mode 100644
index 0000000000..2acc7348e7
--- /dev/null
+++ b/meta/packages/vte/files/vte-pkgconfig-fixes.patch
@@ -0,0 +1,47 @@
1Index: vte-0.16.9/configure.in
2===================================================================
3--- vte-0.16.9.orig/configure.in 2007-09-17 23:07:18.000000000 +0100
4+++ vte-0.16.9/configure.in 2008-03-05 15:59:04.000000000 +0000
5@@ -381,8 +381,6 @@
6
7 # Search for the required modules.
8 PKG_CHECK_MODULES(VTE,[$wantedmodules])
9-NEEDEDPACKAGES="$wantedmodules"
10-AC_SUBST(NEEDEDPACKAGES)
11
12 # Check for various optional functions within those modules
13 save_CFLAGS="$CFLAGS"
14@@ -403,10 +401,12 @@
15
16 # Require Freetype2. First see if there is suitable pkgconfig file...
17 PKG_CHECK_EXISTS(freetype2 >= 6.1.0,
18- [PKG_CHECK_MODULES(FT2, freetype2)], [
19+ [PKG_CHECK_MODULES(FT2, freetype2)
20+ wantedmodules="$wantedmodules freetype2 >= 6.1.0"], [
21 # We use our local copy of the macro because packages of
22 # freetype's development files don't always include the proper macro.
23- VTE_CHECK_FT2(6.1.0,,
24+ VTE_CHECK_FT2(6.1.0,[
25+ wantedmodules="$wantedmodules freetype2 >= 6.1.0" ],
26 [AC_MSG_ERROR([You must have freetype 2.0.2 or later to build vte.])])])
27
28 # Temporarily pull in the Freetype cflags and libs for checking what's
29@@ -508,6 +508,8 @@
30 CFLAGS="$savecflags"
31 CPPFLAGS="$savecppflags"
32
33+NEEDEDPACKAGES="$wantedmodules"
34+AC_SUBST(NEEDEDPACKAGES)
35
36 wcs_funcs_includes="
37 #ifdef HAVE_STRING_H
38Index: vte-0.16.9/vte.pc.in
39===================================================================
40--- vte-0.16.9.orig/vte.pc.in 2007-02-26 21:05:19.000000000 +0000
41+++ vte-0.16.9/vte.pc.in 2008-03-05 15:56:37.000000000 +0000
42@@ -11,4 +11,4 @@
43 Requires: @NEEDEDPACKAGES@
44 Libs: -L${libdir} -lvte @OTHERLIBS@
45 Libs.private: @FT2_LIBS@
46-Cflags: -I${includedir} @FT2_CFLAGS@ @OTHERCFLAGS@
47+Cflags: -I${includedir} @OTHERCFLAGS@