summaryrefslogtreecommitdiffstats
path: root/meta/packages/uboot
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-11-17 21:49:29 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2009-11-17 21:49:29 +0000
commitc5f2ff91f6fa929c12315b773421cd13b26fbb34 (patch)
treed1bca24d5915c39e4d1a5869df457534e73282fc /meta/packages/uboot
parentb36dcf3a484000d6239d3b4f15a27768676fa373 (diff)
downloadpoky-c5f2ff91f6fa929c12315b773421cd13b26fbb34.tar.gz
u-boot-mkimage-native: Convert to use do_install for staging
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/uboot')
-rw-r--r--meta/packages/uboot/u-boot-mkimage-native_1.3.2.bb12
1 files changed, 7 insertions, 5 deletions
diff --git a/meta/packages/uboot/u-boot-mkimage-native_1.3.2.bb b/meta/packages/uboot/u-boot-mkimage-native_1.3.2.bb
index 38dd700d08..6922d69e07 100644
--- a/meta/packages/uboot/u-boot-mkimage-native_1.3.2.bb
+++ b/meta/packages/uboot/u-boot-mkimage-native_1.3.2.bb
@@ -12,11 +12,13 @@ inherit native
12EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}" 12EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
13 13
14do_compile () { 14do_compile () {
15 oe_runmake smdk2410_config 15 oe_runmake smdk2410_config
16 oe_runmake tools 16 oe_runmake tools
17} 17}
18 18
19do_stage () { 19NATIVE_INSTALL_WORKS = "1"
20 install -m 0755 tools/mkimage ${STAGING_BINDIR_NATIVE}/uboot-mkimage 20do_install () {
21 ln -sf ${STAGING_BINDIR_NATIVE}/uboot-mkimage ${STAGING_BINDIR_NATIVE}/mkimage 21 install -d ${D}${bindir}/
22 install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
23 ln -sf uboot-mkimage ${D}${bindir}/mkimage
22} 24}