summaryrefslogtreecommitdiffstats
path: root/meta/packages/telepathy
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2007-05-29 14:24:48 +0000
committerRoss Burton <ross@openedhand.com>2007-05-29 14:24:48 +0000
commit8ca3683347ebd30b2cf4ba46c85e23692668fe1a (patch)
tree940caa19e3b87cfa6b55f618074024dee0041e72 /meta/packages/telepathy
parent6c11258fb540b1e3f3dba8c9bb0ba18d85d23fe9 (diff)
downloadpoky-8ca3683347ebd30b2cf4ba46c85e23692668fe1a.tar.gz
Add gnome-vfs depends, update icon cache
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1807 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/telepathy')
-rw-r--r--meta/packages/telepathy/empathy-0.5/no-gnome.diff29
-rw-r--r--meta/packages/telepathy/empathy_0.5.bb9
2 files changed, 25 insertions, 13 deletions
diff --git a/meta/packages/telepathy/empathy-0.5/no-gnome.diff b/meta/packages/telepathy/empathy-0.5/no-gnome.diff
index 3246c8789d..29d6276f51 100644
--- a/meta/packages/telepathy/empathy-0.5/no-gnome.diff
+++ b/meta/packages/telepathy/empathy-0.5/no-gnome.diff
@@ -2,23 +2,35 @@ Index: libempathy-gtk/gossip-ui-utils.c
2=================================================================== 2===================================================================
3--- libempathy-gtk/gossip-ui-utils.c (revision 99) 3--- libempathy-gtk/gossip-ui-utils.c (revision 99)
4+++ libempathy-gtk/gossip-ui-utils.c (working copy) 4+++ libempathy-gtk/gossip-ui-utils.c (working copy)
5@@ -33,7 +33,6 @@ 5@@ -33,7 +33,7 @@
6 #include <glib/gi18n.h> 6 #include <glib/gi18n.h>
7 #include <gtk/gtk.h> 7 #include <gtk/gtk.h>
8 #include <glade/glade.h> 8 #include <glade/glade.h>
9-#include <libgnome/libgnome.h> 9-#include <libgnome/libgnome.h>
10+#include <libgnomevfs/gnome-vfs-utils.h>
10 11
11 #include <libmissioncontrol/mc-profile.h> 12 #include <libmissioncontrol/mc-profile.h>
12 13
13@@ -1283,7 +1282,7 @@ 14@@ -1280,13 +1280,14 @@
14 GError *error = NULL; 15 gossip_url_show (const char *url)
16 {
17 gchar *real_url;
18- GError *error = NULL;
19+ GnomeVFSResult res;
15 20
16 real_url = fixup_url (url); 21 real_url = fixup_url (url);
17- gnome_url_show (real_url, &error); 22- gnome_url_show (real_url, &error);
18+ g_warning ("TODO: gnome_url_show (real_url, &error);"); 23- if (error) {
19 if (error) { 24- g_warning ("Couldn't show URL:'%s'", real_url);
20 g_warning ("Couldn't show URL:'%s'", real_url); 25- g_error_free (error);
21 g_error_free (error); 26+ res = gnome_vfs_url_show (real_url);
27+ if (res != GNOME_VFS_OK) {
28+ g_warning ("Couldn't show URL %s: %s",
29+ real_url,
30+ gnome_vfs_result_to_string (res));
31 }
32
33 g_free (real_url);
22Index: src/empathy-chat-main.c 34Index: src/empathy-chat-main.c
23=================================================================== 35===================================================================
24--- src/empathy-chat-main.c (revision 99) 36--- src/empathy-chat-main.c (revision 99)
@@ -117,7 +129,7 @@ Index: configure.ac
117=================================================================== 129===================================================================
118--- configure.ac (revision 99) 130--- configure.ac (revision 99)
119+++ configure.ac (working copy) 131+++ configure.ac (working copy)
120@@ -62,12 +62,12 @@ 132@@ -62,12 +62,13 @@
121 133
122 PKG_CHECK_MODULES(EMPATHY, 134 PKG_CHECK_MODULES(EMPATHY,
123 [ 135 [
@@ -128,6 +140,7 @@ Index: configure.ac
128 gconf-2.0 >= $GCONF_REQUIRED 140 gconf-2.0 >= $GCONF_REQUIRED
129 libglade-2.0 >= $LIBGLADE_REQUIRED 141 libglade-2.0 >= $LIBGLADE_REQUIRED
130- libgnomeui-2.0 142- libgnomeui-2.0
143+ gnome-vfs-2.0
131 libtelepathy >= $TELEPATHY_REQUIRED 144 libtelepathy >= $TELEPATHY_REQUIRED
132 libmissioncontrol >= $MISSION_CONTROL_REQUIRED 145 libmissioncontrol >= $MISSION_CONTROL_REQUIRED
133 ]) 146 ])
diff --git a/meta/packages/telepathy/empathy_0.5.bb b/meta/packages/telepathy/empathy_0.5.bb
index 99a7873185..a9578bea30 100644
--- a/meta/packages/telepathy/empathy_0.5.bb
+++ b/meta/packages/telepathy/empathy_0.5.bb
@@ -1,18 +1,17 @@
1DESCRIPTION = "Empathy: a Telepathy based IM client" 1DESCRIPTION = "Empathy: a Telepathy based IM client"
2HOMEPAGE = "http://blogs.gnome.org/view/xclaesse/2007/04/26/0" 2HOMEPAGE = "http://blogs.gnome.org/view/xclaesse/2007/04/26/0"
3LICENSE = "GPL" 3LICENSE = "GPL"
4DEPENDS = "telepathy-mission-control libtelepathy gtk+ gconf libglade" 4DEPENDS = "telepathy-mission-control libtelepathy gtk+ gconf libglade gnome-vfs"
5RDEPENDS = "telepathy-mission-control" 5RDEPENDS = "telepathy-mission-control"
6RRECOMMENDS = "telepathy-gabble" 6RRECOMMENDS = "telepathy-gabble"
7 7
8PR="r0" 8PR="r1"
9 9
10inherit gnome 10inherit gnome gtk-icon-cache
11 11
12SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/empathy/0.5/empathy-${PV}.tar.bz2 \ 12SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/empathy/0.5/empathy-${PV}.tar.bz2 \
13 file://no-gnome.diff;patch=1;pnum=0" 13 file://no-gnome.diff;patch=1;pnum=0"
14 14
15FILES_${PN} += "${datadir}/mission-control/profiles/*.profile \ 15FILES_${PN} += "${datadir}/mission-control/profiles/*.profile \
16 ${datadir}/dbus-1/services/*.service \ 16 ${datadir}/dbus-1/services/*.service \
17 ${datadir}/telepathy/managers/*.chandler \ 17 ${datadir}/telepathy/managers/*.chandler"
18 ${datadir}/icons"