summaryrefslogtreecommitdiffstats
path: root/meta/packages/telepathy
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2007-04-27 16:22:57 +0000
committerRoss Burton <ross@openedhand.com>2007-04-27 16:22:57 +0000
commit11185b17df6964ddf4ccb6e89095e19c175f2462 (patch)
treeb30c698349b88d0d019c596b14bea7050dfc086a /meta/packages/telepathy
parentc1d676e52de9ec31887191c42a843ce6b146cf32 (diff)
downloadpoky-11185b17df6964ddf4ccb6e89095e19c175f2462.tar.gz
Add Empathy
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1576 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/telepathy')
-rw-r--r--meta/packages/telepathy/empathy-0.1/no-gnome.diff39
-rw-r--r--meta/packages/telepathy/empathy_0.1.bb13
2 files changed, 52 insertions, 0 deletions
diff --git a/meta/packages/telepathy/empathy-0.1/no-gnome.diff b/meta/packages/telepathy/empathy-0.1/no-gnome.diff
new file mode 100644
index 0000000000..4dd4a96354
--- /dev/null
+++ b/meta/packages/telepathy/empathy-0.1/no-gnome.diff
@@ -0,0 +1,39 @@
1diff -ur empathy-0.1.orig/configure.ac empathy-0.1/configure.ac
2--- empathy-0.1.orig/configure.ac 2007-04-25 23:05:40.000000000 +0100
3+++ empathy-0.1/configure.ac 2007-04-27 17:10:29.000000000 +0100
4@@ -39,12 +39,12 @@
5
6 PKG_CHECK_MODULES(EMPATHY,
7 [
8+ libxml-2.0
9 glib-2.0 >= $GLIB_REQUIRED
10 gobject-2.0
11 gtk+-2.0 >= $GTK_REQUIRED
12 gconf-2.0 >= $GCONF_REQUIRED
13 libglade-2.0 >= $LIBGLADE_REQUIRED
14- libgnomeui-2.0
15 libtelepathy >= $TELEPATHY_REQUIRED
16 libmissioncontrol >= $MISSION_CONTROL_REQUIRED
17 ])
18Only in empathy-0.1: configure.ac~
19diff -ur empathy-0.1.orig/libempathy-gtk/gossip-ui-utils.c empathy-0.1/libempathy-gtk/gossip-ui-utils.c
20--- empathy-0.1.orig/libempathy-gtk/gossip-ui-utils.c 2007-04-25 23:05:40.000000000 +0100
21+++ empathy-0.1/libempathy-gtk/gossip-ui-utils.c 2007-04-27 17:06:48.000000000 +0100
22@@ -31,7 +31,6 @@
23 #include <glib/gi18n.h>
24 #include <gtk/gtk.h>
25 #include <glade/glade.h>
26-#include <libgnome/libgnome.h>
27
28 #include <libmissioncontrol/mc-profile.h>
29
30@@ -1307,7 +1306,7 @@
31 GError *error = NULL;
32
33 real_url = fixup_url (url);
34- gnome_url_show (real_url, &error);
35+ g_warning ("TODO: gnome_url_show (real_url, &error);");
36 if (error) {
37 g_warning ("Couldn't show URL:'%s'", real_url);
38 g_error_free (error);
39Only in empathy-0.1/libempathy-gtk: gossip-ui-utils.c~
diff --git a/meta/packages/telepathy/empathy_0.1.bb b/meta/packages/telepathy/empathy_0.1.bb
new file mode 100644
index 0000000000..2a6b94a758
--- /dev/null
+++ b/meta/packages/telepathy/empathy_0.1.bb
@@ -0,0 +1,13 @@
1DESCRIPTION = "Empathy: a Telepathy based IM client"
2HOMEPAGE = "http://blogs.gnome.org/view/xclaesse/2007/04/26/0"
3LICENSE = "GPL"
4DEPENDS = "telepathy-mission-control libtelepathy gtk+ gconf libglade"
5
6SRC_URI = "http://projects.collabora.co.uk/~xclaesse/empathy-0.1.tar.gz \
7 file://no-gnome.diff;patch=1"
8
9inherit autotools pkgconfig
10
11FILES_${PN} += "/usr/share/mission-control/profiles/*.profile \
12 /usr/share/dbus-1/services/*.service \
13 /usr/share/telepathy/managers/*.chandler"