summaryrefslogtreecommitdiffstats
path: root/meta/packages/tasks
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-12-20 00:00:03 +0000
committerRichard Purdie <richard@openedhand.com>2006-12-20 00:00:03 +0000
commitf5b38f9db0cebb0c7c9d9d72fa98a4ff5241db20 (patch)
tree337089b8ad5015b9485099a263763c0c72cd3a99 /meta/packages/tasks
parent50bbb7742c760360d1003e441e2a029bee3035df (diff)
downloadpoky-f5b38f9db0cebb0c7c9d9d72fa98a4ff5241db20.tar.gz
Remove DISTRO_TYPE, replacing with IMAGE_FEATURES. Documentation is in local.conf.sample
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1053 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/tasks')
-rw-r--r--meta/packages/tasks/task-oh-sdk.bb89
-rw-r--r--meta/packages/tasks/task-oh.bb21
2 files changed, 63 insertions, 47 deletions
diff --git a/meta/packages/tasks/task-oh-sdk.bb b/meta/packages/tasks/task-oh-sdk.bb
index a142816306..ac3aaec746 100644
--- a/meta/packages/tasks/task-oh-sdk.bb
+++ b/meta/packages/tasks/task-oh-sdk.bb
@@ -1,10 +1,13 @@
1DESCRIPTON = "Software Development Tasks for OpenedHand Poky" 1DESCRIPTON = "Software Development Tasks for OpenedHand Poky"
2PR = "r11" 2PR = "r12"
3DEPENDS = "task-oh" 3DEPENDS = "task-oh"
4ALLOW_EMPTY = "1" 4ALLOW_EMPTY = "1"
5PACKAGEFUNCS =+ 'generate_sdk_pkgs' 5#PACKAGEFUNCS =+ 'generate_sdk_pkgs'
6 6
7PACKAGES = "task-oh-sdk" 7PACKAGES = "\
8 task-oh-sdk \
9 task-oh-sdk-dbg \
10 task-oh-sdk-dev"
8 11
9RDEPENDS_task-oh-sdk = "\ 12RDEPENDS_task-oh-sdk = "\
10 autoconf \ 13 autoconf \
@@ -19,43 +22,43 @@ RDEPENDS_task-oh-sdk = "\
19 pkgconfig \ 22 pkgconfig \
20 distcc" 23 distcc"
21 24
22python generate_sdk_pkgs () { 25#python generate_sdk_pkgs () {
23 ohpkgs = read_pkgdata('task-oh', d)['PACKAGES'] 26# ohpkgs = read_pkgdata('task-oh', d)['PACKAGES']
24 pkgs = bb.data.getVar('PACKAGES', d, 1).split() 27# pkgs = bb.data.getVar('PACKAGES', d, 1).split()
25 for pkg in ohpkgs.split(): 28# for pkg in ohpkgs.split():
26 newpkg = pkg.replace('task-oh', 'task-oh-sdk') 29# newpkg = pkg.replace('task-oh', 'task-oh-sdk')
27 30#
28 # for each of the task packages, add a corresponding sdk task 31# # for each of the task packages, add a corresponding sdk task
29 pkgs.append(newpkg) 32# pkgs.append(newpkg)
30 33#
31 # for each sdk task, take the rdepends of the non-sdk task, and turn 34# # for each sdk task, take the rdepends of the non-sdk task, and turn
32 # that into rrecommends upon the -dev versions of those, not unlike 35# # that into rrecommends upon the -dev versions of those, not unlike
33 # the package depchain code 36# # the package depchain code
34 spkgdata = read_subpkgdata(pkg, d) 37# spkgdata = read_subpkgdata(pkg, d)
35 38#
36 rdepends = explode_deps(spkgdata.get('RDEPENDS_%s' % pkg) or '') 39# rdepends = explode_deps(spkgdata.get('RDEPENDS_%s' % pkg) or '')
37 rreclist = [] 40# rreclist = []
38 41#
39 for depend in rdepends: 42# for depend in rdepends:
40 split_depend = depend.split(' (') 43# split_depend = depend.split(' (')
41 name = split_depend[0].strip() 44# name = split_depend[0].strip()
42 if packaged('%s-dev' % name, d): 45# if packaged('%s-dev' % name, d):
43 rreclist.append('%s-dev' % name) 46# rreclist.append('%s-dev' % name)
44 else: 47# else:
45 deppkgdata = read_subpkgdata(name, d) 48# deppkgdata = read_subpkgdata(name, d)
46 rdepends2 = explode_deps(deppkgdata.get('RDEPENDS_%s' % name) or '') 49# rdepends2 = explode_deps(deppkgdata.get('RDEPENDS_%s' % name) or '')
47 for depend in rdepends2: 50# for depend in rdepends2:
48 split_depend = depend.split(' (') 51# split_depend = depend.split(' (')
49 name = split_depend[0].strip() 52# name = split_depend[0].strip()
50 if packaged('%s-dev' % name, d): 53# if packaged('%s-dev' % name, d):
51 rreclist.append('%s-dev' % name) 54# rreclist.append('%s-dev' % name)
52 55#
53 oldrrec = bb.data.getVar('RRECOMMENDS_%s' % newpkg, d) or '' 56# oldrrec = bb.data.getVar('RRECOMMENDS_%s' % newpkg, d) or ''
54 bb.data.setVar('RRECOMMENDS_%s' % newpkg, oldrrec + ' ' + ' '.join(rreclist), d) 57# bb.data.setVar('RRECOMMENDS_%s' % newpkg, oldrrec + ' ' + ' '.join(rreclist), d)
55 # bb.note('RRECOMMENDS_%s = "%s"' % (newpkg, bb.data.getVar('RRECOMMENDS_%s' % newpkg, d))) 58# # bb.note('RRECOMMENDS_%s = "%s"' % (newpkg, bb.data.getVar('RRECOMMENDS_%s' % newpkg, d)))
56 59#
57 # bb.note('pkgs is %s' % pkgs) 60# # bb.note('pkgs is %s' % pkgs)
58 bb.data.setVar('PACKAGES', ' '.join(pkgs), d) 61# bb.data.setVar('PACKAGES', ' '.join(pkgs), d)
59} 62#}
60 63#
61PACKAGES_DYNAMIC = "task-oh-sdk-*" 64#PACKAGES_DYNAMIC = "task-oh-sdk-*"
diff --git a/meta/packages/tasks/task-oh.bb b/meta/packages/tasks/task-oh.bb
index d7f9b055a1..5b9ce8ce81 100644
--- a/meta/packages/tasks/task-oh.bb
+++ b/meta/packages/tasks/task-oh.bb
@@ -1,14 +1,28 @@
1DESCRIPTION = "Tasks for OpenedHand Poky" 1pDESCRIPTION = "Tasks for OpenedHand Poky"
2PR = "r43" 2PR = "r44"
3 3
4PACKAGES = "\ 4PACKAGES = "\
5 task-oh-base \ 5 task-oh-base \
6 task-oh-base-dbg \
7 task-oh-base-dev \
6 task-oh-boot \ 8 task-oh-boot \
9 task-oh-boot-dbg \
10 task-oh-boot-dev \
7 task-oh-standard \ 11 task-oh-standard \
12 task-oh-standard-dbg \
13 task-oh-standard-dev \
8 task-oh-boot-extras \ 14 task-oh-boot-extras \
15 task-oh-boot-extras-dbg \
16 task-oh-boot-extras-dev \
9 task-oh-boot-min-extras \ 17 task-oh-boot-min-extras \
18 task-oh-boot-min-extras-dbg \
19 task-oh-boot-min-extras-dev \
10 task-oh-devtools \ 20 task-oh-devtools \
11 task-oh-testapps" 21 task-oh-devtools-dbg \
22 task-oh-devtools-dev \
23 task-oh-testapps \
24 task-oh-testapps-dbg \
25 task-oh-testapps-dev"
12 26
13XSERVER ?= "xserver-kdrive-fbdev" 27XSERVER ?= "xserver-kdrive-fbdev"
14 28
@@ -29,7 +43,6 @@ RDEPENDS_task-oh-boot = "\
29 ipkg \ 43 ipkg \
30 update-alternatives \ 44 update-alternatives \
31 module-init-tools-depmod" 45 module-init-tools-depmod"
32# linux-hotplug \
33 46
34RDEPENDS_task-oh-boot-extras = "\ 47RDEPENDS_task-oh-boot-extras = "\
35 task-base" 48 task-base"