summaryrefslogtreecommitdiffstats
path: root/meta/packages/syslinux
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-10-20 11:58:05 +0000
committerRichard Purdie <richard@openedhand.com>2008-10-20 11:58:05 +0000
commit22170fe71182c7da0ae14fb3101be1c474753c64 (patch)
treea8385e332aa47103dfcc095d4662741a3a8c7cbf /meta/packages/syslinux
parentf105cdc88a735b6e0a0b1b0c5a0bd3931a5ad9c3 (diff)
downloadpoky-22170fe71182c7da0ae14fb3101be1c474753c64.tar.gz
syslinux: Various cleanups and add back some missing staging pieces
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5542 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/syslinux')
-rw-r--r--meta/packages/syslinux/syslinux-installer-native_3.36.bb11
-rw-r--r--meta/packages/syslinux/syslinux_3.36.bb29
2 files changed, 28 insertions, 12 deletions
diff --git a/meta/packages/syslinux/syslinux-installer-native_3.36.bb b/meta/packages/syslinux/syslinux-installer-native_3.36.bb
index ae5b73afac..88bc37a1d3 100644
--- a/meta/packages/syslinux/syslinux-installer-native_3.36.bb
+++ b/meta/packages/syslinux/syslinux-installer-native_3.36.bb
@@ -1,14 +1,13 @@
1# syslinux-native OE build file
2# Copyright (C) 2004-2006, Advanced Micro Devices, Inc. All Rights Reserved 1# Copyright (C) 2004-2006, Advanced Micro Devices, Inc. All Rights Reserved
3# Released under the MIT license (see packages/COPYING) 2# Released under the MIT license (see packages/COPYING)
4 3
5DESCRIPTION="A multi-purpose linux bootloader" 4DESCRIPTION = "A multi-purpose linux bootloader"
6HOMEPAGE="http://syslinux.zytor.com/" 5HOMEPAGE = "http://syslinux.zytor.com/"
7LICENSE="GPL" 6LICENSE = "GPL"
8SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/boot/syslinux/syslinux-${PV}.tar.bz2 " 7SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/boot/syslinux/syslinux-${PV}.tar.bz2 "
9 8
10S="${WORKDIR}/syslinux-${PV}" 9S = "${WORKDIR}/syslinux-${PV}"
11STAGE_TEMP="${WORKDIR}/stage_temp" 10STAGE_TEMP = "${WORKDIR}/stage_temp"
12 11
13inherit native 12inherit native
14 13
diff --git a/meta/packages/syslinux/syslinux_3.36.bb b/meta/packages/syslinux/syslinux_3.36.bb
index 4458c1f234..42880f4076 100644
--- a/meta/packages/syslinux/syslinux_3.36.bb
+++ b/meta/packages/syslinux/syslinux_3.36.bb
@@ -1,14 +1,31 @@
1DESCRIPTION="A multi-purpose linux bootloader" 1DESCRIPTION = "A multi-purpose linux bootloader"
2HOMEPAGE="http://syslinux.zytor.com/" 2HOMEPAGE = "http://syslinux.zytor.com/"
3LICENSE="GPL" 3LICENSE = "GPL"
4SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/boot/syslinux/syslinux-${PV}.tar.bz2 " 4SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/boot/syslinux/syslinux-${PV}.tar.bz2"
5PR = "r1"
5 6
6# If you really want to run syslinux, you need mtools. We just want the 7# If you really want to run syslinux, you need mtools. We just want the
7# ldlinux.* stuff for now, so skip mtools-native 8# ldlinux.* stuff for now, so skip mtools-native
8DEPENDS="nasm-native" 9DEPENDS = "nasm-native"
9 10
10S="${WORKDIR}/syslinux-${PV}" 11S = "${WORKDIR}/syslinux-${PV}"
11 12
12do_configure() { 13do_configure() {
13 sed -i ${S}/Makefile ${S}/*/Makefile -e 's/\(CC[\t ]*\)=/\1?=/' 14 sed -i ${S}/Makefile ${S}/*/Makefile -e 's/\(CC[\t ]*\)=/\1?=/'
14} 15}
16
17STAGE_TEMP = "${WORKDIR}/stage_temp"
18
19do_stage() {
20 install -d ${STAGE_TEMP}
21 oe_runmake install INSTALLROOT="${STAGE_TEMP}"
22
23 # When building media, the syslinux binary isn't nearly as useful
24 # as the DOS data files, so we copy those into a special location
25 # for usage during a image build stage
26
27 install -d ${STAGING_DATADIR}/syslinux
28 install -m 0644 ${STAGE_TEMP}/usr/lib/syslinux/isolinux.bin ${STAGING_DATADIR}/syslinux/isolinux.bin
29 install -m 644 ${S}/ldlinux.sys ${STAGING_DATADIR}/syslinux/ldlinux.sys
30 install -m 644 ${S}/ldlinux.bss ${STAGING_DATADIR}/syslinux/ldlinux.bss
31}