summaryrefslogtreecommitdiffstats
path: root/meta/packages/syslinux/syslinux_3.36.bb
diff options
context:
space:
mode:
authorAndrzej Zaborowski <andrew@openedhand.com>2008-10-20 00:22:07 +0000
committerAndrzej Zaborowski <andrew@openedhand.com>2008-10-20 00:22:07 +0000
commit3f93ed6bce12da9ece86e3f965e4e667b22fb306 (patch)
tree3d059c6ebe00f5d19590c4e660696dfc7c0964bd /meta/packages/syslinux/syslinux_3.36.bb
parent4cb659823ba8f8631d623a870695c79ba352a6ad (diff)
downloadpoky-3f93ed6bce12da9ece86e3f965e4e667b22fb306.tar.gz
syslinux-native: Try to make syslinux cross-compile friendly.
We only had one package for building both the bootloader and the installer, i.e. target and host code. It used always the host compiler. Split the package into syslinux and syslinux-installer-native, require both for a cd bootable image. git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5539 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/syslinux/syslinux_3.36.bb')
-rw-r--r--meta/packages/syslinux/syslinux_3.36.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta/packages/syslinux/syslinux_3.36.bb b/meta/packages/syslinux/syslinux_3.36.bb
new file mode 100644
index 0000000000..4458c1f234
--- /dev/null
+++ b/meta/packages/syslinux/syslinux_3.36.bb
@@ -0,0 +1,14 @@
1DESCRIPTION="A multi-purpose linux bootloader"
2HOMEPAGE="http://syslinux.zytor.com/"
3LICENSE="GPL"
4SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/boot/syslinux/syslinux-${PV}.tar.bz2 "
5
6# If you really want to run syslinux, you need mtools. We just want the
7# ldlinux.* stuff for now, so skip mtools-native
8DEPENDS="nasm-native"
9
10S="${WORKDIR}/syslinux-${PV}"
11
12do_configure() {
13 sed -i ${S}/Makefile ${S}/*/Makefile -e 's/\(CC[\t ]*\)=/\1?=/'
14}