summaryrefslogtreecommitdiffstats
path: root/meta/packages/syslinux/syslinux-installer-native_3.36.bb
diff options
context:
space:
mode:
authorAndrzej Zaborowski <andrew@openedhand.com>2008-10-20 00:22:07 +0000
committerAndrzej Zaborowski <andrew@openedhand.com>2008-10-20 00:22:07 +0000
commit3f93ed6bce12da9ece86e3f965e4e667b22fb306 (patch)
tree3d059c6ebe00f5d19590c4e660696dfc7c0964bd /meta/packages/syslinux/syslinux-installer-native_3.36.bb
parent4cb659823ba8f8631d623a870695c79ba352a6ad (diff)
downloadpoky-3f93ed6bce12da9ece86e3f965e4e667b22fb306.tar.gz
syslinux-native: Try to make syslinux cross-compile friendly.
We only had one package for building both the bootloader and the installer, i.e. target and host code. It used always the host compiler. Split the package into syslinux and syslinux-installer-native, require both for a cd bootable image. git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5539 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/syslinux/syslinux-installer-native_3.36.bb')
-rw-r--r--meta/packages/syslinux/syslinux-installer-native_3.36.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/packages/syslinux/syslinux-installer-native_3.36.bb b/meta/packages/syslinux/syslinux-installer-native_3.36.bb
new file mode 100644
index 0000000000..ae5b73afac
--- /dev/null
+++ b/meta/packages/syslinux/syslinux-installer-native_3.36.bb
@@ -0,0 +1,26 @@
1# syslinux-native OE build file
2# Copyright (C) 2004-2006, Advanced Micro Devices, Inc. All Rights Reserved
3# Released under the MIT license (see packages/COPYING)
4
5DESCRIPTION="A multi-purpose linux bootloader"
6HOMEPAGE="http://syslinux.zytor.com/"
7LICENSE="GPL"
8SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/boot/syslinux/syslinux-${PV}.tar.bz2 "
9
10S="${WORKDIR}/syslinux-${PV}"
11STAGE_TEMP="${WORKDIR}/stage_temp"
12
13inherit native
14
15do_compile() {
16 oe_runmake installer
17}
18
19do_stage() {
20 install -d ${STAGE_TEMP}
21 oe_runmake install INSTALLROOT="${STAGE_TEMP}"
22
23 install -d ${STAGING_BINDIR}
24 install -m 755 ${STAGE_TEMP}/usr/bin/syslinux ${STAGING_BINDIR}
25 install -m 755 ${STAGE_TEMP}/sbin/extlinux ${STAGING_BINDIR}
26}