summaryrefslogtreecommitdiffstats
path: root/meta/packages/strace
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-10-25 12:25:37 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-10-25 12:25:37 +0000
commitcb773ee9f65cc48f7b91d318b63c8bb29e6b68bd (patch)
tree22fc87ade27f67c6575627e9935363a3b7ff1626 /meta/packages/strace
parent706f9a34c531111d1af2e760355f1159f3687166 (diff)
downloadpoky-cb773ee9f65cc48f7b91d318b63c8bb29e6b68bd.tar.gz
strace: Apply patch from uclibc buildroot to fix compilation uclibc (sync with OE)
Without that patch the uclibc EABI build fails. Patch was taken from the buildroot of uclibc. git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2961 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/strace')
-rw-r--r--meta/packages/strace/strace/strace-undef-syscall.patch66
-rw-r--r--meta/packages/strace/strace_4.5.14.bb3
2 files changed, 68 insertions, 1 deletions
diff --git a/meta/packages/strace/strace/strace-undef-syscall.patch b/meta/packages/strace/strace/strace-undef-syscall.patch
new file mode 100644
index 0000000000..95166ea18a
--- /dev/null
+++ b/meta/packages/strace/strace/strace-undef-syscall.patch
@@ -0,0 +1,66 @@
1Origin is http://buildroot.uclibc.org/cgi-bin/viewcvs.cgi/*checkout*/trunk/buildroot/package/strace/strace-undef-syscall.patch?rev=17767
2
3This gets applied to fix build errors with uclibc on ARM EABI
4
5--- strace-4.5.12/linux/syscallent.h.orig 2005-08-09 01:48:54.000000000 -0600
6+++ strace-4.5.12/linux/syscallent.h 2005-08-09 01:50:23.000000000 -0600
7@@ -298,7 +298,11 @@
8 { 3, 0, sys_io_cancel, "io_cancel" }, /* 249 */
9 { 5, TF, sys_fadvise64, "fadvise64" }, /* 250 */
10 { 5, 0, printargs, "SYS_251" }, /* 251 */
11- { 1, TP, sys_exit, "exit_group", __NR_exit_group }, /* 252 */
12+ { 1, TP, sys_exit, "exit_group"
13+#ifdef __NR_exit_group
14+ , __NR_exit_group
15+#endif
16+ }, /* 252 */
17 { 4, 0, printargs, "lookup_dcookie"}, /* 253 */
18 { 1, 0, sys_epoll_create, "epoll_create" }, /* 254 */
19 { 4, 0, sys_epoll_ctl, "epoll_ctl" }, /* 255 */
20--- strace-4.5.15.orig/linux/syscallent.h 2007-02-04 19:03:48.000000000 +0100
21+++ strace-4.5.15/linux/syscallent.h 2007-02-04 19:11:04.000000000 +0100
22@@ -130,7 +130,10 @@
23 { 2, TF, sys_statfs, "statfs" }, /* 99 */
24 { 2, TD, sys_fstatfs, "fstatfs" }, /* 100 */
25 { 3, 0, sys_ioperm, "ioperm" }, /* 101 */
26- { 2, TD, sys_socketcall, "socketcall", SYS_socketcall }, /* 102 */
27+ { 2, TD, sys_socketcall, "socketcall",
28+#ifdef __NR_socketcall
29+ SYS_socketcall }, /* 102 */
30+#endif
31 { 3, 0, sys_syslog, "syslog" }, /* 103 */
32 { 3, 0, sys_setitimer, "setitimer" }, /* 104 */
33 { 2, 0, sys_getitimer, "getitimer" }, /* 105 */
34@@ -145,7 +148,10 @@
35 { 4, TP, sys_wait4, "wait4", SYS_wait4 }, /* 114 */
36 { 1, 0, sys_swapoff, "swapoff" }, /* 115 */
37 { 1, 0, sys_sysinfo, "sysinfo" }, /* 116 */
38- { 6, 0, sys_ipc, "ipc", SYS_ipc }, /* 117 */
39+ { 6, 0, sys_ipc, "ipc",
40+#ifdef __NR_ipc
41+ SYS_ipc }, /* 117 */
42+#endif
43 { 1, TD, sys_fsync, "fsync" }, /* 118 */
44 { 1, TS, sys_sigreturn, "sigreturn" }, /* 119 */
45 { 5, TP, sys_clone, "clone", SYS_clone }, /* 120 */
46--- strace-4.5.15.orig/syscall.c 2007-02-04 19:03:48.000000000 +0100
47+++ strace-4.5.15/syscall.c 2007-02-04 19:07:26.000000000 +0100
48@@ -2404,14 +2404,18 @@
49 switch (known_scno(tcp)) {
50 #ifdef LINUX
51 #if !defined (ALPHA) && !defined(SPARC) && !defined(SPARC64) && !defined(MIPS) && !defined(HPPA)
52+#ifdef __NR_socketcall
53 case SYS_socketcall:
54 decode_subcall(tcp, SYS_socket_subcall,
55 SYS_socket_nsubcalls, deref_style);
56 break;
57+#endif
58+#ifdef __NR_ipc
59 case SYS_ipc:
60 decode_subcall(tcp, SYS_ipc_subcall,
61 SYS_ipc_nsubcalls, shift_style);
62 break;
63+#endif
64 #endif /* !ALPHA && !MIPS && !SPARC && !SPARC64 && !HPPA */
65 #if defined (SPARC) || defined (SPARC64)
66 case SYS_socketcall:
diff --git a/meta/packages/strace/strace_4.5.14.bb b/meta/packages/strace/strace_4.5.14.bb
index b301d0100b..50baef86dc 100644
--- a/meta/packages/strace/strace_4.5.14.bb
+++ b/meta/packages/strace/strace_4.5.14.bb
@@ -9,7 +9,8 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.bz2 \
9 file://drop-ctl-proc.patch;patch=1 \ 9 file://drop-ctl-proc.patch;patch=1 \
10 file://sh-arch-update.patch;patch=1 \ 10 file://sh-arch-update.patch;patch=1 \
11 file://sh-syscall-update.patch;patch=1 \ 11 file://sh-syscall-update.patch;patch=1 \
12 file://strace-fix-arm-bad-syscall.patch;patch=1" 12 file://strace-fix-arm-bad-syscall.patch;patch=1 \
13 file://strace-undef-syscall.patch;patch=1 "
13 14
14inherit autotools 15inherit autotools
15 16