diff options
author | Dexuan Cui <dexuan.cui@intel.com> | 2010-08-24 11:34:29 +0800 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-08-27 13:04:38 +0100 |
commit | 084eb5a04dc684f5558401a2d77550d5dfc057b4 (patch) | |
tree | c6d71f2b2a71dbf4003ecc6968286d3006225e31 /meta/packages/rsync | |
parent | 9f03fdd5c749cf7b9a971ffbf610bc4f001853af (diff) | |
download | poky-084eb5a04dc684f5558401a2d77550d5dfc057b4.tar.gz |
rsync: split GPLv2 version from GPLv3 by fixing the GPLv2 recipe
remove the "require rsync.inc", and copy the .inc file into the GPLv2 recipe,
and adjust it properly;
mkdir rsync-2.6.9 and copy files/rsyncd.conf into rsync-2.6.9/rsyncd.conf.
BTW: the .conf file originated from OE in 2006:
commit c2a4b021eb04924f8c8b0e0af1fac337a04cbcae
Author: Raymond Danks <raymond@edanks.com>
Date: Tue Apr 18 01:43:08 2006 +0000
rsync: Add rsyncd.conf
http://cgit.openembedded.org/cgit.cgi/openembedded/commit/?id=c2a4b021eb04924f8c8b0e0af1fac337a04cbcae
Signed-off-by: Dexuan Cui <dexuan.cui@intel.com>
Diffstat (limited to 'meta/packages/rsync')
-rw-r--r-- | meta/packages/rsync/rsync-2.6.9/rsyncd.conf | 15 | ||||
-rw-r--r-- | meta/packages/rsync/rsync_2.6.9.bb | 23 |
2 files changed, 36 insertions, 2 deletions
diff --git a/meta/packages/rsync/rsync-2.6.9/rsyncd.conf b/meta/packages/rsync/rsync-2.6.9/rsyncd.conf new file mode 100644 index 0000000000..845f5b33f5 --- /dev/null +++ b/meta/packages/rsync/rsync-2.6.9/rsyncd.conf | |||
@@ -0,0 +1,15 @@ | |||
1 | # /etc/rsyncd.conf | ||
2 | |||
3 | # Minimal configuration file for rsync daemon | ||
4 | # See rsync(1) and rsyncd.conf(5) man pages for help | ||
5 | |||
6 | # This file is required by rsync --daemon | ||
7 | pid file = /var/run/rsyncd.pid | ||
8 | use chroot = yes | ||
9 | read only = yes | ||
10 | |||
11 | # Simple example for enabling your own local rsync server | ||
12 | #[everything] | ||
13 | # path = / | ||
14 | # comment = Everything except /etc exposed | ||
15 | # exclude = /etc | ||
diff --git a/meta/packages/rsync/rsync_2.6.9.bb b/meta/packages/rsync/rsync_2.6.9.bb index a9b5c86d8f..43379829ea 100644 --- a/meta/packages/rsync/rsync_2.6.9.bb +++ b/meta/packages/rsync/rsync_2.6.9.bb | |||
@@ -1,6 +1,25 @@ | |||
1 | require rsync.inc | 1 | DESCRIPTION = "A file-synchronization tool" |
2 | HOMEPAGE = "http://rsync.samba.org/" | ||
3 | BUGTRACKER = "http://rsync.samba.org/bugzilla.html" | ||
4 | SECTION = "console/network" | ||
5 | PRIORITY = "optional" | ||
6 | |||
7 | # needs to add acl and attr | ||
8 | DEPENDS = "popt" | ||
9 | |||
10 | SRC_URI = "http://rsync.samba.org/ftp/rsync/src/rsync-${PV}.tar.gz \ | ||
11 | file://rsyncd.conf" | ||
12 | |||
13 | inherit autotools | ||
14 | |||
15 | do_install_append() { | ||
16 | install -d ${D}/etc | ||
17 | install -m 0644 ${WORKDIR}/rsyncd.conf ${D}/etc | ||
18 | } | ||
19 | |||
20 | EXTRA_OEMAKE='STRIP=""' | ||
2 | 21 | ||
3 | LICENSE = "GPLv2+" | 22 | LICENSE = "GPLv2+" |
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=6d5a9d4c4d3af25cd68fd83e8a8cb09c" | 23 | LIC_FILES_CHKSUM = "file://COPYING;md5=6d5a9d4c4d3af25cd68fd83e8a8cb09c" |
5 | 24 | ||
6 | PR = "r1" | 25 | PR = "r2" |