summaryrefslogtreecommitdiffstats
path: root/meta/packages/rpm
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-08-20 07:27:38 +0000
committerRichard Purdie <richard@openedhand.com>2008-08-20 07:27:38 +0000
commit14f2b65bb11d57690515bbd532d4e94f8d901a6d (patch)
treeee398a4b7af8fae94f2f7f9aaa45d83603074d54 /meta/packages/rpm
parent210f0111454206730a5f4ed8eb799bfc59485708 (diff)
downloadpoky-14f2b65bb11d57690515bbd532d4e94f8d901a6d.tar.gz
rpm: Patch out some Makefile strangeness causing build failures
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5085 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/rpm')
-rw-r--r--meta/packages/rpm/files/cross_libpaths.patch33
-rw-r--r--meta/packages/rpm/rpm_4.4.2.3.bb2
2 files changed, 22 insertions, 13 deletions
diff --git a/meta/packages/rpm/files/cross_libpaths.patch b/meta/packages/rpm/files/cross_libpaths.patch
index 8cc34f2a74..4fed9b751a 100644
--- a/meta/packages/rpm/files/cross_libpaths.patch
+++ b/meta/packages/rpm/files/cross_libpaths.patch
@@ -1,7 +1,7 @@
1Index: rpm-4.4.2.3/configure.ac 1Index: rpm-4.4.2.3/configure.ac
2=================================================================== 2===================================================================
3--- rpm-4.4.2.3.orig/configure.ac 2008-08-17 11:40:29.000000000 +0100 3--- rpm-4.4.2.3.orig/configure.ac 2008-08-18 10:25:14.000000000 +0100
4+++ rpm-4.4.2.3/configure.ac 2008-08-17 11:40:29.000000000 +0100 4+++ rpm-4.4.2.3/configure.ac 2008-08-18 10:25:14.000000000 +0100
5@@ -326,10 +326,8 @@ 5@@ -326,10 +326,8 @@
6 6
7 localdone= 7 localdone=
@@ -43,7 +43,7 @@ Index: rpm-4.4.2.3/configure.ac
43Index: rpm-4.4.2.3/rpmio/Makefile.am 43Index: rpm-4.4.2.3/rpmio/Makefile.am
44=================================================================== 44===================================================================
45--- rpm-4.4.2.3.orig/rpmio/Makefile.am 2008-04-01 08:28:22.000000000 +0100 45--- rpm-4.4.2.3.orig/rpmio/Makefile.am 2008-04-01 08:28:22.000000000 +0100
46+++ rpm-4.4.2.3/rpmio/Makefile.am 2008-08-17 11:40:29.000000000 +0100 46+++ rpm-4.4.2.3/rpmio/Makefile.am 2008-08-18 10:25:14.000000000 +0100
47@@ -26,8 +26,6 @@ 47@@ -26,8 +26,6 @@
48 48
49 BEECRYPTLOBJS = $(shell test X"@WITH_BEECRYPT_SUBDIR@" != X && cat $(top_builddir)/@WITH_BEECTYPT_SUBDIR@/listobjs) 49 BEECRYPTLOBJS = $(shell test X"@WITH_BEECRYPT_SUBDIR@" != X && cat $(top_builddir)/@WITH_BEECTYPT_SUBDIR@/listobjs)
@@ -56,7 +56,7 @@ Index: rpm-4.4.2.3/rpmio/Makefile.am
56Index: rpm-4.4.2.3/rpmio/rpmio_internal.h 56Index: rpm-4.4.2.3/rpmio/rpmio_internal.h
57=================================================================== 57===================================================================
58--- rpm-4.4.2.3.orig/rpmio/rpmio_internal.h 2008-04-01 08:28:22.000000000 +0100 58--- rpm-4.4.2.3.orig/rpmio/rpmio_internal.h 2008-04-01 08:28:22.000000000 +0100
59+++ rpm-4.4.2.3/rpmio/rpmio_internal.h 2008-08-17 11:40:29.000000000 +0100 59+++ rpm-4.4.2.3/rpmio/rpmio_internal.h 2008-08-18 10:25:14.000000000 +0100
60@@ -12,22 +12,22 @@ 60@@ -12,22 +12,22 @@
61 #if HAVE_BEECRYPT_API_H 61 #if HAVE_BEECRYPT_API_H
62 #include <api.h> 62 #include <api.h>
@@ -92,8 +92,8 @@ Index: rpm-4.4.2.3/rpmio/rpmio_internal.h
92 #include <sha384.h> 92 #include <sha384.h>
93Index: rpm-4.4.2.3/Makefile.am 93Index: rpm-4.4.2.3/Makefile.am
94=================================================================== 94===================================================================
95--- rpm-4.4.2.3.orig/Makefile.am 2008-08-17 11:42:36.000000000 +0100 95--- rpm-4.4.2.3.orig/Makefile.am 2008-04-01 08:28:21.000000000 +0100
96+++ rpm-4.4.2.3/Makefile.am 2008-08-17 11:42:50.000000000 +0100 96+++ rpm-4.4.2.3/Makefile.am 2008-08-20 08:26:44.000000000 +0100
97@@ -10,7 +10,7 @@ 97@@ -10,7 +10,7 @@
98 po/*.in po/*.po po/rpm.pot \ 98 po/*.in po/*.po po/rpm.pot \
99 rpm.magic rpmpopt-$(VERSION) rpmqv.c 99 rpm.magic rpmpopt-$(VERSION) rpmqv.c
@@ -103,10 +103,19 @@ Index: rpm-4.4.2.3/Makefile.am
103 103
104 INCLUDES = \ 104 INCLUDES = \
105 -I$(top_srcdir)/build \ 105 -I$(top_srcdir)/build \
106@@ -93,7 +93,7 @@
107 rpm2cpio_LDFLAGS = $(myLDFLAGS)
108 rpm2cpio_LDADD = $(myLDADD) @LIBMISC@
109
110-$(PROGRAMS): $(myLDADD) @WITH_APIDOCS_TARGET@
111+$(PROGRAMS): @WITH_APIDOCS_TARGET@
112
113 .PHONY: splint
114 splint:
106Index: rpm-4.4.2.3/rpmdb/Makefile.am 115Index: rpm-4.4.2.3/rpmdb/Makefile.am
107=================================================================== 116===================================================================
108--- rpm-4.4.2.3.orig/rpmdb/Makefile.am 2008-08-17 11:43:36.000000000 +0100 117--- rpm-4.4.2.3.orig/rpmdb/Makefile.am 2008-04-01 08:28:22.000000000 +0100
109+++ rpm-4.4.2.3/rpmdb/Makefile.am 2008-08-17 11:43:57.000000000 +0100 118+++ rpm-4.4.2.3/rpmdb/Makefile.am 2008-08-18 10:25:14.000000000 +0100
110@@ -41,9 +41,6 @@ 119@@ -41,9 +41,6 @@
111 # XXX watchout, ../db3/libdb.la created by this Makefile may surprise 120 # XXX watchout, ../db3/libdb.la created by this Makefile may surprise
112 libdb_la = $(top_builddir)/$(WITH_DB_SUBDIR)/libdb.la 121 libdb_la = $(top_builddir)/$(WITH_DB_SUBDIR)/libdb.la
@@ -119,8 +128,8 @@ Index: rpm-4.4.2.3/rpmdb/Makefile.am
119 librpmdb_la_SOURCES = \ 128 librpmdb_la_SOURCES = \
120Index: rpm-4.4.2.3/lib/Makefile.am 129Index: rpm-4.4.2.3/lib/Makefile.am
121=================================================================== 130===================================================================
122--- rpm-4.4.2.3.orig/lib/Makefile.am 2008-08-17 11:46:43.000000000 +0100 131--- rpm-4.4.2.3.orig/lib/Makefile.am 2008-04-01 08:28:22.000000000 +0100
123+++ rpm-4.4.2.3/lib/Makefile.am 2008-08-17 11:46:51.000000000 +0100 132+++ rpm-4.4.2.3/lib/Makefile.am 2008-08-18 10:25:14.000000000 +0100
124@@ -29,8 +29,6 @@ 133@@ -29,8 +29,6 @@
125 mylibs = librpm.la 134 mylibs = librpm.la
126 LIBS = 135 LIBS =
@@ -132,8 +141,8 @@ Index: rpm-4.4.2.3/lib/Makefile.am
132 librpm_la_SOURCES = \ 141 librpm_la_SOURCES = \
133Index: rpm-4.4.2.3/build/Makefile.am 142Index: rpm-4.4.2.3/build/Makefile.am
134=================================================================== 143===================================================================
135--- rpm-4.4.2.3.orig/build/Makefile.am 2008-08-17 11:47:37.000000000 +0100 144--- rpm-4.4.2.3.orig/build/Makefile.am 2008-04-01 08:28:21.000000000 +0100
136+++ rpm-4.4.2.3/build/Makefile.am 2008-08-17 11:47:43.000000000 +0100 145+++ rpm-4.4.2.3/build/Makefile.am 2008-08-18 10:25:14.000000000 +0100
137@@ -22,8 +22,6 @@ 146@@ -22,8 +22,6 @@
138 pkginc_HEADERS = rpmbuild.h rpmfc.h rpmfile.h rpmspec.h 147 pkginc_HEADERS = rpmbuild.h rpmfc.h rpmfile.h rpmspec.h
139 noinst_HEADERS = buildio.h 148 noinst_HEADERS = buildio.h
diff --git a/meta/packages/rpm/rpm_4.4.2.3.bb b/meta/packages/rpm/rpm_4.4.2.3.bb
index b04b500b86..a568ea8c0e 100644
--- a/meta/packages/rpm/rpm_4.4.2.3.bb
+++ b/meta/packages/rpm/rpm_4.4.2.3.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "The RPM Package Manager."
2HOMEPAGE = "http://rpm.org/" 2HOMEPAGE = "http://rpm.org/"
3LICENSE = "LGPL GPL" 3LICENSE = "LGPL GPL"
4DEPENDS = "zlib beecrypt file popt" 4DEPENDS = "zlib beecrypt file popt"
5PR = "r1" 5PR = "r2"
6 6
7SRC_URI = "http://www.rpm.org/releases/rpm-4.4.x/rpm-4.4.2.3.tar.gz \ 7SRC_URI = "http://www.rpm.org/releases/rpm-4.4.x/rpm-4.4.2.3.tar.gz \
8 file://external-tools.patch;patch=1 \ 8 file://external-tools.patch;patch=1 \