summaryrefslogtreecommitdiffstats
path: root/meta/packages/qemu
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-04-25 08:28:26 +0000
committerRichard Purdie <richard@openedhand.com>2008-04-25 08:28:26 +0000
commitb5a8a564b65a2d0e1dfaa96f5a74f8a82d75cc59 (patch)
treeacc2be013056a14017ae5c98a7c56a5b89a1ec50 /meta/packages/qemu
parent3523d22ec428592446a4b1e99ba1c4605764d9ee (diff)
downloadpoky-b5a8a564b65a2d0e1dfaa96f5a74f8a82d75cc59.tar.gz
qemu: Patch out gcc3 checks, limit the target list
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4336 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/qemu')
-rw-r--r--meta/packages/qemu/qemu-0.9.1+svn/remove_gcc3_check.patch54
-rw-r--r--meta/packages/qemu/qemu_svn.bb5
2 files changed, 57 insertions, 2 deletions
diff --git a/meta/packages/qemu/qemu-0.9.1+svn/remove_gcc3_check.patch b/meta/packages/qemu/qemu-0.9.1+svn/remove_gcc3_check.patch
new file mode 100644
index 0000000000..3a180ec853
--- /dev/null
+++ b/meta/packages/qemu/qemu-0.9.1+svn/remove_gcc3_check.patch
@@ -0,0 +1,54 @@
1Index: trunk/configure
2===================================================================
3--- trunk.orig/configure 2008-04-25 09:09:31.000000000 +0100
4+++ trunk/configure 2008-04-25 09:11:31.000000000 +0100
5@@ -22,8 +22,6 @@
6 static="no"
7 cross_prefix=""
8 cc="gcc"
9-gcc3_search="yes"
10-gcc3_list="gcc-3.4.6 gcc-3.4 gcc34 gcc-3.3.6 gcc-3.3 gcc33 gcc-3.2 gcc32"
11 host_cc="gcc"
12 ar="ar"
13 make="make"
14@@ -245,9 +243,6 @@
15 ;;
16 --cross-prefix=*) cross_prefix="$optarg"
17 ;;
18- --cc=*) cc="$optarg"
19- gcc3_search="no"
20- ;;
21 --host-cc=*) host_cc="$optarg"
22 ;;
23 --make=*) make="$optarg"
24@@ -479,30 +474,6 @@
25 #endif
26 int main(){return 0;}
27 EOF
28- if "$cc" $ARCH_CFLAGS -o $TMPE $TMPC 2> /dev/null ; then
29- echo "WARNING: \"$cc\" looks like gcc 4.x"
30- found_compat_cc="no"
31- if test "$gcc3_search" = "yes" ; then
32- echo "Looking for gcc 3.x"
33- for compat_cc in $gcc3_list ; do
34- if "$cross_prefix$compat_cc" --version 2> /dev/null | fgrep '(GCC) 3.' > /dev/null 2>&1 ; then
35- echo "Found \"$compat_cc\""
36- cc="$cross_prefix$compat_cc"
37- found_compat_cc="yes"
38- break
39- fi
40- done
41- if test "$found_compat_cc" = "no" ; then
42- echo "gcc 3.x not found!"
43- fi
44- fi
45- if test "$found_compat_cc" = "no" ; then
46- echo "QEMU is known to have problems when compiled with gcc 4.x"
47- echo "It is recommended that you use gcc 3.x to build QEMU"
48- echo "To use this compiler anyway, configure with --disable-gcc-check"
49- exit 1;
50- fi
51- fi
52 fi
53
54 #
diff --git a/meta/packages/qemu/qemu_svn.bb b/meta/packages/qemu/qemu_svn.bb
index 2feb4724d8..1fc9446877 100644
--- a/meta/packages/qemu/qemu_svn.bb
+++ b/meta/packages/qemu/qemu_svn.bb
@@ -1,7 +1,7 @@
1LICENSE = "GPL" 1LICENSE = "GPL"
2DEPENDS = "zlib" 2DEPENDS = "zlib"
3PV = "0.9.1+svnr${SRCREV}" 3PV = "0.9.1+svnr${SRCREV}"
4PR = "r6" 4PR = "r7"
5 5
6FILESPATH = "${FILE_DIRNAME}/qemu-0.9.1+svn/" 6FILESPATH = "${FILE_DIRNAME}/qemu-0.9.1+svn/"
7 7
@@ -30,12 +30,13 @@ SRC_URI = "\
30 file://no-strip.patch;patch=1 \ 30 file://no-strip.patch;patch=1 \
31 file://fix_brk.patch;patch=1 \ 31 file://fix_brk.patch;patch=1 \
32 file://fix_protection_bits.patch;patch=1 \ 32 file://fix_protection_bits.patch;patch=1 \
33 file://remove_gcc3_check.patch;patch=1 \
33 file://qemu-n800-support.patch;patch=1" 34 file://qemu-n800-support.patch;patch=1"
34 35
35S = "${WORKDIR}/trunk" 36S = "${WORKDIR}/trunk"
36 37
37#EXTRA_OECONF += "--disable-sdl" 38#EXTRA_OECONF += "--disable-sdl"
38#EXTRA_OECONF += "--target-list=arm-linux-user,arm-softmmu" 39EXTRA_OECONF += "--target-list=arm-linux-user,arm-softmmu,i386-softmmu"
39EXTRA_OECONF += "--disable-gfx-check" 40EXTRA_OECONF += "--disable-gfx-check"
40 41
41inherit autotools 42inherit autotools