summaryrefslogtreecommitdiffstats
path: root/meta/packages/qemu
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-02-03 00:03:07 +0000
committerRichard Purdie <richard@openedhand.com>2008-02-03 00:03:07 +0000
commit8c42510e06cdc8364f5e74b31b1d75ca342ab269 (patch)
tree60e224d0fb014e190b957883f2e1c0d59e4451b5 /meta/packages/qemu
parent30d7bf91e51a4117b93b9d6add3fd7c9645f964e (diff)
downloadpoky-8c42510e06cdc8364f5e74b31b1d75ca342ab269.tar.gz
qemu: Fix writev syscall null value handling, fixes glibc LC_CTYPE errors during locale generation
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3661 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/qemu')
-rw-r--r--meta/packages/qemu/qemu-0.9.1/writev_fix.patch17
-rw-r--r--meta/packages/qemu/qemu_0.9.1.bb3
2 files changed, 19 insertions, 1 deletions
diff --git a/meta/packages/qemu/qemu-0.9.1/writev_fix.patch b/meta/packages/qemu/qemu-0.9.1/writev_fix.patch
new file mode 100644
index 0000000000..e0ed4af972
--- /dev/null
+++ b/meta/packages/qemu/qemu-0.9.1/writev_fix.patch
@@ -0,0 +1,17 @@
1---
2 linux-user/syscall.c | 2 +-
3 1 file changed, 1 insertion(+), 1 deletion(-)
4
5Index: qemu-0.9.1/linux-user/syscall.c
6===================================================================
7--- qemu-0.9.1.orig/linux-user/syscall.c 2008-02-03 00:00:00.000000000 +0000
8+++ qemu-0.9.1/linux-user/syscall.c 2008-02-03 00:00:38.000000000 +0000
9@@ -1048,7 +1048,7 @@ static abi_long lock_iovec(int type, str
10 base = tswapl(target_vec[i].iov_base);
11 vec[i].iov_len = tswapl(target_vec[i].iov_len);
12 vec[i].iov_base = lock_user(type, base, vec[i].iov_len, copy);
13- if (!vec[i].iov_base)
14+ if (!vec[i].iov_base && vec[i].iov_len)
15 goto fail;
16 }
17 unlock_user (target_vec, target_addr, 0);
diff --git a/meta/packages/qemu/qemu_0.9.1.bb b/meta/packages/qemu/qemu_0.9.1.bb
index 59aa55bbed..1a34d4d73b 100644
--- a/meta/packages/qemu/qemu_0.9.1.bb
+++ b/meta/packages/qemu/qemu_0.9.1.bb
@@ -1,6 +1,6 @@
1LICENSE = "GPL" 1LICENSE = "GPL"
2DEPENDS = "zlib" 2DEPENDS = "zlib"
3PR = "r4" 3PR = "r5"
4 4
5FILESPATH = "${FILE_DIRNAME}/qemu-${PV}" 5FILESPATH = "${FILE_DIRNAME}/qemu-${PV}"
6FILESDIR = "${WORKDIR}" 6FILESDIR = "${WORKDIR}"
@@ -31,6 +31,7 @@ SRC_URI = "\
31 file://qemu-amd64-32b-mapping-0.9.0.patch;patch=1 \ 31 file://qemu-amd64-32b-mapping-0.9.0.patch;patch=1 \
32 file://workaround_bad_futex_headers.patch;patch=1 \ 32 file://workaround_bad_futex_headers.patch;patch=1 \
33 file://fix_segfault.patch;patch=1 \ 33 file://fix_segfault.patch;patch=1 \
34 file://writev_fix.patch;patch=1 \
34 file://configure_symlinkpath_fix.patch;patch=1 \ 35 file://configure_symlinkpath_fix.patch;patch=1 \
35 file://disable-error-in-configure.patch;patch=1" 36 file://disable-error-in-configure.patch;patch=1"
36 37