summaryrefslogtreecommitdiffstats
path: root/meta/packages/qemu/qemu_0.9.1.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-01-09 11:16:08 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-01-09 11:16:08 +0000
commit3e5646fce1af97a8bde8a740da4ee0c58bf42ebd (patch)
tree2d5c0dc86ac168f2b3ae135d5d66ba84e36f9478 /meta/packages/qemu/qemu_0.9.1.bb
parent03e591a793512342acac958597047f34a9d5bfbe (diff)
downloadpoky-3e5646fce1af97a8bde8a740da4ee0c58bf42ebd.tar.gz
qemu: upgrade CVS snapshot 20071230 to 0.9.1 release
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3435 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/qemu/qemu_0.9.1.bb')
-rw-r--r--meta/packages/qemu/qemu_0.9.1.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta/packages/qemu/qemu_0.9.1.bb b/meta/packages/qemu/qemu_0.9.1.bb
new file mode 100644
index 0000000000..5d75c6bfa6
--- /dev/null
+++ b/meta/packages/qemu/qemu_0.9.1.bb
@@ -0,0 +1,55 @@
1LICENSE = "GPL"
2DEPENDS = "zlib"
3SRCDATE = "20071230"
4
5FILESPATH = "${FILE_DIRNAME}/qemu-${PV}:${FILE_DIRNAME}/files"
6FILESDIR = "${WORKDIR}"
7
8SRC_URI = "\
9 http://fabrice.bellard.free.fr/qemu/qemu-0.9.1.tar.gz \
10 file://02_snapshot_use_tmpdir.patch;patch=1;pnum=0 \
11 file://04_do_not_print_rtc_freq_if_ok.patch;patch=1;pnum=1 \
12 file://05_non-fatal_if_linux_hd_missing.patch;patch=1;pnum=1 \
13 file://06_exit_segfault.patch;patch=1;pnum=0 \
14 file://10_signal_jobs.patch;patch=1;pnum=0 \
15 file://11_signal_sigaction.patch;patch=1;pnum=0 \
16 file://22_net_tuntap_stall.patch;patch=1;pnum=0 \
17 file://31_syscalls.patch;patch=1;pnum=0 \
18 file://32_syscall_sysctl.patch;patch=1;pnum=0 \
19 file://33_syscall_ppc_clone.patch;patch=1;pnum=0 \
20 file://39_syscall_fadvise64.patch;patch=1;pnum=0 \
21 file://41_arm_fpa_sigfpe.patch;patch=1;pnum=0 \
22 file://52_ne2000_return.patch;patch=1;pnum=1 \
23 file://61_safe_64bit_int.patch;patch=1;pnum=0 \
24 file://63_sparc_build.patch;patch=1;pnum=0 \
25 file://64_ppc_asm_constraints.patch;patch=1;pnum=1 \
26 file://65_kfreebsd.patch;patch=1;pnum=0 \
27 file://66_tls_ld.patch;patch=1;pnum=0 \
28 file://91-oh-sdl-cursor.patch;patch=1;pnum=0 \
29 file://qemu-0.9.0-nptl.patch;patch=1 \
30 file://qemu-0.9.0-nptl-update.patch;patch=1 \
31 file://qemu-amd64-32b-mapping-0.9.0.patch;patch=1 \
32 file://workaround_bad_futex_headers.patch;patch=1 \
33 file://fix_segfault.patch;patch=1 \
34 file://disable-error-in-configure.patch;patch=1"
35
36# svn://svn.o-hand.com/repos/misc/trunk/qemu-packaging/qemu;module=debian;proto=http;srcdate=20070119 \
37# file://debian/patches/21_net_soopts.patch;patch=1;pnum=0 \
38# file://debian/patches/35_syscall_sockaddr.patch;patch=1;pnum=0 \
39# file://debian/patches/43_arm_cpustate.patch;patch=1;pnum=0 \
40# file://debian/patches/62_linux_boot_nasm.patch;patch=1;pnum=0 \
41# file://debian/patches/67_ppc_ftbfs.patch;patch=1;pnum=0 \
42# file://debian/patches/80_ui_curses.patch;patch=1;pnum=0 \
43# file://debian/patches/96-x.patch;patch=1"
44
45S = "${WORKDIR}/qemu-${PV}"
46
47#EXTRA_OECONF += "--disable-sdl"
48#EXTRA_OECONF += "--target-list=arm-linux-user"
49EXTRA_OECONF += "--disable-gfx-check"
50
51inherit autotools
52
53do_configure() {
54 oe_runconf
55}