summaryrefslogtreecommitdiffstats
path: root/meta/packages/qemu/qemu-git/fix-nogl.patch
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-06-09 22:16:58 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-06-09 22:16:58 +0100
commitbe24aaa96c007edb30210dac9f873f0477395beb (patch)
treef10f21ee67b0de18a2ef600872be4217367f9581 /meta/packages/qemu/qemu-git/fix-nogl.patch
parent3ac19a493e1c24ae40d3b62a6ff3bc0cd4943266 (diff)
downloadpoky-be24aaa96c007edb30210dac9f873f0477395beb.tar.gz
qemu: Drop a ton of old now mostly inappropriate patches and update the qemugl passthrough patch
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/qemu/qemu-git/fix-nogl.patch')
-rw-r--r--meta/packages/qemu/qemu-git/fix-nogl.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/packages/qemu/qemu-git/fix-nogl.patch b/meta/packages/qemu/qemu-git/fix-nogl.patch
new file mode 100644
index 0000000000..f1f9bcf00b
--- /dev/null
+++ b/meta/packages/qemu/qemu-git/fix-nogl.patch
@@ -0,0 +1,40 @@
1Index: git/Makefile.target
2===================================================================
3--- git.orig/Makefile.target 2009-06-09 22:05:27.000000000 +0100
4+++ git/Makefile.target 2009-06-09 22:05:28.000000000 +0100
5@@ -155,6 +155,8 @@
6
7 ifeq ($(TARGET_BASE_ARCH), i386)
8 LIBOBJS+=helper_opengl.o opengl_exec.o
9+else
10+LIBOBJS+=dummygl.o
11 endif
12
13 ifeq ($(TARGET_BASE_ARCH), arm)
14Index: git/target-arm/dummygl.c
15===================================================================
16--- /dev/null 1970-01-01 00:00:00.000000000 +0000
17+++ git/target-arm/dummygl.c 2009-06-09 22:15:55.000000000 +0100
18@@ -0,0 +1,22 @@
19+#include <string.h>
20+#include <stdlib.h>
21+#include <assert.h>
22+#include <stdint.h>
23+#include <X11/Xlib.h>
24+#include <X11/Xutil.h>
25+
26+void opengl_exec_set_parent_window(Display* _dpy, Window _parent_window)
27+{
28+
29+}
30+
31+void opengl_process_enable(void)
32+{
33+
34+}
35+
36+
37+void mem_opengl(uint64_t ptr)
38+{
39+
40+}