summaryrefslogtreecommitdiffstats
path: root/meta/packages/python
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-10-07 09:31:38 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-10-07 09:31:38 +0000
commitceb27d5fd3c8553946ad4ee0ce1ca86435661357 (patch)
tree8f238dfb601018d8210ddc16a621aad52642bed7 /meta/packages/python
parentb7aed5e958e36374b807071719fe7c83292af5b2 (diff)
downloadpoky-ceb27d5fd3c8553946ad4ee0ce1ca86435661357.tar.gz
python: package bzip2 support into separate package
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5428 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/python')
-rw-r--r--meta/packages/python/python-2.5-manifest.inc8
-rw-r--r--meta/packages/python/python_2.5.2.bb4
2 files changed, 7 insertions, 5 deletions
diff --git a/meta/packages/python/python-2.5-manifest.inc b/meta/packages/python/python-2.5-manifest.inc
index c098494d17..3e7dd178e8 100644
--- a/meta/packages/python/python-2.5-manifest.inc
+++ b/meta/packages/python/python-2.5-manifest.inc
@@ -8,9 +8,9 @@
8######################################################################################################################## 8########################################################################################################################
9 9
10 10
11PROVIDES+="python-profile python-threading python-distutils python-textutils python-codecs python-ctypes python-pickle python-datetime python-core python-io python-compiler python-compression python-re python-xmlrpc python-terminal python-email python-image python-tests python-core-dbg python-resource python-devel python-math python-hotshot python-unixadmin python-syslog python-tkinter python-gdbm python-fcntl python-netclient python-pprint python-netserver python-curses python-smtpd python-html python-readline python-subprocess python-pydoc python-logging python-mailbox python-xml python-mime python-sqlite3 python-sqlite3-tests python-unittest python-stringold python-robotparser python-lib-old-and-deprecated python-compile python-debugger python-shell python-bsddb python-mmap python-zlib python-db python-crypt python-idle python-lang python-audio " 11PROVIDES+="python-profile python-threading python-distutils python-textutils python-codecs python-ctypes python-pickle python-datetime python-core python-io python-compiler python-compression python-re python-xmlrpc python-terminal python-email python-image python-tests python-core-dbg python-resource python-devel python-math python-hotshot python-unixadmin python-syslog python-tkinter python-gdbm python-fcntl python-netclient python-pprint python-netserver python-curses python-smtpd python-html python-readline python-subprocess python-pydoc python-logging python-mailbox python-xml python-mime python-sqlite3 python-sqlite3-tests python-unittest python-stringold python-robotparser python-lib-old-and-deprecated python-compile python-debugger python-shell python-bsddb python-mmap python-zlib python-db python-crypt python-idle python-lang python-audio python-bzip2 python-elementtree"
12 12
13PACKAGES="python-profile python-threading python-distutils python-textutils python-codecs python-ctypes python-pickle python-datetime python-core python-io python-compiler python-compression python-re python-xmlrpc python-terminal python-email python-image python-tests python-core-dbg python-resource python-devel python-math python-hotshot python-unixadmin python-syslog python-tkinter python-gdbm python-fcntl python-netclient python-pprint python-netserver python-curses python-smtpd python-html python-readline python-subprocess python-pydoc python-logging python-mailbox python-xml python-mime python-sqlite3 python-sqlite3-tests python-unittest python-stringold python-robotparser python-lib-old-and-deprecated python-compile python-debugger python-shell python-bsddb python-mmap python-zlib python-db python-crypt python-idle python-lang python-audio " 13PACKAGES="python-profile python-threading python-distutils python-textutils python-codecs python-ctypes python-pickle python-datetime python-core python-io python-compiler python-compression python-re python-xmlrpc python-terminal python-email python-image python-tests python-core-dbg python-resource python-devel python-math python-hotshot python-unixadmin python-syslog python-tkinter python-gdbm python-fcntl python-netclient python-pprint python-netserver python-curses python-smtpd python-html python-readline python-subprocess python-pydoc python-logging python-mailbox python-xml python-mime python-sqlite3 python-sqlite3-tests python-unittest python-stringold python-robotparser python-lib-old-and-deprecated python-compile python-debugger python-shell python-bsddb python-mmap python-zlib python-db python-crypt python-idle python-lang python-audio python-bzip2 python-elementtree"
14 14
15DESCRIPTION_python-profile="Python Basic Profiling Support" 15DESCRIPTION_python-profile="Python Basic Profiling Support"
16PR_python-profile="ml0" 16PR_python-profile="ml0"
@@ -302,5 +302,7 @@ PR_python-audio="ml0"
302RDEPENDS_python-audio="python-core" 302RDEPENDS_python-audio="python-core"
303FILES_python-audio="${libdir}/python2.5/wave.* ${libdir}/python2.5/chunk.* ${libdir}/python2.5/sndhdr.* ${libdir}/python2.5/lib-dynload/ossaudiodev.so ${libdir}/python2.5/lib-dynload/audioop.so " 303FILES_python-audio="${libdir}/python2.5/wave.* ${libdir}/python2.5/chunk.* ${libdir}/python2.5/sndhdr.* ${libdir}/python2.5/lib-dynload/ossaudiodev.so ${libdir}/python2.5/lib-dynload/audioop.so "
304 304
305 305DESCRIPTION_python-bzip2="Python bzip2 Handling"
306RDEPENDS_python-bzip2="python-core"
307FILES_python-bzip2="${libdir}/python2.5/lib-dynload/bz2.so"
306 308
diff --git a/meta/packages/python/python_2.5.2.bb b/meta/packages/python/python_2.5.2.bb
index 1ac48f3686..d779865801 100644
--- a/meta/packages/python/python_2.5.2.bb
+++ b/meta/packages/python/python_2.5.2.bb
@@ -3,9 +3,9 @@ HOMEPAGE = "http://www.python.org"
3LICENSE = "PSF" 3LICENSE = "PSF"
4SECTION = "devel/python" 4SECTION = "devel/python"
5PRIORITY = "optional" 5PRIORITY = "optional"
6DEPENDS = "python-native readline zlib gdbm openssl sqlite3" 6DEPENDS = "python-native readline zlib gdbm openssl sqlite3 bzip2"
7DEPENDS_sharprom = "python-native readline zlib gdbm openssl" 7DEPENDS_sharprom = "python-native readline zlib gdbm openssl"
8PR = "ml1" 8PR = "ml2"
9 9
10PYTHON_MAJMIN = "2.5" 10PYTHON_MAJMIN = "2.5"
11 11