summaryrefslogtreecommitdiffstats
path: root/meta/packages/python
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-06-10 12:21:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-06-10 12:21:24 +0100
commit12d6acb013433bf9768cd96559070a131ac5b03c (patch)
treefc82a9cba47671f2914dacd0f008347f61deb7c8 /meta/packages/python
parentde687629d89740d8f748f8a0b11650e5649c66e4 (diff)
downloadpoky-12d6acb013433bf9768cd96559070a131ac5b03c.tar.gz
python-gobject: 2.12.3 -> 2.16.0
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/python')
-rw-r--r--meta/packages/python/python-pygobject-native_2.12.3.bb7
-rw-r--r--meta/packages/python/python-pygobject-native_2.16.0.bb18
-rw-r--r--meta/packages/python/python-pygobject/generate-constants.patch18
-rw-r--r--meta/packages/python/python-pygobject/python-path.patch23
-rw-r--r--meta/packages/python/python-pygobject_2.12.3.bb24
-rw-r--r--meta/packages/python/python-pygobject_2.16.0.bb38
6 files changed, 74 insertions, 54 deletions
diff --git a/meta/packages/python/python-pygobject-native_2.12.3.bb b/meta/packages/python/python-pygobject-native_2.12.3.bb
deleted file mode 100644
index cb879fdeb1..0000000000
--- a/meta/packages/python/python-pygobject-native_2.12.3.bb
+++ /dev/null
@@ -1,7 +0,0 @@
1require python-pygobject_${PV}.bb
2
3DEPENDS = "python-native glib-2.0-native"
4
5SRC_URI = "ftp://ftp.gnome.org/pub/GNOME/sources/pygobject/2.12/pygobject-${PV}.tar.bz2 "
6
7inherit native
diff --git a/meta/packages/python/python-pygobject-native_2.16.0.bb b/meta/packages/python/python-pygobject-native_2.16.0.bb
new file mode 100644
index 0000000000..a1c733334c
--- /dev/null
+++ b/meta/packages/python/python-pygobject-native_2.16.0.bb
@@ -0,0 +1,18 @@
1require python-pygobject_${PV}.bb
2
3DEPENDS = "python-native glib-2.0-native"
4PR = "r1"
5
6PARALLEL_MAKE = ""
7
8inherit native
9
10SRC_URI = "\
11 ftp://ftp.gnome.org/pub/GNOME/sources/pygobject/${MAJ_VER}/pygobject-${PV}.tar.bz2 \
12# file://python-path.patch;patch=1 \
13"
14
15do_stage_append() {
16 install -d ${STAGING_BINDIR}
17 install -m 0755 gobject/generate-constants ${STAGING_BINDIR}/gobject-generate-constants
18}
diff --git a/meta/packages/python/python-pygobject/generate-constants.patch b/meta/packages/python/python-pygobject/generate-constants.patch
new file mode 100644
index 0000000000..57a9380620
--- /dev/null
+++ b/meta/packages/python/python-pygobject/generate-constants.patch
@@ -0,0 +1,18 @@
1Index: pygobject-2.14.2/gobject/Makefile.am
2===================================================================
3--- pygobject-2.14.2.orig/gobject/Makefile.am
4+++ pygobject-2.14.2/gobject/Makefile.am
5@@ -21,11 +21,11 @@ if PLATFORM_WIN32
6 common_ldflags += -no-undefined
7 endif
8
9-constants.py: generate-constants$(EXEEXT) constants.py.in
10+constants.py: constants.py.in
11 rm -f constants.py
12 cp $(srcdir)/constants.py.in constants.py
13 chmod 644 constants.py
14- $(top_builddir)/gobject/generate-constants$(EXEEXT) >> constants.py
15+ gobject-generate-constants$(EXEEXT) >> constants.py
16 chmod 444 constants.py
17
18 generate_constants_CFLAGS = $(GLIB_CFLAGS)
diff --git a/meta/packages/python/python-pygobject/python-path.patch b/meta/packages/python/python-pygobject/python-path.patch
deleted file mode 100644
index 2ab7bdce6e..0000000000
--- a/meta/packages/python/python-pygobject/python-path.patch
+++ /dev/null
@@ -1,23 +0,0 @@
1Index: pygobject-2.12.3/m4/python.m4
2===================================================================
3--- pygobject-2.12.3.orig/m4/python.m4 2007-03-02 15:00:20.945635455 +0100
4+++ pygobject-2.12.3/m4/python.m4 2007-03-02 15:00:43.532189734 +0100
5@@ -43,12 +43,18 @@
6 [AC_REQUIRE([AM_PATH_PYTHON])
7 AC_MSG_CHECKING(for headers required to compile python extensions)
8 dnl deduce PYTHON_INCLUDES
9+AC_ARG_WITH(python-includes,
10+ [ --with-python-includes=DIR path to Python includes], py_exec_prefix=$withval)
11+if test x$py_exec_prefix != x; then
12+PYTHON_INCLUDES="-I${py_exec_prefix}/include/python${PYTHON_VERSION}"
13+else
14 py_prefix=`$PYTHON -c "import sys; print sys.prefix"`
15 py_exec_prefix=`$PYTHON -c "import sys; print sys.exec_prefix"`
16 PYTHON_INCLUDES="-I${py_prefix}/include/python${PYTHON_VERSION}"
17 if test "$py_prefix" != "$py_exec_prefix"; then
18 PYTHON_INCLUDES="$PYTHON_INCLUDES -I${py_exec_prefix}/include/python${PYTHON_VERSION}"
19 fi
20+fi
21 AC_SUBST(PYTHON_INCLUDES)
22 dnl check if the headers exist:
23 save_CPPFLAGS="$CPPFLAGS"
diff --git a/meta/packages/python/python-pygobject_2.12.3.bb b/meta/packages/python/python-pygobject_2.12.3.bb
deleted file mode 100644
index bfd04d569d..0000000000
--- a/meta/packages/python/python-pygobject_2.12.3.bb
+++ /dev/null
@@ -1,24 +0,0 @@
1DESCRIPTION = "Python GObject bindings"
2SECTION = "devel/python"
3LICENSE = "LGPL"
4DEPENDS = "python-pygobject-native"
5PR = "r3"
6
7SRC_URI = "ftp://ftp.gnome.org/pub/GNOME/sources/pygobject/2.12/pygobject-${PV}.tar.bz2 \
8 file://python-path.patch;patch=1"
9S = "${WORKDIR}/pygobject-${PV}"
10
11inherit autotools distutils-base pkgconfig
12
13EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
14
15do_stage() {
16 autotools_stage_all
17 install -d ${STAGING_LIBDIR}/../share/pygobject/
18 cp -dpfR docs/* ${STAGING_LIBDIR}/../share/pygobject/
19 install -d ${STAGING_LIBDIR}/../share/gtk-doc/html/pygobject/
20 cp docs/style.css ${STAGING_LIBDIR}/../share/gtk-doc/html/pygobject/
21}
22
23FILES_${PN} = "${libdir}/python*"
24FILES_${PN}-dev += "${datadir}/pygobject/xsl"
diff --git a/meta/packages/python/python-pygobject_2.16.0.bb b/meta/packages/python/python-pygobject_2.16.0.bb
new file mode 100644
index 0000000000..d7bd1c041f
--- /dev/null
+++ b/meta/packages/python/python-pygobject_2.16.0.bb
@@ -0,0 +1,38 @@
1DESCRIPTION = "Python GObject bindings"
2SECTION = "devel/python"
3LICENSE = "LGPL"
4DEPENDS = "python-pygobject-native-${PV}"
5PR = "ml2"
6
7MAJ_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
8
9SRC_URI = "\
10 ftp://ftp.gnome.org/pub/GNOME/sources/pygobject/${MAJ_VER}/pygobject-${PV}.tar.bz2 \
11 file://generate-constants.patch;patch=1 \
12"
13S = "${WORKDIR}/pygobject-${PV}"
14
15FILESPATH = "${FILE_DIRNAME}/python-pygobject:${FILE_DIRNAME}/files"
16
17inherit autotools distutils-base pkgconfig
18
19# necessary to let the call for python-config succeed
20export BUILD_SYS
21export HOST_SYS
22
23do_stage() {
24 autotools_stage_all
25 install -d ${STAGING_LIBDIR}/../share/pygobject/
26 cp -dpfR docs/* ${STAGING_LIBDIR}/../share/pygobject/
27 install -d ${STAGING_LIBDIR}/../share/gtk-doc/html/pygobject/
28 cp docs/style.css ${STAGING_LIBDIR}/../share/gtk-doc/html/pygobject/
29}
30
31PACKAGES += "${PN}-lib"
32
33RDEPENDS_${PN} += "python-textutils"
34
35FILES_${PN} = "${libdir}/python*"
36FILES_${PN}-lib = "${libdir}/lib*.so.*"
37FILES_${PN}-dev += "${bindir} ${datadir}"
38FILES_${PN}-dbg += "${libdir}/.debug"