summaryrefslogtreecommitdiffstats
path: root/meta/packages/python/python_2.5.2.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-12-03 12:07:18 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2009-12-03 12:07:18 +0000
commit3b5336f7cf1c01c23e2fd81b54fbf89558fc2cd4 (patch)
treee1b0dda81e40da45f269b81a89f4145f350037bf /meta/packages/python/python_2.5.2.bb
parentde73c65121ff57ca094e86401bcbc02f6629ebf2 (diff)
downloadpoky-3b5336f7cf1c01c23e2fd81b54fbf89558fc2cd4.tar.gz
python: Update 2.5 -> 2.6 (from OE.dev)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/python/python_2.5.2.bb')
-rw-r--r--meta/packages/python/python_2.5.2.bb100
1 files changed, 0 insertions, 100 deletions
diff --git a/meta/packages/python/python_2.5.2.bb b/meta/packages/python/python_2.5.2.bb
deleted file mode 100644
index 195ab2f4ef..0000000000
--- a/meta/packages/python/python_2.5.2.bb
+++ /dev/null
@@ -1,100 +0,0 @@
1DESCRIPTION = "Python Programming Language"
2HOMEPAGE = "http://www.python.org"
3LICENSE = "PSF"
4SECTION = "devel/python"
5PRIORITY = "optional"
6DEPENDS = "python-native readline zlib gdbm openssl sqlite3 bzip2"
7DEPENDS_sharprom = "python-native readline zlib gdbm openssl"
8PR = "ml3"
9
10PYTHON_MAJMIN = "2.5"
11
12SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
13 file://bindir-libdir.patch;patch=1 \
14 file://crosscompile.patch;patch=1 \
15 file://fix-tkinter-detection.patch;patch=1 \
16 file://autohell.patch;patch=1 \
17 file://sitebranding.patch;patch=1 \
18 file://enable-ctypes-module.patch;patch=1 \
19 file://default-is-optimized.patch;patch=1 \
20 file://sitecustomize.py"
21S = "${WORKDIR}/Python-${PV}"
22
23inherit autotools
24
25EXTRA_OECONF = "--with-threads --with-pymalloc --with-cyclic-gc \
26 --without-cxx --with-signal-module --with-wctype-functions \
27 --enable-shared"
28
29#
30# copy config.h and an appropriate Makefile for distutils.sysconfig
31# which laters uses the information out of these to compile extensions
32#
33do_compile_prepend() {
34 install -d ${STAGING_INCDIR}/python${PYTHON_MAJMIN}/
35 install -d ${STAGING_LIBDIR}/python${PYTHON_MAJMIN}/config/
36 install -m 0644 pyconfig.h ${STAGING_INCDIR}/python${PYTHON_MAJMIN}/
37 install -m 0644 Makefile Makefile.orig
38 install -m 0644 Makefile Makefile.backup
39 sed -e 's,${includedir},${STAGING_INCDIR},' < Makefile.backup > Makefile
40 install -m 0644 Makefile Makefile.backup
41 sed -e 's,${libdir},${STAGING_LIBDIR},' < Makefile.backup > Makefile
42 install -m 0644 Makefile ${STAGING_LIBDIR}/python${PYTHON_MAJMIN}/config/
43}
44
45do_compile() {
46 oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/pgen \
47 HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python \
48 STAGING_LIBDIR=${STAGING_LIBDIR} \
49 STAGING_INCDIR=${STAGING_INCDIR} \
50 BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
51 OPT="${CFLAGS}" libpython2.5.so
52
53 oe_libinstall -so libpython2.5 ${STAGING_LIBDIR}
54
55 oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/pgen \
56 HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python \
57 STAGING_LIBDIR=${STAGING_LIBDIR} \
58 STAGING_INCDIR=${STAGING_INCDIR} \
59 BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
60 OPT="${CFLAGS}"
61}
62
63do_install() {
64 install -m 0644 Makefile.orig Makefile
65
66 oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/pgen \
67 HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python \
68 STAGING_LIBDIR=${STAGING_LIBDIR} \
69 STAGING_INCDIR=${STAGING_INCDIR} \
70 BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
71 DESTDIR=${D} LIBDIR=${libdir} install
72
73 install -m 0644 ${WORKDIR}/sitecustomize.py ${D}/${libdir}/python${PYTHON_MAJMIN}
74}
75
76require python-${PYTHON_MAJMIN}-manifest.inc
77
78# manual dependency additions
79RPROVIDES_python-core = "python"
80RRECOMMENDS_python-core = "python-readline"
81RRECOMMENDS_python-crypt = "openssl"
82
83# add sitecustomize
84FILES_python-core += "${libdir}/python${PYTHON_MAJMIN}/sitecustomize.py"
85
86# package libpython
87PACKAGES =+ "libpython2"
88FILES_libpython2 = "${libdir}/libpython*"
89
90# catch debug extensions
91FILES_python-dbg += "${libdir}/python${PYTHON_MAJMIN}/lib-dynload/.debug"
92
93# catch all the rest (unsorted)
94PACKAGES += "python-misc"
95FILES_python-misc = "${libdir}/python${PYTHON_MAJMIN}"
96
97# catch manpage
98PACKAGES += "python-man"
99FILES_python-man = "${datadir}/man"
100