summaryrefslogtreecommitdiffstats
path: root/meta/packages/pkgconfig
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-03-26 22:37:55 +0000
committerRichard Purdie <richard@openedhand.com>2008-03-26 22:37:55 +0000
commitcd22fcc461abb68f9f901433c3489bc562e3fa99 (patch)
tree3be39e26d651edd06e4ed129a46ff76423145b5c /meta/packages/pkgconfig
parentc3735c4462710b2c04ed4e2de90ab6bdfc148504 (diff)
downloadpoky-cd22fcc461abb68f9f901433c3489bc562e3fa99.tar.gz
pkgconfig: Fix problems with the sysroot implementation merged upstream, switch pkgconfig to link against an external glib-2.0
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4126 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/pkgconfig')
-rw-r--r--meta/packages/pkgconfig/pkgconfig-0.23/sysrootfix.patch31
-rw-r--r--meta/packages/pkgconfig/pkgconfig.inc3
-rw-r--r--meta/packages/pkgconfig/pkgconfig_0.23.bb3
3 files changed, 36 insertions, 1 deletions
diff --git a/meta/packages/pkgconfig/pkgconfig-0.23/sysrootfix.patch b/meta/packages/pkgconfig/pkgconfig-0.23/sysrootfix.patch
new file mode 100644
index 0000000000..c5ee82e9aa
--- /dev/null
+++ b/meta/packages/pkgconfig/pkgconfig-0.23/sysrootfix.patch
@@ -0,0 +1,31 @@
1Index: pkg-config-0.23/pkg.c
2===================================================================
3--- pkg-config-0.23.orig/pkg.c 2008-03-26 22:18:39.000000000 +0000
4+++ pkg-config-0.23/pkg.c 2008-03-26 22:31:11.000000000 +0000
5@@ -472,19 +472,15 @@
6 while (tmp != NULL)
7 {
8 char *tmpstr = (char*) tmp->data;
9- if (pcsysrootdir != NULL)
10+ if (pcsysrootdir != NULL && tmpstr[0] == '-' &&
11+ (tmpstr[1] == 'I' || tmpstr[1] == 'L'))
12 {
13- if (tmpstr[0] == '-' &&
14- (tmpstr[1] == 'I' ||
15- tmpstr[1] == 'L'))
16- {
17- g_string_append_c (str, '-');
18- g_string_append_c (str, tmpstr[1]);
19- g_string_append (str, pcsysrootdir);
20- g_string_append (str, tmpstr+2);
21- }
22+ g_string_append_c (str, '-');
23+ g_string_append_c (str, tmpstr[1]);
24+ g_string_append (str, pcsysrootdir);
25+ g_string_append (str, tmpstr+2);
26 }
27- else
28+ else
29 {
30 g_string_append (str, tmpstr);
31 }
diff --git a/meta/packages/pkgconfig/pkgconfig.inc b/meta/packages/pkgconfig/pkgconfig.inc
index d4607f1733..6fec0c3645 100644
--- a/meta/packages/pkgconfig/pkgconfig.inc
+++ b/meta/packages/pkgconfig/pkgconfig.inc
@@ -5,9 +5,10 @@ It replaces the ubiquitous *-config scripts you may have \
5seen with a single tool." 5seen with a single tool."
6HOMEPAGE = "http://pkg-config.freedesktop.org/wiki/" 6HOMEPAGE = "http://pkg-config.freedesktop.org/wiki/"
7LICENSE = "GPL" 7LICENSE = "GPL"
8PR = "r3" 8PR = "r6"
9 9
10SRC_URI = "http://pkgconfig.freedesktop.org/releases/pkg-config-${PV}.tar.gz \ 10SRC_URI = "http://pkgconfig.freedesktop.org/releases/pkg-config-${PV}.tar.gz \
11 file://sysrootfix.patch;patch=1 \
11 file://glibconfig-sysdefs.h" 12 file://glibconfig-sysdefs.h"
12 13
13S = "${WORKDIR}/pkg-config-${PV}/" 14S = "${WORKDIR}/pkg-config-${PV}/"
diff --git a/meta/packages/pkgconfig/pkgconfig_0.23.bb b/meta/packages/pkgconfig/pkgconfig_0.23.bb
index 599e1c815e..39fdc30f2c 100644
--- a/meta/packages/pkgconfig/pkgconfig_0.23.bb
+++ b/meta/packages/pkgconfig/pkgconfig_0.23.bb
@@ -1,3 +1,6 @@
1require pkgconfig.inc 1require pkgconfig.inc
2 2
3SRC_URI += "file://autofoo.patch;patch=1" 3SRC_URI += "file://autofoo.patch;patch=1"
4
5DEPENDS += "glib-2.0"
6EXTRA_OECONF = "--with-installed-glib"