summaryrefslogtreecommitdiffstats
path: root/meta/packages/pkgconfig/pkgconfig/disable-legacy.patch
diff options
context:
space:
mode:
authorJoshua Lock <josh@linux.intel.com>2010-06-22 13:20:08 +0100
committerJoshua Lock <josh@linux.intel.com>2010-06-25 14:54:40 +0100
commit4f14e0a240f5d6e4eeecdb4bbbae7205e2070cab (patch)
tree6dbed655b94c57e9fa3665c3c6c45ee439a8977f /meta/packages/pkgconfig/pkgconfig/disable-legacy.patch
parentc27b95110949fbb36ea056757650cdb338655ba0 (diff)
downloadpoky-4f14e0a240f5d6e4eeecdb4bbbae7205e2070cab.tar.gz
pkgconfig: add patch to disable legacy scripts such as glib-config
On an F13 host with glib-config installed pkgconfig-native can get into a horrible state with recursive calls between pkg-config and glib-config. The patch adds a configure time option to disable legacy script support in pkgconfig and makes use of the option for Poky. Signed-off-by: Joshua Lock <josh@linux.intel.com>
Diffstat (limited to 'meta/packages/pkgconfig/pkgconfig/disable-legacy.patch')
-rw-r--r--meta/packages/pkgconfig/pkgconfig/disable-legacy.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/packages/pkgconfig/pkgconfig/disable-legacy.patch b/meta/packages/pkgconfig/pkgconfig/disable-legacy.patch
new file mode 100644
index 0000000000..fea2d3d501
--- /dev/null
+++ b/meta/packages/pkgconfig/pkgconfig/disable-legacy.patch
@@ -0,0 +1,42 @@
1On an Fedora host with glib-config installed pkgconfig-native can get into a
2horrible state with recursive calls between pkg-config and glib-config.
3The patch adds a configure time option to disable legacy script support in
4pkgconfig with the --disable-legacy-scripts option, to maintain compatibility
5the default is to leave the scripts enabled.
6
7JL - 22/06/10
8Index: pkg-config-0.23/configure.in
9===================================================================
10--- pkg-config-0.23.orig/configure.in 2008-01-16 22:48:07.000000000 +0000
11+++ pkg-config-0.23/configure.in 2010-06-22 13:05:58.951984140 +0100
12@@ -125,6 +125,14 @@
13 AC_CONFIG_SUBDIRS(glib-1.2.10)
14 fi # !native_win32
15
16+# legacy *-configure scripts can cause headaches, add option to disable
17+AC_ARG_ENABLE(legacy-scripts,
18+ [AC_HELP_STRING([--enable-legacy-scripts=@<:@no/yes@:>@],
19+ [Whether pkg-config will try and use legacy scripts such as glib-config and gnome-config @<:@default=yes@:>@])],
20+ [],
21+ [enable_legacy=yes])
22+AM_CONDITIONAL([LEGACY_SCRIPTS], [test x$enable_legacy = xyes])
23+
24 AC_FUNC_ALLOCA
25
26 AC_CHECK_FUNCS(setresuid setreuid,break)
27Index: pkg-config-0.23/parse.c
28===================================================================
29--- pkg-config-0.23.orig/parse.c 2008-01-16 20:42:49.000000000 +0000
30+++ pkg-config-0.23/parse.c 2010-06-22 13:09:10.410129471 +0100
31@@ -1195,6 +1195,11 @@
32 * messages.
33 */
34 return NULL;
35+#elif defined(LEGACY_SCRIPTS)
36+ /* There are scenarios where we might not want to use these legacy
37+ * scripts even if they are available.
38+ */
39+ return NULL;
40 #else
41
42 Package *pkg;