summaryrefslogtreecommitdiffstats
path: root/meta/packages/pciutils/pciutils_2.2.4.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-06-29 07:34:11 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-06-29 07:34:11 +0000
commitf8ca66bdb7fff028d9826b79afb9265f235735f2 (patch)
treebbf5e45cd4b4ce8a3ac7754891ae69e7fcd41379 /meta/packages/pciutils/pciutils_2.2.4.bb
parentba9dd5228c290c96c622fb82964e49ce2511a1e9 (diff)
downloadpoky-f8ca66bdb7fff028d9826b79afb9265f235735f2.tar.gz
pciutils: added 2.2.4 from OE
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2054 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/pciutils/pciutils_2.2.4.bb')
-rw-r--r--meta/packages/pciutils/pciutils_2.2.4.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/packages/pciutils/pciutils_2.2.4.bb b/meta/packages/pciutils/pciutils_2.2.4.bb
new file mode 100644
index 0000000000..0cd335eb32
--- /dev/null
+++ b/meta/packages/pciutils/pciutils_2.2.4.bb
@@ -0,0 +1,38 @@
1DESCRIPTION = 'The PCI Utilities package contains a library for portable access \
2to PCI bus configuration space and several utilities based on this library.'
3DESCRIPTION_pciutils-ids = 'The list of PCI IDs for pciutils'
4SECTION = "console/utils"
5HOMEPAGE = "http://atrey.karlin.mff.cuni.cz/~mj/pciutils.shtml"
6LICENSE = "GPLv2"
7DEPENDS = "zlib"
8
9SRC_URI = "ftp://ftp.kernel.org/pub/software/utils/pciutils/pciutils-${PV}.tar.bz2 \
10 file://configure.patch;patch=1 \
11 file://configure-uclibc.patch;patch=1 \
12 file://pcimodules-pciutils.diff;patch=1"
13
14PARALLEL_MAKE = ""
15
16PR="r1"
17
18do_configure () {
19 (cd lib && ./configure ${datadir} ${PV} ${TARGET_OS} 2.4.21 ${TARGET_ARCH})
20}
21
22export PREFIX = "${D}${prefix}"
23export SBINDIR = "${D}${sbindir}"
24export SHAREDIR = "${D}${datadir}"
25export MANDIR = "${D}${mandir}"
26
27LDFLAGS += "-lz"
28
29do_install () {
30 oe_runmake install
31}
32do_install_append () {
33 install -d ${D}/${prefix}/share
34 install -m 6440 ${WORKDIR}/${PN}-${PV}/pci.ids ${D}/${prefix}/share
35}
36
37PACKAGES =+ "pciutils-ids"
38FILES_pciutils-ids="${prefix}/share/pci.ids"