summaryrefslogtreecommitdiffstats
path: root/meta/packages/orinoco
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-04-11 07:50:26 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-04-11 07:50:26 +0000
commit23b9718ff70049806a7d42900533d8d8a2d0631b (patch)
treedf6f68cc5dd965c3cc55ef6b4b95455c99c94c18 /meta/packages/orinoco
parent6427370753146b2a71a06df614f71e8df9de9a23 (diff)
downloadpoky-23b9718ff70049806a7d42900533d8d8a2d0631b.tar.gz
orinoco-modules: dropped as they are provided by 2.6 kernel now
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1475 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/orinoco')
-rw-r--r--meta/packages/orinoco/orinoco-modules-0.15rc2/add_event.patch56
-rw-r--r--meta/packages/orinoco/orinoco-modules-0.15rc2/add_utsname.patch21
-rw-r--r--meta/packages/orinoco/orinoco-modules-0.15rc2/catch-up-with-kernel-changes.patch48
-rw-r--r--meta/packages/orinoco/orinoco-modules-0.15rc2/list-move.patch22
-rw-r--r--meta/packages/orinoco/orinoco-modules-0.15rc2/makefile_fix.patch13
-rw-r--r--meta/packages/orinoco/orinoco-modules-0.15rc2/spectrum_cs_ids.patch101
-rw-r--r--meta/packages/orinoco/orinoco-modules_0.15rc2.bb37
7 files changed, 0 insertions, 298 deletions
diff --git a/meta/packages/orinoco/orinoco-modules-0.15rc2/add_event.patch b/meta/packages/orinoco/orinoco-modules-0.15rc2/add_event.patch
deleted file mode 100644
index f8b86f335b..0000000000
--- a/meta/packages/orinoco/orinoco-modules-0.15rc2/add_event.patch
+++ /dev/null
@@ -1,56 +0,0 @@
1Index: orinoco-0.15rc2/orinoco_cs.c
2===================================================================
3--- orinoco-0.15rc2.orig/orinoco_cs.c 2004-07-28 07:06:45.000000000 +0100
4+++ orinoco-0.15rc2/orinoco_cs.c 2005-08-03 18:38:34.000000000 +0100
5@@ -189,11 +189,13 @@
6
7 client_reg.dev_info = &dev_info;
8 client_reg.Attributes = INFO_IO_CLIENT | INFO_CARD_SHARE;
9+#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,13))
10 client_reg.EventMask =
11 CS_EVENT_CARD_INSERTION | CS_EVENT_CARD_REMOVAL |
12 CS_EVENT_RESET_PHYSICAL | CS_EVENT_CARD_RESET |
13 CS_EVENT_PM_SUSPEND | CS_EVENT_PM_RESUME;
14 client_reg.event_handler = &orinoco_cs_event;
15+#endif
16 client_reg.Version = 0x0210; /* FIXME: what does this mean? */
17 client_reg.event_callback_args.client_data = link;
18
19@@ -612,6 +614,9 @@
20 .name = DRIVER_NAME,
21 },
22 .attach = orinoco_cs_attach,
23+#if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,12))
24+ .event = orinoco_cs_event,
25+#endif
26 .detach = orinoco_cs_detach,
27 };
28
29Index: orinoco-0.15rc2/spectrum_cs.c
30===================================================================
31--- orinoco-0.15rc2.orig/spectrum_cs.c 2005-08-03 11:51:09.000000000 +0100
32+++ orinoco-0.15rc2/spectrum_cs.c 2005-08-03 18:38:46.000000000 +0100
33@@ -699,11 +699,13 @@
34
35 client_reg.dev_info = &dev_info;
36 client_reg.Attributes = INFO_IO_CLIENT | INFO_CARD_SHARE;
37+#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,13))
38 client_reg.EventMask =
39 CS_EVENT_CARD_INSERTION | CS_EVENT_CARD_REMOVAL |
40 CS_EVENT_RESET_PHYSICAL | CS_EVENT_CARD_RESET |
41 CS_EVENT_PM_SUSPEND | CS_EVENT_PM_RESUME;
42 client_reg.event_handler = &spectrum_cs_event;
43+#endif
44 client_reg.Version = 0x0210; /* FIXME: what does this mean? */
45 client_reg.event_callback_args.client_data = link;
46
47@@ -1096,6 +1098,9 @@
48 .name = DRIVER_NAME,
49 },
50 .attach = spectrum_cs_attach,
51+#if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,12))
52+ .event = spectrum_cs_event,
53+#endif
54 .detach = spectrum_cs_detach,
55 };
56
diff --git a/meta/packages/orinoco/orinoco-modules-0.15rc2/add_utsname.patch b/meta/packages/orinoco/orinoco-modules-0.15rc2/add_utsname.patch
deleted file mode 100644
index 7c2efec2f3..0000000000
--- a/meta/packages/orinoco/orinoco-modules-0.15rc2/add_utsname.patch
+++ /dev/null
@@ -1,21 +0,0 @@
1Index: orinoco-0.15rc1/kcompat.h
2===================================================================
3--- orinoco-0.15rc1.orig/kcompat.h 2005-08-03 14:51:18.000000000 +0000
4+++ orinoco-0.15rc1/kcompat.h 2005-08-03 15:11:02.000000000 +0000
5@@ -1,3 +1,4 @@
6+#include <linux/utsname.h>
7 #include <linux/version.h>
8
9 /********************************************************************/
10Index: orinoco-0.15rc2/orinoco.h
11===================================================================
12--- orinoco-0.15rc2.orig/orinoco.h 2004-07-28 07:06:45.000000000 +0100
13+++ orinoco-0.15rc2/orinoco.h 2005-08-03 18:43:46.000000000 +0100
14@@ -13,6 +13,7 @@
15 #include <linux/spinlock.h>
16 #include <linux/netdevice.h>
17 #include <linux/wireless.h>
18+#include <linux/utsname.h>
19 #include <linux/version.h>
20 #if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 4, 25)
21 #include <linux/moduleparam.h>
diff --git a/meta/packages/orinoco/orinoco-modules-0.15rc2/catch-up-with-kernel-changes.patch b/meta/packages/orinoco/orinoco-modules-0.15rc2/catch-up-with-kernel-changes.patch
deleted file mode 100644
index d2e8a5bc4c..0000000000
--- a/meta/packages/orinoco/orinoco-modules-0.15rc2/catch-up-with-kernel-changes.patch
+++ /dev/null
@@ -1,48 +0,0 @@
1diff -up orinoco-0.15rc2/orinoco_pci.c orinoco-0.15rc2-new/orinoco_pci.c
2--- orinoco-0.15rc2/orinoco_pci.c 2004-07-28 08:06:45.000000000 +0200
3+++ orinoco-0.15rc2-new/orinoco_pci.c 2005-06-19 17:13:07.000000000 +0200
4@@ -327,7 +327,7 @@ static int orinoco_pci_suspend(struct pc
5
6 orinoco_unlock(priv, &flags);
7
8- pci_save_state(pdev, card->pci_state);
9+ pci_save_state(pdev);
10 pci_set_power_state(pdev, 3);
11
12 return 0;
13@@ -344,7 +344,7 @@ static int orinoco_pci_resume(struct pci
14 printk(KERN_DEBUG "%s: Orinoco-PCI waking up\n", dev->name);
15
16 pci_set_power_state(pdev, 0);
17- pci_restore_state(pdev, card->pci_state);
18+ pci_restore_state(pdev);
19
20 err = orinoco_reinit_firmware(dev);
21 if (err) {
22diff -up orinoco-0.15rc2/spectrum_cs.c orinoco-0.15rc2-new/spectrum_cs.c
23--- orinoco-0.15rc2/spectrum_cs.c 2004-07-28 08:06:45.000000000 +0200
24+++ orinoco-0.15rc2-new/spectrum_cs.c 2005-06-19 18:06:39.000000000 +0200
25@@ -579,12 +579,13 @@ static int
26 spectrum_dl_firmware(hermes_t *hw, dev_link_t *link)
27 {
28 int ret;
29+ client_handle_t handle = link->handle;
30
31 #ifndef SPECTRUM_FW_INCLUDED
32 const struct firmware *fw_entry;
33
34 if (request_firmware(&fw_entry, primary_fw_name,
35- spectrum_cs_device) == 0) {
36+ &handle_to_dev(handle)) == 0) {
37 primsym = fw_entry->data;
38 } else {
39 printk(KERN_ERR PFX "Cannot find firmware: %s\n",
40@@ -593,7 +594,7 @@ spectrum_dl_firmware(hermes_t *hw, dev_l
41 }
42
43 if (request_firmware(&fw_entry, secondary_fw_name,
44- spectrum_cs_device) == 0) {
45+ &handle_to_dev(handle)) == 0) {
46 secsym = fw_entry->data;
47 } else {
48 printk(KERN_ERR PFX "Cannot find firmware: %s\n",
diff --git a/meta/packages/orinoco/orinoco-modules-0.15rc2/list-move.patch b/meta/packages/orinoco/orinoco-modules-0.15rc2/list-move.patch
deleted file mode 100644
index cd8bec0ec2..0000000000
--- a/meta/packages/orinoco/orinoco-modules-0.15rc2/list-move.patch
+++ /dev/null
@@ -1,22 +0,0 @@
1
2#
3# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
4#
5
6--- orinoco-0.15rc1/kcompat.h~list-move.patch 2004-04-19 07:08:24.000000000 +0200
7+++ orinoco-0.15rc1/kcompat.h 2004-06-15 19:16:17.000000000 +0200
8@@ -39,13 +39,12 @@
9 typedef void irqreturn_t;
10 #endif
11
12-#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,4,20))
13+#if 0
14 static inline void list_move(struct list_head *list, struct list_head *head)
15 {
16 __list_del(list->prev, list->next);
17 list_add(list, head);
18 }
19-
20 static inline void list_move_tail(struct list_head *list,
21 struct list_head *head)
22 {
diff --git a/meta/packages/orinoco/orinoco-modules-0.15rc2/makefile_fix.patch b/meta/packages/orinoco/orinoco-modules-0.15rc2/makefile_fix.patch
deleted file mode 100644
index 5421d40b10..0000000000
--- a/meta/packages/orinoco/orinoco-modules-0.15rc2/makefile_fix.patch
+++ /dev/null
@@ -1,13 +0,0 @@
1Index: orinoco-0.15rc2/Makefile
2===================================================================
3--- orinoco-0.15rc2.orig/Makefile 2004-07-28 07:06:45.000000000 +0100
4+++ orinoco-0.15rc2/Makefile 2005-05-24 00:09:07.000000000 +0100
5@@ -12,7 +12,7 @@
6
7 # The default kernel is the one you are running, but you may want to set
8 # it to another configured Linux source tree
9-KERNEL_SRC = $(shell readlink -f /lib/modules/`uname -r`/build)
10+KERNEL_SRC = $(KERNEL_SOURCE)
11
12 # Output directory that you used when building Linux kernel, if any.
13 # Note: this driver will be compiled to the current directory regardless.
diff --git a/meta/packages/orinoco/orinoco-modules-0.15rc2/spectrum_cs_ids.patch b/meta/packages/orinoco/orinoco-modules-0.15rc2/spectrum_cs_ids.patch
deleted file mode 100644
index 709e05a435..0000000000
--- a/meta/packages/orinoco/orinoco-modules-0.15rc2/spectrum_cs_ids.patch
+++ /dev/null
@@ -1,101 +0,0 @@
1Index: orinoco-0.15rc2/spectrum_cs.c
2===================================================================
3--- orinoco-0.15rc2.orig/spectrum_cs.c 2005-08-03 18:43:58.000000000 +0100
4+++ orinoco-0.15rc2/spectrum_cs.c 2005-08-03 22:27:03.000000000 +0100
5@@ -1092,6 +1092,17 @@
6 " (Pavel Roskin <proski@gnu.org>,"
7 " David Gibson <hermes@gibson.dropbear.id.au>, et al)";
8
9+#if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,12))
10+static struct pcmcia_device_id spectrum_cs_ids[] = {
11+ PCMCIA_DEVICE_MANF_CARD(0x026c, 0x0001),
12+ PCMCIA_DEVICE_MANF_CARD(0x0104, 0x0001),
13+ PCMCIA_DEVICE_MANF_CARD(0x0089, 0x0001),
14+ PCMCIA_DEVICE_PROD_ID12("Symbol", "Spectrum24 LA4100 Series WLAN PC Card", 0xd20d85fd, 0x63066cd9),
15+ PCMCIA_DEVICE_NULL,
16+};
17+MODULE_DEVICE_TABLE(pcmcia, spectrum_cs_ids);
18+#endif
19+
20 static struct pcmcia_driver orinoco_driver = {
21 .owner = THIS_MODULE,
22 .drv = {
23@@ -1100,6 +1111,7 @@
24 .attach = spectrum_cs_attach,
25 #if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,12))
26 .event = spectrum_cs_event,
27+ .id_table = spectrum_cs_ids,
28 #endif
29 .detach = spectrum_cs_detach,
30 };
31Index: orinoco-0.15rc2/orinoco_cs.c
32===================================================================
33--- orinoco-0.15rc2.orig/orinoco_cs.c 2005-08-03 18:43:55.000000000 +0100
34+++ orinoco-0.15rc2/orinoco_cs.c 2005-08-03 22:58:58.000000000 +0100
35@@ -608,6 +608,58 @@
36 " (David Gibson <hermes@gibson.dropbear.id.au>, "
37 "Pavel Roskin <proski@gnu.org>, et al)";
38
39+#if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,12))
40+static struct pcmcia_device_id orinoco_cs_ids[] = {
41+ PCMCIA_DEVICE_MANF_CARD(0x000b, 0x7300),
42+ PCMCIA_DEVICE_MANF_CARD(0x0089, 0x0001),
43+ PCMCIA_DEVICE_MANF_CARD(0x0138, 0x0002),
44+ PCMCIA_DEVICE_MANF_CARD(0x0156, 0x0002),
45+ PCMCIA_DEVICE_MANF_CARD(0x01eb, 0x080a),
46+ PCMCIA_DEVICE_MANF_CARD(0x0261, 0x0002),
47+ PCMCIA_DEVICE_MANF_CARD(0x0268, 0x0001),
48+ PCMCIA_DEVICE_MANF_CARD(0x026f, 0x0305),
49+ PCMCIA_DEVICE_MANF_CARD(0x0274, 0x1613),
50+ PCMCIA_DEVICE_MANF_CARD(0x028a, 0x0002),
51+ PCMCIA_DEVICE_MANF_CARD(0x028a, 0x0673),
52+ PCMCIA_DEVICE_MANF_CARD(0x02aa, 0x0002),
53+ PCMCIA_DEVICE_MANF_CARD(0x02ac, 0x0002),
54+ PCMCIA_DEVICE_MANF_CARD(0x14ea, 0xb001),
55+ PCMCIA_DEVICE_MANF_CARD(0x50c2, 0x7300),
56+ PCMCIA_DEVICE_MANF_CARD(0x9005, 0x0021),
57+ PCMCIA_DEVICE_MANF_CARD(0xc250, 0x0002),
58+ PCMCIA_DEVICE_MANF_CARD(0xd601, 0x0002),
59+ PCMCIA_DEVICE_MANF_CARD(0xd601, 0x0002),
60+ PCMCIA_DEVICE_MANF_CARD(0xd601, 0x0005),
61+ PCMCIA_DEVICE_MANF_CARD(0xd601, 0x0005),
62+ PCMCIA_DEVICE_PROD_ID12("3Com", "3CRWE737A AirConnect Wireless LAN PC Card", 0x41240e5b, 0x56010af3),
63+ PCMCIA_DEVICE_PROD_ID123("Instant Wireless ", " Network PC CARD", "Version 01.02", 0x11d901af, 0x6e9bd926, 0x4b74baa0),
64+ PCMCIA_DEVICE_PROD_ID12("ACTIONTEC", "PRISM Wireless LAN PC Card", 0x393089da, 0xa71e69d5),
65+ PCMCIA_DEVICE_PROD_ID12("Avaya Communication", "Avaya Wireless PC Card", 0xd8a43b78, 0x0d341169),
66+ PCMCIA_DEVICE_PROD_ID12("BUFFALO", "WLI-PCM-L11G", 0x2decece3, 0xf57ca4b3),
67+ PCMCIA_DEVICE_PROD_ID12("Cabletron", "RoamAbout 802.11 DS", 0x32d445f5, 0xedeffd90),
68+ PCMCIA_DEVICE_PROD_ID12("corega K.K.", "Wireless LAN PCC-11", 0x5261440f, 0xa6405584),
69+ PCMCIA_DEVICE_PROD_ID12("corega K.K.", "Wireless LAN PCCA-11", 0x5261440f, 0xdf6115f9),
70+ PCMCIA_DEVICE_PROD_ID12("D", "Link DRC-650 11Mbps WLAN Card", 0x71b18589, 0xf144e3ac),
71+ PCMCIA_DEVICE_PROD_ID12("D", "Link DWL-650 11Mbps WLAN Card", 0x71b18589, 0xb6f1b0ab),
72+ PCMCIA_DEVICE_PROD_ID12("ELSA", "AirLancer MC-11", 0x4507a33a, 0xef54f0e3),
73+ PCMCIA_DEVICE_PROD_ID12("HyperLink", "Wireless PC Card 11Mbps", 0x56cc3f1a, 0x0bcf220c),
74+ PCMCIA_DEVICE_PROD_ID12("INTERSIL", "HFA384x/IEEE", 0x74c5e40d, 0xdb472a18),
75+ PCMCIA_DEVICE_PROD_ID12("Lucent Technologies", "WaveLAN/IEEE", 0x23eb9949, 0xc562e72a),
76+ PCMCIA_DEVICE_PROD_ID12("MELCO", "WLI-PCM-L11", 0x481e0094, 0x7360e410),
77+ PCMCIA_DEVICE_PROD_ID12("MELCO", "WLI-PCM-L11G", 0x481e0094, 0xf57ca4b3),
78+ PCMCIA_DEVICE_PROD_ID12("Microsoft", "Wireless Notebook Adapter MN-520", 0x5961bf85, 0x6eec8c01),
79+ PCMCIA_DEVICE_PROD_ID12("NCR", "WaveLAN/IEEE", 0x24358cd4, 0xc562e72a),
80+ PCMCIA_DEVICE_PROD_ID12("NETGEAR MA401RA Wireless PC", "Card", 0x0306467f, 0x9762e8f1),
81+ PCMCIA_DEVICE_PROD_ID12("PLANEX", "GeoWave/GW-CF110", 0x209f40ab, 0xd9715264),
82+ PCMCIA_DEVICE_PROD_ID12("PROXIM", "LAN PC CARD HARMONY 80211B", 0xc6536a5e, 0x090c3cd9),
83+ PCMCIA_DEVICE_PROD_ID12("PROXIM", "LAN PCI CARD HARMONY 80211B", 0xc6536a5e, 0x9f494e26),
84+ PCMCIA_DEVICE_PROD_ID12("SAMSUNG", "11Mbps WLAN Card", 0x43d74cb4, 0x579bd91b),
85+ PCMCIA_DEVICE_PROD_ID1("Symbol Technologies", 0x3f02b4d6),
86+ PCMCIA_DEVICE_NULL,
87+};
88+MODULE_DEVICE_TABLE(pcmcia, orinoco_cs_ids);
89+#endif
90+
91 static struct pcmcia_driver orinoco_driver = {
92 .owner = THIS_MODULE,
93 .drv = {
94@@ -616,6 +668,7 @@
95 .attach = orinoco_cs_attach,
96 #if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,12))
97 .event = orinoco_cs_event,
98+ .id_table = orinoco_cs_ids,
99 #endif
100 .detach = orinoco_cs_detach,
101 };
diff --git a/meta/packages/orinoco/orinoco-modules_0.15rc2.bb b/meta/packages/orinoco/orinoco-modules_0.15rc2.bb
deleted file mode 100644
index b31f1bf6c2..0000000000
--- a/meta/packages/orinoco/orinoco-modules_0.15rc2.bb
+++ /dev/null
@@ -1,37 +0,0 @@
1DESCRIPTION = "A driver for wireless LAN cards based on Hermes(Orinoco) cards. \
2Also contains support for cards using downloadable firmware, i.e. the Symbol/Socket family."
3SECTION = "kernel/modules"
4PRIORITY = "optional"
5PROVIDES = "spectrum-modules"
6DEPENDS = "orinoco-conf spectrum-fw"
7RDEPENDS = "orinoco-conf"
8LICENSE = "GPL"
9PR = "r9"
10
11SRC_URI = "http://ozlabs.org/people/dgibson/dldwd/orinoco-${PV}.tar.gz \
12 file://makefile_fix.patch;patch=1 \
13 file://list-move.patch;patch=1 \
14 file://add_utsname.patch;patch=1 \
15 file://add_event.patch;patch=1 \
16 file://spectrum_cs_ids.patch;patch=1 \
17 file://catch-up-with-kernel-changes.patch;patch=1"
18S = "${WORKDIR}/orinoco-${PV}"
19
20inherit module
21
22do_install() {
23 install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
24 install -m 0644 *${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
25}
26
27PACKAGES = "orinoco-modules-cs orinoco-modules-pci orinoco-modules-usb orinoco-modules-nortel orinoco-modules"
28FILES_orinoco-modules-cs = "/lib/modules/${KERNEL_VERSION}/net/*_cs${KERNEL_OBJECT_SUFFIX}"
29FILES_orinoco-modules-pci = "/lib/modules/${KERNEL_VERSION}/net/orinoco_p*${KERNEL_OBJECT_SUFFIX}"
30FILES_orinoco-modules-usb = "/lib/modules/${KERNEL_VERSION}/net/*_usb${KERNEL_OBJECT_SUFFIX}"
31FILES_orinoco-modules-nortel = "/lib/modules/${KERNEL_VERSION}/net/orinoco_tmd${KERNEL_OBJECT_SUFFIX} \
32 /lib/modules/${KERNEL_VERSION}/net/orinoco_nortel${KERNEL_OBJECT_SUFFIX}"
33FILES_orinoco-modules = "/lib/modules/"
34RDEPENDS_orinoco-modules-cs = "orinoco-modules spectrum-fw"
35RDEPENDS_orinoco-modules-pci = "orinoco-modules"
36RDEPENDS_orinoco-modules-usb = "orinoco-modules"
37RDEPENDS_orinoco-modules-nortel = "orinoco-modules"