summaryrefslogtreecommitdiffstats
path: root/meta/packages/oprofile
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2007-05-30 10:27:06 +0000
committerRichard Purdie <richard@openedhand.com>2007-05-30 10:27:06 +0000
commit351a196c49ee18cc0e26049ab4e6ee1439cb641d (patch)
tree1729a950b0d7c8e762b1f85c52de2d07f67ccbde /meta/packages/oprofile
parentacb45ff67a231480145dd44ec427ae62a6a16260 (diff)
downloadpoky-351a196c49ee18cc0e26049ab4e6ee1439cb641d.tar.gz
oprofile: Update SRCDATE, remove merged patches
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1818 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/oprofile')
-rw-r--r--meta/packages/oprofile/oprofile/armv6_events.patch102
-rw-r--r--meta/packages/oprofile/oprofile/oparchive-debug-dir.patch52
-rw-r--r--meta/packages/oprofile/oprofile/oparchive-list-files.patch131
-rw-r--r--meta/packages/oprofile/oprofile/xscale_events.patch39
-rw-r--r--meta/packages/oprofile/oprofile_cvs.bb5
5 files changed, 1 insertions, 328 deletions
diff --git a/meta/packages/oprofile/oprofile/armv6_events.patch b/meta/packages/oprofile/oprofile/armv6_events.patch
deleted file mode 100644
index cbe6efef8e..0000000000
--- a/meta/packages/oprofile/oprofile/armv6_events.patch
+++ /dev/null
@@ -1,102 +0,0 @@
1---
2 events/arm/armv6/events | 9 ++++++---
3 events/arm/armv6/unit_masks | 2 +-
4 libop/op_cpu_type.c | 2 +-
5 libop/op_cpu_type.h | 2 +-
6 libop/op_events.c | 5 +----
7 utils/ophelp.c | 2 +-
8 6 files changed, 11 insertions(+), 11 deletions(-)
9
10Index: oprofile/events/arm/armv6/events
11===================================================================
12--- oprofile.orig/events/arm/armv6/events 2007-05-23 15:02:33.000000000 +0100
13+++ oprofile/events/arm/armv6/events 2007-05-24 00:33:41.000000000 +0100
14@@ -1,4 +1,4 @@
15-# ARM11 events
16+# ARM V6 events
17 #
18 event:0x00 counters:1,2 um:zero minimum:500 name:IFU_IFETCH_MISS : number of instruction fetch misses
19 event:0x01 counters:1,2 um:zero minimum:500 name:CYCLES_IFU_MEM_STALL : cycles instruction fetch pipe is stalled
20@@ -17,5 +17,8 @@ event:0x0f counters:1,2 um:zero minimum:
21 event:0x10 counters:1,2 um:zero minimum:500 name:EXP_EXTERNAL : Explict external data access
22 event:0x11 counters:1,2 um:zero minimum:500 name:LSU_STALL : cycles stalled because Load Store request queque is full
23 event:0x12 counters:1,2 um:zero minimum:500 name:WRITE_DRAIN : Times write buffer was drained
24-event:0xff counters:0 um:zero minimum:500 name:CPU_CYCLES : clock cycles counter
25-#
26+event:0x20 counters:1,2 um:zero minimum:500 name:ETMEXTOUT0 : nuber of cycles ETMEXTOUT[0] signal was asserted
27+event:0x21 counters:1,2 um:zero minimum:500 name:ETMEXTOUT1 : nuber of cycles ETMEXTOUT[1] signal was asserted
28+event:0x22 counters:1,2 um:zero minimum:500 name:ETMEXTOUT_BOTH : nuber of cycles both ETMEXTOUT [0] and [1] were asserted * 2
29+event:0xff counters:1,2 um:zero minimum:500 name:CPU_CYCLES2 : clock cycles counter
30+event:0xfe counters:0 um:zero minimum:500 name:CPU_CYCLES : clock cycles counter
31Index: oprofile/events/arm/armv6/unit_masks
32===================================================================
33--- oprofile.orig/events/arm/armv6/unit_masks 2007-05-23 15:02:33.000000000 +0100
34+++ oprofile/events/arm/armv6/unit_masks 2007-05-23 15:28:24.000000000 +0100
35@@ -1,4 +1,4 @@
36-# Arm11 possible unit masks
37+# ARM V6 PMU possible unit masks
38 #
39 name:zero type:mandatory default:0x00
40 0x00 No unit mask
41Index: oprofile/libop/op_cpu_type.c
42===================================================================
43--- oprofile.orig/libop/op_cpu_type.c 2007-05-24 00:17:01.000000000 +0100
44+++ oprofile/libop/op_cpu_type.c 2007-05-24 00:26:34.000000000 +0100
45@@ -70,7 +70,7 @@ static struct cpu_descr const cpu_descrs
46 { "AMD64 family10", "x86-64/family10", CPU_FAMILY10, 4 },
47 { "ppc64 PA6T", "ppc64/pa6t", CPU_PPC64_PA6T, 6 },
48 { "ARM MPCore", "arm/mpcore", CPU_ARM_MPCORE, 2 },
49- { "ARM11 PMU", "arm/armv6", CPU_ARM_ARM11, 3 },
50+ { "ARM V6 PMU", "arm/armv6", CPU_ARM_V6, 3 },
51 };
52
53 static size_t const nr_cpu_descrs = sizeof(cpu_descrs) / sizeof(struct cpu_descr);
54Index: oprofile/libop/op_cpu_type.h
55===================================================================
56--- oprofile.orig/libop/op_cpu_type.h 2007-05-24 00:17:01.000000000 +0100
57+++ oprofile/libop/op_cpu_type.h 2007-05-24 00:26:50.000000000 +0100
58@@ -68,7 +68,7 @@ typedef enum {
59 CPU_FAMILY10, /**< AMD family 10 */
60 CPU_PPC64_PA6T, /**< ppc64 PA6T */
61 CPU_ARM_MPCORE, /**< ARM MPCore */
62- CPU_ARM_ARM11, /**< ARM11 */
63+ CPU_ARM_V6, /**< ARM V6 */
64 MAX_CPU_TYPE
65 } op_cpu;
66
67Index: oprofile/libop/op_events.c
68===================================================================
69--- oprofile.orig/libop/op_events.c 2007-05-24 00:17:01.000000000 +0100
70+++ oprofile/libop/op_events.c 2007-05-24 00:27:49.000000000 +0100
71@@ -786,6 +786,7 @@ void op_default_event(op_cpu cpu_type, s
72 case CPU_ARM_XSCALE1:
73 case CPU_ARM_XSCALE2:
74 case CPU_ARM_MPCORE:
75+ case CPU_ARM_V6:
76 descr->name = "CPU_CYCLES";
77 break;
78
79@@ -842,10 +843,6 @@ void op_default_event(op_cpu cpu_type, s
80 descr->name = "CPU_CLK";
81 break;
82
83- case CPU_ARM_ARM11:
84- descr->name = "CPU_CYCLES";
85- break;
86-
87 // don't use default, if someone add a cpu he wants a compiler
88 // warning if he forgets to handle it here.
89 case CPU_TIMER_INT:
90Index: oprofile/utils/ophelp.c
91===================================================================
92--- oprofile.orig/utils/ophelp.c 2007-05-24 00:17:12.000000000 +0100
93+++ oprofile/utils/ophelp.c 2007-05-24 00:26:08.000000000 +0100
94@@ -429,7 +429,7 @@ int main(int argc, char const * argv[])
95 "Page 3-70, performance counters\n");
96 break;
97
98- case CPU_ARM_ARM11:
99+ case CPU_ARM_V6:
100 printf("See ARM11 Technical Reference Manual\n");
101 break;
102
diff --git a/meta/packages/oprofile/oprofile/oparchive-debug-dir.patch b/meta/packages/oprofile/oprofile/oparchive-debug-dir.patch
deleted file mode 100644
index ab925c9048..0000000000
--- a/meta/packages/oprofile/oprofile/oparchive-debug-dir.patch
+++ /dev/null
@@ -1,52 +0,0 @@
1Index: oprofile/pp/oparchive.cpp
2===================================================================
3--- oprofile.orig/pp/oparchive.cpp
4+++ oprofile/pp/oparchive.cpp
5@@ -84,9 +84,10 @@ int oparchive(options::spec const & spec
6 exe_archive_file);
7
8 /* If there are any debuginfo files, copy them over.
9- * Need to copy the debug info file in the same
10- * directory as the executable. The /usr/lib/debug
11- * search path is not going to work.
12+ * Need to copy the debug info file to somewhere we'll
13+ * find it - executable location + "/.debug"
14+ * to avoid overwriting files with the same name. The
15+ * /usr/lib/debug search path is not going to work.
16 */
17 bfd * ibfd = open_bfd(exe_name);
18 if (ibfd) {
19@@ -97,8 +98,15 @@ int oparchive(options::spec const & spec
20 if (find_separate_debug_file(ibfd, dirname, global,
21 debug_filename)) {
22 /* found something copy it over */
23- string dest_debug = options::outdirectory +
24- dirname + "/" +
25+ string dest_debug_dir = options::outdirectory +
26+ dirname + "/.debug/";
27+ if (create_dir(dest_debug_dir.c_str())) {
28+ cerr << "Unable to create directory: "
29+ << dest_debug_dir << "." << endl;
30+ exit (EXIT_FAILURE);
31+ }
32+
33+ string dest_debug = dest_debug_dir +
34 op_basename(debug_filename);
35 copy_one_file(image_ok, debug_filename, dest_debug);
36 }
37Index: oprofile/ChangeLog
38===================================================================
39--- oprofile.orig/ChangeLog
40+++ oprofile/ChangeLog
41@@ -1,5 +1,11 @@
42 2007-05-09 Richard Purdie <rpurdie@openedhand.com>
43
44+ * oprofile/pp/oparchive.cpp: If the debug files have the same name
45+ as the original binary, the binary gets overwritten. Add in a .debug
46+ directory to avoid this.
47+
48+2007-05-09 Richard Purdie <rpurdie@openedhand.com>
49+
50 * oprofile/daemon/opd_cookie.c: Fix syscall for ARM EABI
51
52 2007-04-25 Manoj Ekbote <manoj.ekbote@broadcom.com>
diff --git a/meta/packages/oprofile/oprofile/oparchive-list-files.patch b/meta/packages/oprofile/oprofile/oparchive-list-files.patch
deleted file mode 100644
index 8d92efead6..0000000000
--- a/meta/packages/oprofile/oprofile/oparchive-list-files.patch
+++ /dev/null
@@ -1,131 +0,0 @@
1Index: oprofile/pp/oparchive.cpp
2===================================================================
3--- oprofile.orig/pp/oparchive.cpp
4+++ oprofile/pp/oparchive.cpp
5@@ -35,6 +35,11 @@ namespace {
6
7 void copy_one_file(image_error err, string const & source, string const & dest)
8 {
9+ if (options::list_files) {
10+ cout << source << endl;
11+ return;
12+ }
13+
14 if (!copy_file(source, dest) && err == image_ok) {
15 cerr << "can't copy from " << source << " to " << dest
16 << " cause: " << strerror(errno) << endl;
17@@ -46,7 +51,7 @@ int oparchive(options::spec const & spec
18 handle_options(spec);
19
20 /* Check to see if directory can be created */
21- if (create_path(options::outdirectory.c_str())) {
22+ if (!options::list_files && create_path(options::outdirectory.c_str())) {
23 cerr << "Unable to create directory for "
24 << options::outdirectory << "." << endl;
25 exit (EXIT_FAILURE);
26@@ -73,7 +78,8 @@ int oparchive(options::spec const & spec
27
28 cverb << vdebug << exe_name << endl;
29 /* Create directory for executable file. */
30- if (create_path(exe_archive_file.c_str())) {
31+ if (!options::list_files
32+ && create_path(exe_archive_file.c_str())) {
33 cerr << "Unable to create directory for "
34 << exe_archive_file << "." << endl;
35 exit (EXIT_FAILURE);
36@@ -100,7 +106,8 @@ int oparchive(options::spec const & spec
37 /* found something copy it over */
38 string dest_debug_dir = options::outdirectory +
39 dirname + "/.debug/";
40- if (create_dir(dest_debug_dir.c_str())) {
41+ if (!options::list_files
42+ && create_dir(dest_debug_dir.c_str())) {
43 cerr << "Unable to create directory: "
44 << dest_debug_dir << "." << endl;
45 exit (EXIT_FAILURE);
46@@ -130,7 +137,8 @@ int oparchive(options::spec const & spec
47
48 cverb << vdebug << (sample_name) << endl;
49 cverb << vdebug << " destp " << sample_archive_file << endl;
50- if (create_path(sample_archive_file.c_str())) {
51+ if (!options::list_files
52+ && create_path(sample_archive_file.c_str())) {
53 cerr << "Unable to create directory for "
54 << sample_archive_file << "." << endl;
55 exit (EXIT_FAILURE);
56Index: oprofile/pp/oparchive_options.cpp
57===================================================================
58--- oprofile.orig/pp/oparchive_options.cpp
59+++ oprofile/pp/oparchive_options.cpp
60@@ -36,6 +36,7 @@ namespace options {
61 bool exclude_dependent;
62 merge_option merge_by;
63 string outdirectory;
64+ bool list_files;
65 }
66
67
68@@ -47,7 +48,9 @@ popt::option options_array[] = {
69 popt::option(options::outdirectory, "output-directory", 'o',
70 "output to the given directory", "directory"),
71 popt::option(options::exclude_dependent, "exclude-dependent", 'x',
72- "exclude libs, kernel, and module samples for applications")
73+ "exclude libs, kernel, and module samples for applications"),
74+ popt::option(options::list_files, "list-files", 'l',
75+ "just list the files necessary, don't produce the archive")
76 };
77
78
79@@ -60,7 +63,7 @@ void check_options()
80 using namespace options;
81
82 /* output directory is required */
83- if (outdirectory.size() == 0) {
84+ if (outdirectory.size() == 0 && !list_files) {
85 cerr << "Requires --output-directory option." << endl;
86 exit(EXIT_FAILURE);
87 }
88Index: oprofile/pp/oparchive_options.h
89===================================================================
90--- oprofile.orig/pp/oparchive_options.h
91+++ oprofile/pp/oparchive_options.h
92@@ -22,6 +22,7 @@ namespace options {
93 extern bool exclude_dependent;
94 extern merge_option merge_by;
95 extern std::string outdirectory;
96+ extern bool list_files;
97 }
98
99 /// All the chosen sample files.
100Index: oprofile/ChangeLog
101===================================================================
102--- oprofile.orig/ChangeLog
103+++ oprofile/ChangeLog
104@@ -1,5 +1,12 @@
105 2007-05-09 Richard Purdie <rpurdie@openedhand.com>
106
107+ * oparchive.cpp:
108+ * oparchive_options.cpp:
109+ * oparchive_options.h: Add --list-files option to list all files that
110+ would be handled by oparchive.
111+
112+2007-05-09 Richard Purdie <rpurdie@openedhand.com>
113+
114 * oprofile/pp/oparchive.cpp: If the debug files have the same name
115 as the original binary, the binary gets overwritten. Add in a .debug
116 directory to avoid this.
117Index: oprofile/doc/oparchive.1.in
118===================================================================
119--- oprofile.orig/doc/oparchive.1.in
120+++ oprofile/doc/oparchive.1.in
121@@ -50,6 +50,10 @@ Output to the given directory. There is
122 Do not include application-specific images for libraries, kernel modules
123 and the kernel. This option only makes sense if the profile session
124 used --separate.
125+.br
126+.TP
127+.BI "--list-files / -l"
128+Only list the files that would be archived, don't copy them.
129
130 .SH ENVIRONMENT
131 No special environment variables are recognised by oparchive.
diff --git a/meta/packages/oprofile/oprofile/xscale_events.patch b/meta/packages/oprofile/oprofile/xscale_events.patch
deleted file mode 100644
index 7f5d1f2bd0..0000000000
--- a/meta/packages/oprofile/oprofile/xscale_events.patch
+++ /dev/null
@@ -1,39 +0,0 @@
1---
2 events/arm/xscale1/events | 8 ++++++--
3 events/arm/xscale2/events | 8 ++++++--
4 2 files changed, 12 insertions(+), 4 deletions(-)
5
6Index: oprofile/events/arm/xscale1/events
7===================================================================
8--- oprofile.orig/events/arm/xscale1/events 2004-04-06 05:32:22.000000000 +0100
9+++ oprofile/events/arm/xscale1/events 2007-05-23 13:37:04.000000000 +0100
10@@ -14,6 +14,10 @@ event:0x0a counters:1,2 um:zero minimum:
11 event:0x0b counters:1,2 um:zero minimum:500 name:DCACHE_MISS : data cache miss
12 event:0x0c counters:1,2 um:zero minimum:500 name:DCACHE_WB : data cache writeback, 1 event for every half cacheline
13 event:0x0d counters:1,2 um:zero minimum:500 name:PC_CHANGE : number of times the program counter was changed without a mode switch
14+event:0x10 counters:1,2 um:zero minimum:500 name:BCU_REQUEST : number of time the BCU received a new memory request from the core
15+event:0x11 counters:1,2 um:zero minimum:500 name:BCU_FULL : number of cycles the BCUs request queue is full
16+event:0x12 counters:1,2 um:zero minimum:500 name:BCU_DRAIN : number of times the BCU queues were drained due to a Drain Write Buffer command or an I/O transaction on a non-cacheable and non-bufferable page
17+event:0x14 counters:1,2 um:zero minimum:500 name:BCU_ECC_NO_ELOG : number of times the BCU detected an ECC error, but no ELOG register was available in which to log the error
18+event:0x15 counters:1,2 um:zero minimum:500 name:BCU_1_BIT_ERR : number of times the BCU detected a 1-bit error while reading data from the bus
19+event:0x16 counters:1,2 um:zero minimum:500 name:RMW : number of times an RMW cycle occurred due to narrow write on ECC-protected memory
20 event:0xfe counters:0 um:zero minimum:500 name:CPU_CYCLES : clock cycles counter
21-#0x10 through 0x17 Defined by ASSP. See the Intel® XScale" core implementation option section of the ASSP
22-#architecture specification for more details.
23Index: oprofile/events/arm/xscale2/events
24===================================================================
25--- oprofile.orig/events/arm/xscale2/events 2004-04-06 05:32:23.000000000 +0100
26+++ oprofile/events/arm/xscale2/events 2007-05-23 13:37:34.000000000 +0100
27@@ -14,6 +14,10 @@ event:0x0a counters:1,2,3,4 um:zero mini
28 event:0x0b counters:1,2,3,4 um:zero minimum:500 name:DCACHE_MISS : data cache miss
29 event:0x0c counters:1,2,3,4 um:zero minimum:500 name:DCACHE_WB : data cache writeback, 1 event for every half cacheline
30 event:0x0d counters:1,2,3,4 um:zero minimum:500 name:PC_CHANGE : number of times the program counter was changed without a mode switch
31+event:0x10 counters:1,2,3,4 um:zero minimum:500 name:BCU_REQUEST : number of time the BCU received a new memory request from the core
32+event:0x11 counters:1,2,3,4 um:zero minimum:500 name:BCU_FULL : number of cycles the BCUs request queue is full
33+event:0x12 counters:1,2,3,4 um:zero minimum:500 name:BCU_DRAIN : number of times the BCU queues were drained due to a Drain Write Buffer command or an I/O transaction on a non-cacheable and non-bufferable page
34+event:0x14 counters:1,2,3,4 um:zero minimum:500 name:BCU_ECC_NO_ELOG : number of times the BCU detected an ECC error, but no ELOG register was available in which to log the error
35+event:0x15 counters:1,2,3,4 um:zero minimum:500 name:BCU_1_BIT_ERR : number of times the BCU detected a 1-bit error while reading data from the bus
36+event:0x16 counters:1,2,3,4 um:zero minimum:500 name:RMW : number of times an RMW cycle occurred due to narrow write on ECC-protected memory
37 event:0xfe counters:0 um:zero minimum:500 name:CPU_CYCLES : clock cycles counter
38-#0x10 through 0x17 Defined by ASSP. See the Intel® XScale" core implementation option section of the ASSP
39-#architecture specification for more details.
diff --git a/meta/packages/oprofile/oprofile_cvs.bb b/meta/packages/oprofile/oprofile_cvs.bb
index e33820c9cf..18b3f371e5 100644
--- a/meta/packages/oprofile/oprofile_cvs.bb
+++ b/meta/packages/oprofile/oprofile_cvs.bb
@@ -1,5 +1,5 @@
1PV = "0.9.2+cvs${SRCDATE}" 1PV = "0.9.2+cvs${SRCDATE}"
2PR = "r6" 2PR = "r0"
3SECTION = "devel" 3SECTION = "devel"
4DESCRIPTION = "OProfile is a system-wide profiler for Linux systems, capable \ 4DESCRIPTION = "OProfile is a system-wide profiler for Linux systems, capable \
5of profiling all running code at low overhead." 5of profiling all running code at low overhead."
@@ -7,9 +7,6 @@ LICENSE = "GPL"
7DEPENDS = "popt binutils" 7DEPENDS = "popt binutils"
8 8
9SRC_URI = "cvs://anonymous@oprofile.cvs.sourceforge.net/cvsroot/oprofile;module=oprofile \ 9SRC_URI = "cvs://anonymous@oprofile.cvs.sourceforge.net/cvsroot/oprofile;module=oprofile \
10 file://oparchive-debug-dir.patch;patch=1 \
11 file://armv6_events.patch;patch=1 \
12 file://xscale_events.patch;patch=1 \
13 file://acinclude.m4" 10 file://acinclude.m4"
14S = "${WORKDIR}/oprofile" 11S = "${WORKDIR}/oprofile"
15 12