summaryrefslogtreecommitdiffstats
path: root/meta/packages/mozilla-headless/mozilla-headless/configurefix.patch
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-12-10 14:00:23 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2009-12-10 14:00:23 +0000
commit7ab7ad82f47d17e629288e67dd94660722899f9e (patch)
tree625110c9e90908784a4d282b4e990c26ea1ed2dc /meta/packages/mozilla-headless/mozilla-headless/configurefix.patch
parent9e278010556d1a6bc5ba3bbf8c1aee976d4a64e4 (diff)
downloadpoky-7ab7ad82f47d17e629288e67dd94660722899f9e.tar.gz
mozilla-headless: Update to work with recent git changes
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/mozilla-headless/mozilla-headless/configurefix.patch')
-rw-r--r--meta/packages/mozilla-headless/mozilla-headless/configurefix.patch194
1 files changed, 102 insertions, 92 deletions
diff --git a/meta/packages/mozilla-headless/mozilla-headless/configurefix.patch b/meta/packages/mozilla-headless/mozilla-headless/configurefix.patch
index d31f91a42d..7ee1211f1a 100644
--- a/meta/packages/mozilla-headless/mozilla-headless/configurefix.patch
+++ b/meta/packages/mozilla-headless/mozilla-headless/configurefix.patch
@@ -1,8 +1,8 @@
1Index: offscreen/configure.in 1Index: offscreen/configure.in
2=================================================================== 2===================================================================
3--- offscreen.orig/configure.in 2009-06-12 14:15:55.000000000 +0100 3--- offscreen.orig/configure.in 2009-12-09 13:10:12.000000000 +0000
4+++ offscreen/configure.in 2009-06-12 14:15:55.000000000 +0100 4+++ offscreen/configure.in 2009-12-09 13:38:51.000000000 +0000
5@@ -62,7 +62,6 @@ 5@@ -64,7 +64,6 @@
6 6
7 AC_PREREQ(2.13) 7 AC_PREREQ(2.13)
8 AC_INIT(config/config.mk) 8 AC_INIT(config/config.mk)
@@ -10,7 +10,7 @@ Index: offscreen/configure.in
10 AC_CANONICAL_SYSTEM 10 AC_CANONICAL_SYSTEM
11 TARGET_CPU="${target_cpu}" 11 TARGET_CPU="${target_cpu}"
12 TARGET_VENDOR="${target_vendor}" 12 TARGET_VENDOR="${target_vendor}"
13@@ -103,7 +102,6 @@ 13@@ -106,7 +105,6 @@
14 _SUBDIR_HOST_CFLAGS="$HOST_CFLAGS" 14 _SUBDIR_HOST_CFLAGS="$HOST_CFLAGS"
15 _SUBDIR_HOST_CXXFLAGS="$HOST_CXXFLAGS" 15 _SUBDIR_HOST_CXXFLAGS="$HOST_CXXFLAGS"
16 _SUBDIR_HOST_LDFLAGS="$HOST_LDFLAGS" 16 _SUBDIR_HOST_LDFLAGS="$HOST_LDFLAGS"
@@ -18,7 +18,7 @@ Index: offscreen/configure.in
18 18
19 dnl Set the version number of the libs included with mozilla 19 dnl Set the version number of the libs included with mozilla
20 dnl ======================================================== 20 dnl ========================================================
21@@ -135,6 +133,9 @@ 21@@ -139,6 +137,9 @@
22 22
23 MSMANIFEST_TOOL= 23 MSMANIFEST_TOOL=
24 24
@@ -28,7 +28,7 @@ Index: offscreen/configure.in
28 dnl Set various checks 28 dnl Set various checks
29 dnl ======================================================== 29 dnl ========================================================
30 MISSING_X= 30 MISSING_X=
31@@ -285,7 +286,7 @@ 31@@ -308,7 +309,7 @@
32 ;; 32 ;;
33 esac 33 esac
34 34
@@ -37,7 +37,7 @@ Index: offscreen/configure.in
37 echo "cross compiling from $host to $target" 37 echo "cross compiling from $host to $target"
38 cross_compiling=yes 38 cross_compiling=yes
39 39
40@@ -323,7 +324,7 @@ 40@@ -346,7 +347,7 @@
41 41
42 AC_MSG_CHECKING([whether the host c compiler ($HOST_CC $HOST_CFLAGS $HOST_LDFLAGS) works]) 42 AC_MSG_CHECKING([whether the host c compiler ($HOST_CC $HOST_CFLAGS $HOST_LDFLAGS) works])
43 AC_TRY_COMPILE([], [return(0);], 43 AC_TRY_COMPILE([], [return(0);],
@@ -46,7 +46,7 @@ Index: offscreen/configure.in
46 AC_MSG_ERROR([installation or configuration problem: host compiler $HOST_CC cannot create executables.]) ) 46 AC_MSG_ERROR([installation or configuration problem: host compiler $HOST_CC cannot create executables.]) )
47 47
48 CC="$HOST_CXX" 48 CC="$HOST_CXX"
49@@ -331,7 +332,7 @@ 49@@ -354,7 +355,7 @@
50 50
51 AC_MSG_CHECKING([whether the host c++ compiler ($HOST_CXX $HOST_CXXFLAGS $HOST_LDFLAGS) works]) 51 AC_MSG_CHECKING([whether the host c++ compiler ($HOST_CXX $HOST_CXXFLAGS $HOST_LDFLAGS) works])
52 AC_TRY_COMPILE([], [return(0);], 52 AC_TRY_COMPILE([], [return(0);],
@@ -55,7 +55,7 @@ Index: offscreen/configure.in
55 AC_MSG_ERROR([installation or configuration problem: host compiler $HOST_CXX cannot create executables.]) ) 55 AC_MSG_ERROR([installation or configuration problem: host compiler $HOST_CXX cannot create executables.]) )
56 56
57 CC=$_SAVE_CC 57 CC=$_SAVE_CC
58@@ -352,7 +353,7 @@ 58@@ -375,7 +376,7 @@
59 ;; 59 ;;
60 esac 60 esac
61 61
@@ -64,7 +64,7 @@ Index: offscreen/configure.in
64 unset ac_cv_prog_CC 64 unset ac_cv_prog_CC
65 AC_PROG_CC 65 AC_PROG_CC
66 AC_CHECK_PROGS(CXX, $CXX "${target_alias}-g++" "${target}-g++", :) 66 AC_CHECK_PROGS(CXX, $CXX "${target_alias}-g++" "${target}-g++", :)
67@@ -376,37 +377,6 @@ 67@@ -399,37 +400,6 @@
68 AC_CHECK_PROGS(STRIP, $STRIP "${target_alias}-strip" "${target}-strip", :) 68 AC_CHECK_PROGS(STRIP, $STRIP "${target_alias}-strip" "${target}-strip", :)
69 AC_CHECK_PROGS(WINDRES, $WINDRES "${target_alias}-windres" "${target}-windres", :) 69 AC_CHECK_PROGS(WINDRES, $WINDRES "${target_alias}-windres" "${target}-windres", :)
70 AC_DEFINE(CROSS_COMPILE) 70 AC_DEFINE(CROSS_COMPILE)
@@ -102,7 +102,7 @@ Index: offscreen/configure.in
102 102
103 GNU_AS= 103 GNU_AS=
104 GNU_LD= 104 GNU_LD=
105@@ -1606,6 +1576,7 @@ 105@@ -1586,6 +1556,7 @@
106 ' 106 '
107 107
108 dnl test that the macros actually work: 108 dnl test that the macros actually work:
@@ -110,7 +110,7 @@ Index: offscreen/configure.in
110 AC_MSG_CHECKING(that static assertion macros used in autoconf tests work) 110 AC_MSG_CHECKING(that static assertion macros used in autoconf tests work)
111 AC_CACHE_VAL(ac_cv_static_assertion_macros_work, 111 AC_CACHE_VAL(ac_cv_static_assertion_macros_work,
112 [AC_LANG_SAVE 112 [AC_LANG_SAVE
113@@ -2767,9 +2738,13 @@ 113@@ -2770,9 +2741,13 @@
114 AC_LANG_C 114 AC_LANG_C
115 AC_HEADER_STDC 115 AC_HEADER_STDC
116 AC_C_CONST 116 AC_C_CONST
@@ -124,7 +124,7 @@ Index: offscreen/configure.in
124 AC_TYPE_SIZE_T 124 AC_TYPE_SIZE_T
125 AC_STRUCT_ST_BLKSIZE 125 AC_STRUCT_ST_BLKSIZE
126 AC_MSG_CHECKING(for siginfo_t) 126 AC_MSG_CHECKING(for siginfo_t)
127@@ -3152,19 +3127,9 @@ 127@@ -3174,21 +3149,9 @@
128 dnl We don't want to link against libm or libpthread on Darwin since 128 dnl We don't want to link against libm or libpthread on Darwin since
129 dnl they both are just symlinks to libSystem and explicitly linking 129 dnl they both are just symlinks to libSystem and explicitly linking
130 dnl against libSystem causes issues when debugging (see bug 299601). 130 dnl against libSystem causes issues when debugging (see bug 299601).
@@ -133,6 +133,8 @@ Index: offscreen/configure.in
133- ;; 133- ;;
134-*-beos*) 134-*-beos*)
135- ;; 135- ;;
136-*-os2*)
137- ;;
136-*) 138-*)
137 AC_CHECK_LIB(m, atan) 139 AC_CHECK_LIB(m, atan)
138 AC_CHECK_LIB(dl, dlopen, 140 AC_CHECK_LIB(dl, dlopen,
@@ -145,7 +147,7 @@ Index: offscreen/configure.in
145 147
146 _SAVE_CFLAGS="$CFLAGS" 148 _SAVE_CFLAGS="$CFLAGS"
147 CFLAGS="$CFLAGS -D_GNU_SOURCE" 149 CFLAGS="$CFLAGS -D_GNU_SOURCE"
148@@ -7007,18 +6972,13 @@ 150@@ -6889,18 +6852,13 @@
149 151
150 # Demangle only for debug or trace-malloc builds 152 # Demangle only for debug or trace-malloc builds
151 MOZ_DEMANGLE_SYMBOLS= 153 MOZ_DEMANGLE_SYMBOLS=
@@ -166,7 +168,7 @@ Index: offscreen/configure.in
166 168
167 dnl ======================================================== 169 dnl ========================================================
168 dnl = 170 dnl =
169@@ -7530,10 +7490,7 @@ 171@@ -7420,10 +7378,7 @@
170 dnl if no gtk/libIDL1 or gtk2/libIDL2 combination was found, fall back 172 dnl if no gtk/libIDL1 or gtk2/libIDL2 combination was found, fall back
171 dnl to either libIDL1 or libIDL2. 173 dnl to either libIDL1 or libIDL2.
172 if test -z "$_LIBIDL_FOUND"; then 174 if test -z "$_LIBIDL_FOUND"; then
@@ -177,7 +179,7 @@ Index: offscreen/configure.in
177 fi 179 fi
178 dnl 180 dnl
179 dnl If we don't have a libIDL config program & not cross-compiling, 181 dnl If we don't have a libIDL config program & not cross-compiling,
180@@ -7605,13 +7562,7 @@ 182@@ -7495,13 +7450,7 @@
181 fi 183 fi
182 184
183 if test -z "$SKIP_PATH_CHECKS"; then 185 if test -z "$SKIP_PATH_CHECKS"; then
@@ -191,7 +193,7 @@ Index: offscreen/configure.in
191 fi 193 fi
192 194
193 if test -z "${GLIB_GMODULE_LIBS}" -a -n "${GLIB_CONFIG}"; then 195 if test -z "${GLIB_GMODULE_LIBS}" -a -n "${GLIB_CONFIG}"; then
194@@ -8457,10 +8408,7 @@ 196@@ -8278,10 +8227,7 @@
195 HAVE_WCRTOMB 197 HAVE_WCRTOMB
196 " 198 "
197 199
@@ -203,7 +205,7 @@ Index: offscreen/configure.in
203 ) 205 )
204 206
205 # Save the defines header file before autoconf removes it. 207 # Save the defines header file before autoconf removes it.
206@@ -8519,31 +8467,11 @@ 208@@ -8340,31 +8286,11 @@
207 dnl To add new Makefiles, edit allmakefiles.sh. 209 dnl To add new Makefiles, edit allmakefiles.sh.
208 dnl allmakefiles.sh sets the variable, MAKEFILES. 210 dnl allmakefiles.sh sets the variable, MAKEFILES.
209 . ${srcdir}/allmakefiles.sh 211 . ${srcdir}/allmakefiles.sh
@@ -235,7 +237,7 @@ Index: offscreen/configure.in
235 dnl Prevent the regeneration of cairo-features.h forcing rebuilds of gfx stuff 237 dnl Prevent the regeneration of cairo-features.h forcing rebuilds of gfx stuff
236 if test "$CAIRO_FEATURES_H"; then 238 if test "$CAIRO_FEATURES_H"; then
237 if cmp -s $CAIRO_FEATURES_H "$CAIRO_FEATURES_H".orig; then 239 if cmp -s $CAIRO_FEATURES_H "$CAIRO_FEATURES_H".orig; then
238@@ -8569,14 +8497,14 @@ 240@@ -8390,14 +8316,14 @@
239 HOST_LDFLAGS="$_SUBDIR_HOST_LDFLAGS" 241 HOST_LDFLAGS="$_SUBDIR_HOST_LDFLAGS"
240 RC= 242 RC=
241 243
@@ -253,7 +255,7 @@ Index: offscreen/configure.in
253 if test -z "$MOZ_DEBUG"; then 255 if test -z "$MOZ_DEBUG"; then
254 ac_configure_args="$ac_configure_args --disable-debug" 256 ac_configure_args="$ac_configure_args --disable-debug"
255 fi 257 fi
256@@ -8592,8 +8520,7 @@ 258@@ -8413,8 +8339,7 @@
257 if test -n "$USE_ARM_KUSER"; then 259 if test -n "$USE_ARM_KUSER"; then
258 ac_configure_args="$ac_configure_args --with-arm-kuser" 260 ac_configure_args="$ac_configure_args --with-arm-kuser"
259 fi 261 fi
@@ -263,7 +265,7 @@ Index: offscreen/configure.in
263 fi 265 fi
264 266
265 if test -z "$MOZ_NATIVE_NSPR"; then 267 if test -z "$MOZ_NATIVE_NSPR"; then
266@@ -8610,7 +8537,6 @@ 268@@ -8431,7 +8356,6 @@
267 269
268 # Run the SpiderMonkey 'configure' script. 270 # Run the SpiderMonkey 'configure' script.
269 dist=$MOZ_BUILD_ROOT/dist 271 dist=$MOZ_BUILD_ROOT/dist
@@ -271,7 +273,7 @@ Index: offscreen/configure.in
271 ac_configure_args="$ac_configure_args --enable-threadsafe" 273 ac_configure_args="$ac_configure_args --enable-threadsafe"
272 if test -z "$MOZ_NATIVE_NSPR"; then 274 if test -z "$MOZ_NATIVE_NSPR"; then
273 ac_configure_args="$ac_configure_args --with-nspr-cflags='$NSPR_CFLAGS'" 275 ac_configure_args="$ac_configure_args --with-nspr-cflags='$NSPR_CFLAGS'"
274@@ -8627,11 +8553,14 @@ 276@@ -8448,8 +8372,7 @@
275 export MOZ_MEMORY_LDFLAGS 277 export MOZ_MEMORY_LDFLAGS
276 fi 278 fi
277 fi 279 fi
@@ -279,19 +281,38 @@ Index: offscreen/configure.in
279-ac_configure_args="$_SUBDIR_CONFIG_ARGS" 281-ac_configure_args="$_SUBDIR_CONFIG_ARGS"
280+AC_CONFIG_SUBDIRS(js/src) 282+AC_CONFIG_SUBDIRS(js/src)
281 283
282 fi # COMPILE_ENVIRONMENT && !LIBXUL_SDK_DIR 284 # Build jsctypes on the platforms we can.
285 if test "$BUILD_CTYPES"; then
286@@ -8465,20 +8388,14 @@
287 if test -n "$CROSS_COMPILE"; then
288 ac_configure_args="$ac_configure_args --build=$build --host=$target"
289 fi
290- if test "$SOLARIS_SUNPRO_CC"; then
291- # Always use gcc for libffi on Solaris
292- old_cache_file=$cache_file
293- cache_file=js/ctypes/libffi/config.cache
294- ac_configure_args="$ac_configure_args CC=gcc"
295- AC_OUTPUT_SUBDIRS(js/ctypes/libffi)
296- cache_file=$old_cache_file
297- else
298- AC_OUTPUT_SUBDIRS(js/ctypes/libffi)
299- fi
300- ac_configure_args="$_SUBDIR_CONFIG_ARGS"
301+ AC_CONFIG_SUBDIRS(js/ctypes/libffi)
302 fi
303 fi
283 304
284+m4_pattern_allow(AS_BIN) 305+m4_pattern_allow(AS_BIN)
285+ 306+
286+AC_OUTPUT($MAKEFILES) 307+AC_OUTPUT($MAKEFILES)
287+ 308+
309 fi # COMPILE_ENVIRONMENT && !LIBXUL_SDK_DIR
310
288 dnl Prevent the regeneration of autoconf.mk forcing rebuilds of the world 311 dnl Prevent the regeneration of autoconf.mk forcing rebuilds of the world
289 dnl Needs to be at the end to respect possible changes from NSPR configure
290 if cmp -s config/autoconf.mk config/autoconf.mk.orig; then
291Index: offscreen/js/src/configure.in 312Index: offscreen/js/src/configure.in
292=================================================================== 313===================================================================
293--- offscreen.orig/js/src/configure.in 2009-06-12 14:15:55.000000000 +0100 314--- offscreen.orig/js/src/configure.in 2009-12-09 13:10:12.000000000 +0000
294+++ offscreen/js/src/configure.in 2009-06-12 14:15:55.000000000 +0100 315+++ offscreen/js/src/configure.in 2009-12-09 13:38:51.000000000 +0000
295@@ -62,7 +62,6 @@ 316@@ -62,7 +62,6 @@
296 317
297 AC_PREREQ(2.13) 318 AC_PREREQ(2.13)
@@ -319,7 +340,7 @@ Index: offscreen/js/src/configure.in
319 dnl Set various checks 340 dnl Set various checks
320 dnl ======================================================== 341 dnl ========================================================
321 MISSING_X= 342 MISSING_X=
322@@ -198,7 +202,7 @@ 343@@ -212,7 +216,7 @@
323 344
324 if test "$COMPILE_ENVIRONMENT"; then 345 if test "$COMPILE_ENVIRONMENT"; then
325 346
@@ -328,7 +349,7 @@ Index: offscreen/js/src/configure.in
328 echo "cross compiling from $host to $target" 349 echo "cross compiling from $host to $target"
329 350
330 _SAVE_CC="$CC" 351 _SAVE_CC="$CC"
331@@ -235,7 +239,7 @@ 352@@ -249,7 +253,7 @@
332 353
333 AC_MSG_CHECKING([whether the host c compiler ($HOST_CC $HOST_CFLAGS $HOST_LDFLAGS) works]) 354 AC_MSG_CHECKING([whether the host c compiler ($HOST_CC $HOST_CFLAGS $HOST_LDFLAGS) works])
334 AC_TRY_COMPILE([], [return(0);], 355 AC_TRY_COMPILE([], [return(0);],
@@ -337,7 +358,7 @@ Index: offscreen/js/src/configure.in
337 AC_MSG_ERROR([installation or configuration problem: host compiler $HOST_CC cannot create executables.]) ) 358 AC_MSG_ERROR([installation or configuration problem: host compiler $HOST_CC cannot create executables.]) )
338 359
339 CC="$HOST_CXX" 360 CC="$HOST_CXX"
340@@ -243,7 +247,7 @@ 361@@ -257,7 +261,7 @@
341 362
342 AC_MSG_CHECKING([whether the host c++ compiler ($HOST_CXX $HOST_CXXFLAGS $HOST_LDFLAGS) works]) 363 AC_MSG_CHECKING([whether the host c++ compiler ($HOST_CXX $HOST_CXXFLAGS $HOST_LDFLAGS) works])
343 AC_TRY_COMPILE([], [return(0);], 364 AC_TRY_COMPILE([], [return(0);],
@@ -346,7 +367,7 @@ Index: offscreen/js/src/configure.in
346 AC_MSG_ERROR([installation or configuration problem: host compiler $HOST_CXX cannot create executables.]) ) 367 AC_MSG_ERROR([installation or configuration problem: host compiler $HOST_CXX cannot create executables.]) )
347 368
348 CC=$_SAVE_CC 369 CC=$_SAVE_CC
349@@ -298,7 +302,7 @@ 370@@ -312,7 +316,7 @@
350 ;; 371 ;;
351 esac 372 esac
352 373
@@ -355,7 +376,7 @@ Index: offscreen/js/src/configure.in
355 unset ac_cv_prog_CC 376 unset ac_cv_prog_CC
356 AC_PROG_CC 377 AC_PROG_CC
357 AC_CHECK_PROGS(CXX, $CXX "${target_alias}-g++" "${target}-g++", :) 378 AC_CHECK_PROGS(CXX, $CXX "${target_alias}-g++" "${target}-g++", :)
358@@ -328,37 +332,6 @@ 379@@ -342,37 +346,6 @@
359 dnl able to run ppc code in a translated environment, making a cross 380 dnl able to run ppc code in a translated environment, making a cross
360 dnl compiler appear native. So we override that here. 381 dnl compiler appear native. So we override that here.
361 cross_compiling=yes 382 cross_compiling=yes
@@ -393,7 +414,7 @@ Index: offscreen/js/src/configure.in
393 414
394 GNU_AS= 415 GNU_AS=
395 GNU_LD= 416 GNU_LD=
396@@ -1424,6 +1397,8 @@ 417@@ -1370,6 +1343,8 @@
397 fi # GNU_CC 418 fi # GNU_CC
398 fi # COMPILE_ENVIRONMENT 419 fi # COMPILE_ENVIRONMENT
399 420
@@ -402,7 +423,7 @@ Index: offscreen/js/src/configure.in
402 dnl ================================================================= 423 dnl =================================================================
403 dnl Set up and test static assertion macros used to avoid AC_TRY_RUN, 424 dnl Set up and test static assertion macros used to avoid AC_TRY_RUN,
404 dnl which is bad when cross compiling. 425 dnl which is bad when cross compiling.
405@@ -2579,9 +2554,13 @@ 426@@ -2557,9 +2532,13 @@
406 AC_LANG_C 427 AC_LANG_C
407 AC_HEADER_STDC 428 AC_HEADER_STDC
408 AC_C_CONST 429 AC_C_CONST
@@ -416,7 +437,7 @@ Index: offscreen/js/src/configure.in
416 AC_TYPE_SIZE_T 437 AC_TYPE_SIZE_T
417 AC_STRUCT_ST_BLKSIZE 438 AC_STRUCT_ST_BLKSIZE
418 AC_MSG_CHECKING(for siginfo_t) 439 AC_MSG_CHECKING(for siginfo_t)
419@@ -2606,7 +2585,8 @@ 440@@ -2584,7 +2563,8 @@
420 441
421 AC_CHECK_HEADER(stdint.h) 442 AC_CHECK_HEADER(stdint.h)
422 if test "$ac_cv_header_stdint_h" = yes; then 443 if test "$ac_cv_header_stdint_h" = yes; then
@@ -426,7 +447,7 @@ Index: offscreen/js/src/configure.in
426 else 447 else
427 dnl We'll figure them out for ourselves. List more likely types 448 dnl We'll figure them out for ourselves. List more likely types
428 dnl earlier. If we ever really encounter a size for which none of 449 dnl earlier. If we ever really encounter a size for which none of
429@@ -3004,10 +2984,7 @@ 450@@ -2938,10 +2918,7 @@
430 ;; 451 ;;
431 *) 452 *)
432 AC_CHECK_LIB(m, atan) 453 AC_CHECK_LIB(m, atan)
@@ -438,7 +459,7 @@ Index: offscreen/js/src/configure.in
438 ;; 459 ;;
439 esac 460 esac
440 461
441@@ -3903,6 +3880,7 @@ 462@@ -3847,6 +3824,7 @@
442 [ --with-nspr-libs=LIBS Pass LIBS to LD when linking code that uses NSPR. 463 [ --with-nspr-libs=LIBS Pass LIBS to LD when linking code that uses NSPR.
443 See --with-nspr-cflags for more details.], 464 See --with-nspr-cflags for more details.],
444 NSPR_LIBS=$withval) 465 NSPR_LIBS=$withval)
@@ -446,7 +467,7 @@ Index: offscreen/js/src/configure.in
446 AC_SUBST(NSPR_CFLAGS) 467 AC_SUBST(NSPR_CFLAGS)
447 AC_SUBST(NSPR_LIBS) 468 AC_SUBST(NSPR_LIBS)
448 469
449@@ -4512,18 +4490,11 @@ 470@@ -4386,18 +4364,11 @@
450 471
451 # Demangle only for debug or trace-malloc builds 472 # Demangle only for debug or trace-malloc builds
452 MOZ_DEMANGLE_SYMBOLS= 473 MOZ_DEMANGLE_SYMBOLS=
@@ -465,24 +486,24 @@ Index: offscreen/js/src/configure.in
465 486
466 dnl ======================================================== 487 dnl ========================================================
467 dnl = 488 dnl =
468@@ -5231,6 +5202,8 @@ 489@@ -5097,6 +5068,8 @@
469 done 490
470 AC_SUBST(LIBS_PATH) 491 AC_HAVE_FUNCS(setlocale)
471 492
472+ 493+
473+ 494+
474 dnl ======================================================== 495 dnl ========================================================
475 dnl JavaScript shell 496 dnl Use cygwin wrapper for win32 builds, except MSYS/MinGW
476 dnl ======================================================== 497 dnl ========================================================
477@@ -5371,3 +5344,4 @@ 498@@ -5234,3 +5207,4 @@
478 # 'js-config' in Makefile.in. 499 # 'js-config' in Makefile.in.
479 AC_MSG_RESULT(invoking make to create js-config script) 500 AC_MSG_RESULT(invoking make to create js-config script)
480 $MAKE js-config 501 $MAKE js-config
481+ 502+
482Index: offscreen/nsprpub/configure.in 503Index: offscreen/nsprpub/configure.in
483=================================================================== 504===================================================================
484--- offscreen.orig/nsprpub/configure.in 2009-06-12 14:15:55.000000000 +0100 505--- offscreen.orig/nsprpub/configure.in 2009-12-09 13:10:12.000000000 +0000
485+++ offscreen/nsprpub/configure.in 2009-06-12 14:15:55.000000000 +0100 506+++ offscreen/nsprpub/configure.in 2009-12-09 13:10:12.000000000 +0000
486@@ -42,7 +42,6 @@ 507@@ -42,7 +42,6 @@
487 AC_PREREQ(2.12) 508 AC_PREREQ(2.12)
488 AC_INIT(config/libc_r.h) 509 AC_INIT(config/libc_r.h)
@@ -562,8 +583,8 @@ Index: offscreen/nsprpub/configure.in
562 583
563 dnl ======================================================== 584 dnl ========================================================
564 dnl Check for gcc -pipe support 585 dnl Check for gcc -pipe support
565@@ -2283,10 +2255,7 @@ 586@@ -2286,10 +2258,7 @@
566 *-darwin*|*-beos*) 587 *-darwin*|*-beos*|*-os2*)
567 ;; 588 ;;
568 *) 589 *)
569- AC_CHECK_LIB(dl, dlopen, 590- AC_CHECK_LIB(dl, dlopen,
@@ -574,7 +595,7 @@ Index: offscreen/nsprpub/configure.in
574 esac 595 esac
575 596
576 597
577@@ -2904,6 +2873,8 @@ 598@@ -2907,6 +2876,8 @@
578 dnl pr/tests/w16gui/Makefile 599 dnl pr/tests/w16gui/Makefile
579 dnl tools/Makefile 600 dnl tools/Makefile
580 601
@@ -583,7 +604,7 @@ Index: offscreen/nsprpub/configure.in
583 if test -z "$USE_PTHREADS" && test -z "$USE_BTHREADS"; then 604 if test -z "$USE_PTHREADS" && test -z "$USE_BTHREADS"; then
584 MAKEFILES="$MAKEFILES pr/src/threads/combined/Makefile" 605 MAKEFILES="$MAKEFILES pr/src/threads/combined/Makefile"
585 elif test -n "$USE_PTHREADS"; then 606 elif test -n "$USE_PTHREADS"; then
586@@ -2919,3 +2890,5 @@ 607@@ -2922,3 +2893,5 @@
587 echo $MAKEFILES > unallmakefiles 608 echo $MAKEFILES > unallmakefiles
588 609
589 AC_OUTPUT([$MAKEFILES], [chmod +x config/nspr-config]) 610 AC_OUTPUT([$MAKEFILES], [chmod +x config/nspr-config])
@@ -591,9 +612,9 @@ Index: offscreen/nsprpub/configure.in
591+ 612+
592Index: offscreen/js/src/Makefile.in 613Index: offscreen/js/src/Makefile.in
593=================================================================== 614===================================================================
594--- offscreen.orig/js/src/Makefile.in 2009-06-12 14:15:55.000000000 +0100 615--- offscreen.orig/js/src/Makefile.in 2009-12-09 13:10:12.000000000 +0000
595+++ offscreen/js/src/Makefile.in 2009-06-12 14:15:55.000000000 +0100 616+++ offscreen/js/src/Makefile.in 2009-12-09 13:10:12.000000000 +0000
596@@ -514,20 +514,8 @@ 617@@ -513,20 +513,8 @@
597 618
598 export:: jsautocfg.h 619 export:: jsautocfg.h
599 620
@@ -614,7 +635,7 @@ Index: offscreen/js/src/Makefile.in
614 635
615 # jscpucfg is a strange target 636 # jscpucfg is a strange target
616 # Needs to be built with the host compiler but needs to include 637 # Needs to be built with the host compiler but needs to include
617@@ -557,7 +545,7 @@ 638@@ -556,7 +544,7 @@
618 echo no need to build jscpucfg $< 639 echo no need to build jscpucfg $<
619 else 640 else
620 jscpucfg$(HOST_BIN_SUFFIX): jscpucfg.cpp Makefile.in 641 jscpucfg$(HOST_BIN_SUFFIX): jscpucfg.cpp Makefile.in
@@ -625,8 +646,8 @@ Index: offscreen/js/src/Makefile.in
625 646
626Index: offscreen/js/src/xpconnect/loader/mozJSComponentLoader.cpp 647Index: offscreen/js/src/xpconnect/loader/mozJSComponentLoader.cpp
627=================================================================== 648===================================================================
628--- offscreen.orig/js/src/xpconnect/loader/mozJSComponentLoader.cpp 2009-06-12 14:15:55.000000000 +0100 649--- offscreen.orig/js/src/xpconnect/loader/mozJSComponentLoader.cpp 2009-12-09 13:10:12.000000000 +0000
629+++ offscreen/js/src/xpconnect/loader/mozJSComponentLoader.cpp 2009-06-12 14:15:55.000000000 +0100 650+++ offscreen/js/src/xpconnect/loader/mozJSComponentLoader.cpp 2009-12-09 13:10:12.000000000 +0000
630@@ -47,6 +47,8 @@ 651@@ -47,6 +47,8 @@
631 652
632 #include <stdarg.h> 653 #include <stdarg.h>
@@ -638,8 +659,8 @@ Index: offscreen/js/src/xpconnect/loader/mozJSComponentLoader.cpp
638 #include "nsCOMPtr.h" 659 #include "nsCOMPtr.h"
639Index: offscreen/js/src/xpconnect/loader/mozJSSubScriptLoader.cpp 660Index: offscreen/js/src/xpconnect/loader/mozJSSubScriptLoader.cpp
640=================================================================== 661===================================================================
641--- offscreen.orig/js/src/xpconnect/loader/mozJSSubScriptLoader.cpp 2009-06-12 14:15:55.000000000 +0100 662--- offscreen.orig/js/src/xpconnect/loader/mozJSSubScriptLoader.cpp 2009-12-09 13:10:12.000000000 +0000
642+++ offscreen/js/src/xpconnect/loader/mozJSSubScriptLoader.cpp 2009-06-12 14:15:55.000000000 +0100 663+++ offscreen/js/src/xpconnect/loader/mozJSSubScriptLoader.cpp 2009-12-09 13:10:12.000000000 +0000
643@@ -39,6 +39,8 @@ 664@@ -39,6 +39,8 @@
644 * 665 *
645 * ***** END LICENSE BLOCK ***** */ 666 * ***** END LICENSE BLOCK ***** */
@@ -649,24 +670,11 @@ Index: offscreen/js/src/xpconnect/loader/mozJSSubScriptLoader.cpp
649 #if !defined(XPCONNECT_STANDALONE) && !defined(NO_SUBSCRIPT_LOADER) 670 #if !defined(XPCONNECT_STANDALONE) && !defined(NO_SUBSCRIPT_LOADER)
650 671
651 #include "mozJSSubScriptLoader.h" 672 #include "mozJSSubScriptLoader.h"
652Index: offscreen/modules/lcms/include/icc34.h
653===================================================================
654--- offscreen.orig/modules/lcms/include/icc34.h 2009-06-12 14:15:55.000000000 +0100
655+++ offscreen/modules/lcms/include/icc34.h 2009-06-12 14:15:55.000000000 +0100
656@@ -144,7 +144,7 @@
657 */
658
659
660-#ifdef PACKAGE_NAME
661+#if 0
662 /*
663 June 9, 2003, Adapted for use with configure by Bob Friesenhahn
664 Added the stupid check for autoconf by Marti Maria.
665Index: offscreen/toolkit/mozapps/update/src/updater/Makefile.in 673Index: offscreen/toolkit/mozapps/update/src/updater/Makefile.in
666=================================================================== 674===================================================================
667--- offscreen.orig/toolkit/mozapps/update/src/updater/Makefile.in 2009-06-12 14:15:55.000000000 +0100 675--- offscreen.orig/toolkit/mozapps/update/src/updater/Makefile.in 2009-12-09 13:10:12.000000000 +0000
668+++ offscreen/toolkit/mozapps/update/src/updater/Makefile.in 2009-06-12 14:15:55.000000000 +0100 676+++ offscreen/toolkit/mozapps/update/src/updater/Makefile.in 2009-12-09 13:10:12.000000000 +0000
669@@ -60,7 +60,7 @@ 677@@ -56,7 +56,7 @@
670 678
671 LIBS += \ 679 LIBS += \
672 $(DEPTH)/modules/libmar/src/$(LIB_PREFIX)mar.$(LIB_SUFFIX) \ 680 $(DEPTH)/modules/libmar/src/$(LIB_PREFIX)mar.$(LIB_SUFFIX) \
@@ -677,8 +685,8 @@ Index: offscreen/toolkit/mozapps/update/src/updater/Makefile.in
677 ifeq ($(OS_ARCH),WINNT) 685 ifeq ($(OS_ARCH),WINNT)
678Index: offscreen/xpcom/sample/program/Makefile.in 686Index: offscreen/xpcom/sample/program/Makefile.in
679=================================================================== 687===================================================================
680--- offscreen.orig/xpcom/sample/program/Makefile.in 2009-06-12 14:15:55.000000000 +0100 688--- offscreen.orig/xpcom/sample/program/Makefile.in 2009-12-09 13:10:12.000000000 +0000
681+++ offscreen/xpcom/sample/program/Makefile.in 2009-06-12 14:15:55.000000000 +0100 689+++ offscreen/xpcom/sample/program/Makefile.in 2009-12-09 13:10:12.000000000 +0000
682@@ -57,7 +57,7 @@ 690@@ -57,7 +57,7 @@
683 # that the application be linked against the XPCOM dynamic library or the NSPR 691 # that the application be linked against the XPCOM dynamic library or the NSPR
684 # dynamic libraries. 692 # dynamic libraries.
@@ -690,8 +698,8 @@ Index: offscreen/xpcom/sample/program/Makefile.in
690 # Need to link with CoreFoundation on Mac 698 # Need to link with CoreFoundation on Mac
691Index: offscreen/xpcom/tools/registry/Makefile.in 699Index: offscreen/xpcom/tools/registry/Makefile.in
692=================================================================== 700===================================================================
693--- offscreen.orig/xpcom/tools/registry/Makefile.in 2009-06-12 14:15:55.000000000 +0100 701--- offscreen.orig/xpcom/tools/registry/Makefile.in 2009-12-09 13:10:12.000000000 +0000
694+++ offscreen/xpcom/tools/registry/Makefile.in 2009-06-12 14:15:55.000000000 +0100 702+++ offscreen/xpcom/tools/registry/Makefile.in 2009-12-09 13:10:12.000000000 +0000
695@@ -54,7 +54,7 @@ 703@@ -54,7 +54,7 @@
696 SIMPLE_PROGRAMS = $(CPPSRCS:.cpp=$(BIN_SUFFIX)) 704 SIMPLE_PROGRAMS = $(CPPSRCS:.cpp=$(BIN_SUFFIX))
697 705
@@ -703,9 +711,9 @@ Index: offscreen/xpcom/tools/registry/Makefile.in
703 # Need to link with CoreFoundation on Mac 711 # Need to link with CoreFoundation on Mac
704Index: offscreen/xulrunner/app/Makefile.in 712Index: offscreen/xulrunner/app/Makefile.in
705=================================================================== 713===================================================================
706--- offscreen.orig/xulrunner/app/Makefile.in 2009-06-12 14:15:55.000000000 +0100 714--- offscreen.orig/xulrunner/app/Makefile.in 2009-12-09 13:10:12.000000000 +0000
707+++ offscreen/xulrunner/app/Makefile.in 2009-06-12 14:15:55.000000000 +0100 715+++ offscreen/xulrunner/app/Makefile.in 2009-12-09 13:10:12.000000000 +0000
708@@ -184,7 +184,7 @@ 716@@ -173,7 +173,7 @@
709 RCFLAGS += -DXULRUNNER_ICO=\"$(DIST)/branding/xulrunner.ico\" -DDOCUMENT_ICO=\"$(DIST)/branding/document.ico\" 717 RCFLAGS += -DXULRUNNER_ICO=\"$(DIST)/branding/xulrunner.ico\" -DDOCUMENT_ICO=\"$(DIST)/branding/document.ico\"
710 endif 718 endif
711 719
@@ -716,9 +724,9 @@ Index: offscreen/xulrunner/app/Makefile.in
716 724
717Index: offscreen/xulrunner/stub/Makefile.in 725Index: offscreen/xulrunner/stub/Makefile.in
718=================================================================== 726===================================================================
719--- offscreen.orig/xulrunner/stub/Makefile.in 2009-06-12 14:15:55.000000000 +0100 727--- offscreen.orig/xulrunner/stub/Makefile.in 2009-12-09 13:10:12.000000000 +0000
720+++ offscreen/xulrunner/stub/Makefile.in 2009-06-12 14:15:55.000000000 +0100 728+++ offscreen/xulrunner/stub/Makefile.in 2009-12-09 13:10:12.000000000 +0000
721@@ -101,7 +101,7 @@ 729@@ -100,7 +100,7 @@
722 endif 730 endif
723 endif 731 endif
724 732
@@ -729,9 +737,9 @@ Index: offscreen/xulrunner/stub/Makefile.in
729 737
730Index: offscreen/modules/plugin/test/testplugin/Makefile.in 738Index: offscreen/modules/plugin/test/testplugin/Makefile.in
731=================================================================== 739===================================================================
732--- offscreen.orig/modules/plugin/test/testplugin/Makefile.in 2009-06-12 14:15:55.000000000 +0100 740--- offscreen.orig/modules/plugin/test/testplugin/Makefile.in 2009-12-09 13:10:12.000000000 +0000
733+++ offscreen/modules/plugin/test/testplugin/Makefile.in 2009-06-12 14:15:55.000000000 +0100 741+++ offscreen/modules/plugin/test/testplugin/Makefile.in 2009-12-09 13:10:12.000000000 +0000
734@@ -63,9 +63,7 @@ 742@@ -60,9 +60,7 @@
735 CMMSRCS = nptest_macosx.mm 743 CMMSRCS = nptest_macosx.mm
736 endif 744 endif
737 745
@@ -743,18 +751,20 @@ Index: offscreen/modules/plugin/test/testplugin/Makefile.in
743 CPPSRCS += nptest_os2.cpp 751 CPPSRCS += nptest_os2.cpp
744Index: offscreen/js/src/aclocal.m4 752Index: offscreen/js/src/aclocal.m4
745=================================================================== 753===================================================================
746--- offscreen.orig/js/src/aclocal.m4 2009-06-12 14:15:55.000000000 +0100 754--- offscreen.orig/js/src/aclocal.m4 2009-12-09 13:10:12.000000000 +0000
747+++ offscreen/js/src/aclocal.m4 2009-06-12 14:15:55.000000000 +0100 755+++ offscreen/js/src/aclocal.m4 2009-12-09 13:39:01.000000000 +0000
748@@ -9,4 +9,3 @@ 756@@ -8,6 +8,4 @@
757 builtin(include, build/autoconf/altoptions.m4)dnl
749 builtin(include, build/autoconf/moznbytetype.m4)dnl 758 builtin(include, build/autoconf/moznbytetype.m4)dnl
750 builtin(include, build/autoconf/mozprog.m4)dnl 759 builtin(include, build/autoconf/mozprog.m4)dnl
760-builtin(include, build/autoconf/acwinpaths.m4)dnl
751 761
752-MOZ_PROG_CHECKMSYS() 762-MOZ_PROG_CHECKMSYS()
753Index: offscreen/toolkit/toolkit-makefiles.sh 763Index: offscreen/toolkit/toolkit-makefiles.sh
754=================================================================== 764===================================================================
755--- offscreen.orig/toolkit/toolkit-makefiles.sh 2009-06-12 14:19:59.000000000 +0100 765--- offscreen.orig/toolkit/toolkit-makefiles.sh 2009-12-09 13:10:12.000000000 +0000
756+++ offscreen/toolkit/toolkit-makefiles.sh 2009-06-12 14:20:09.000000000 +0100 766+++ offscreen/toolkit/toolkit-makefiles.sh 2009-12-09 13:10:12.000000000 +0000
757@@ -342,7 +342,6 @@ 767@@ -369,7 +369,6 @@
758 modules/plugin/sdk/samples/Makefile 768 modules/plugin/sdk/samples/Makefile
759 modules/plugin/sdk/samples/common/Makefile 769 modules/plugin/sdk/samples/common/Makefile
760 modules/plugin/sdk/samples/basic/windows/Makefile 770 modules/plugin/sdk/samples/basic/windows/Makefile