summaryrefslogtreecommitdiffstats
path: root/meta/packages/meta
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-07-17 21:34:57 +0000
committerRichard Purdie <richard@openedhand.com>2008-07-17 21:34:57 +0000
commitd12df5427a52c03ad3027d882a9749e5284ca344 (patch)
treea759ad5c583249b98fb1a9e754a4bd27829756f6 /meta/packages/meta
parent7332ac9069c01441defd10d2341f55f4d186bc2c (diff)
downloadpoky-d12df5427a52c03ad3027d882a9749e5284ca344.tar.gz
Switch from ipkg-utils to opkg-utils
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4863 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/meta')
-rw-r--r--meta/packages/meta/meta-toolchain.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/packages/meta/meta-toolchain.bb b/meta/packages/meta/meta-toolchain.bb
index de82cab765..4a383293ba 100644
--- a/meta/packages/meta/meta-toolchain.bb
+++ b/meta/packages/meta/meta-toolchain.bb
@@ -1,6 +1,6 @@
1DESCRIPTION = "Meta package for building a installable toolchain" 1DESCRIPTION = "Meta package for building a installable toolchain"
2LICENSE = "MIT" 2LICENSE = "MIT"
3DEPENDS = "opkg-native ipkg-utils-native fakeroot-native sed-native" 3DEPENDS = "opkg-native opkg-utils-native fakeroot-native sed-native"
4 4
5inherit sdk meta 5inherit sdk meta
6 6
@@ -58,7 +58,7 @@ do_populate_sdk() {
58 if [ -e $pkgnames ]; then 58 if [ -e $pkgnames ]; then
59 echo "Found $pkgnames" 59 echo "Found $pkgnames"
60 cp $pkgnames ${SDK_OUTPUT2}/${prefix}/ipk/ 60 cp $pkgnames ${SDK_OUTPUT2}/${prefix}/ipk/
61 orig_pkg=`ipkg-list-fields $pkgnames | grep OE: | cut -d ' ' -f2` 61 orig_pkg=`opkg-list-fields $pkgnames | grep OE: | cut -d ' ' -f2`
62 pkg_subdir=$arch${TARGET_VENDOR}${@['-' + bb.data.getVar('TARGET_OS', d, 1), ''][bb.data.getVar('TARGET_OS', d, 1) == ('' or 'custom')]} 62 pkg_subdir=$arch${TARGET_VENDOR}${@['-' + bb.data.getVar('TARGET_OS', d, 1), ''][bb.data.getVar('TARGET_OS', d, 1) == ('' or 'custom')]}
63 mkdir -p ${SDK_OUTPUT2}/${prefix}/pkgdata/$pkg_subdir/runtime 63 mkdir -p ${SDK_OUTPUT2}/${prefix}/pkgdata/$pkg_subdir/runtime
64 cp ${STAGING_DIR}/pkgdata/$pkg_subdir/$orig_pkg ${SDK_OUTPUT2}/${prefix}/pkgdata/$pkg_subdir/ 64 cp ${STAGING_DIR}/pkgdata/$pkg_subdir/$orig_pkg ${SDK_OUTPUT2}/${prefix}/pkgdata/$pkg_subdir/