summaryrefslogtreecommitdiffstats
path: root/meta/packages/matchbox-wm
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-04-17 16:08:13 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-04-17 16:08:13 +0000
commit15f5842bcba831a6e8c4330ad0ad93066ee02b5f (patch)
treed0c7d0f6d4f56255da3dea1947435c47e8553479 /meta/packages/matchbox-wm
parentd065e28d1f03f5ee1805d1ff6782333e9ccfcc8e (diff)
downloadpoky-15f5842bcba831a6e8c4330ad0ad93066ee02b5f.tar.gz
matchbox-wm: added 1.2
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1517 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/matchbox-wm')
-rw-r--r--meta/packages/matchbox-wm/matchbox-wm_1.2.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/packages/matchbox-wm/matchbox-wm_1.2.bb b/meta/packages/matchbox-wm/matchbox-wm_1.2.bb
new file mode 100644
index 0000000000..82ba5221c2
--- /dev/null
+++ b/meta/packages/matchbox-wm/matchbox-wm_1.2.bb
@@ -0,0 +1,36 @@
1SECTION = "x11/wm"
2DESCRIPTION = "Matchbox window manager"
3LICENSE = "GPL"
4DEPENDS = "libmatchbox virtual/libx11 libxext libxcomposite libxfixes xdamage libxrender startup-notification expat matchbox-common"
5RDEPENDS = "matchbox-common"
6
7SRC_URI = "http://matchbox-project.org/sources/matchbox-window-manager/1.2/matchbox-window-manager-${PV}.tar.bz2 \
8 file://kbdconfig \
9 file://gconf-2.m4"
10
11S = "${WORKDIR}/matchbox-window-manager-${PV}"
12
13inherit autotools pkgconfig update-alternatives
14
15FILES_${PN} = "${bindir}/* \
16 ${datadir}/matchbox \
17 ${sysconfdir}/matchbox \
18 ${datadir}/themes/blondie/matchbox \
19 ${datadir}/themes/Default/matchbox \
20 ${datadir}/themes/MBOpus/matchbox"
21
22ALTERNATIVE_NAME = "x-window-manager"
23ALTERNATIVE_LINK = "${bindir}/x-window-manager"
24ALTERNATIVE_PATH = "${bindir}/matchbox-session"
25ALTERNATIVE_PRIORITY = "10"
26
27EXTRA_OECONF = " --enable-startup-notification --disable-xrm"
28
29do_configure_prepend () {
30 cp ${WORKDIR}/gconf-2.m4 ${S}/
31}
32
33do_install_prepend() {
34 install ${WORKDIR}/kbdconfig ${S}/data/kbdconfig
35}
36