summaryrefslogtreecommitdiffstats
path: root/meta/packages/matchbox-wm/matchbox-wm_svn.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-07-21 10:10:31 +0000
committerRichard Purdie <richard@openedhand.com>2006-07-21 10:10:31 +0000
commitb2f192faabe412adce79534e22efe9fb69ee40e2 (patch)
tree7076c49d4286f8a1733650bd8fbc7161af200d57 /meta/packages/matchbox-wm/matchbox-wm_svn.bb
parent2cf0eadf9f730027833af802d7e6c90b44248f80 (diff)
downloadpoky-b2f192faabe412adce79534e22efe9fb69ee40e2.tar.gz
Rename /openembedded/ -> /meta/
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@530 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/matchbox-wm/matchbox-wm_svn.bb')
-rw-r--r--meta/packages/matchbox-wm/matchbox-wm_svn.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/packages/matchbox-wm/matchbox-wm_svn.bb b/meta/packages/matchbox-wm/matchbox-wm_svn.bb
new file mode 100644
index 0000000000..ad37976dd4
--- /dev/null
+++ b/meta/packages/matchbox-wm/matchbox-wm_svn.bb
@@ -0,0 +1,34 @@
1SECTION = "x11/wm"
2DESCRIPTION = "Matchbox window manager"
3LICENSE = "GPL"
4DEPENDS = "libmatchbox libx11 libxext libxrender startup-notification expat matchbox-common gconf"
5RDEPENDS = "matchbox-common"
6PV = "0.9.5+svn${SRCDATE}"
7PR = "r4"
8DEFAULT_PREFERENCE = "-1"
9
10SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=matchbox-window-manager;proto=http \
11 file://kbdconfig"
12
13S = "${WORKDIR}/matchbox-window-manager"
14
15inherit autotools pkgconfig update-alternatives
16
17ALTERNATIVE_NAME = "x-window-manager"
18ALTERNATIVE_LINK = "${bindir}/x-window-manager"
19ALTERNATIVE_PATH = "${bindir}/matchbox-session"
20ALTERNATIVE_PRIORITY = "10"
21
22FILES_${PN} = "${bindir} \
23 ${datadir}/matchbox \
24 ${sysconfdir}/matchbox \
25 ${datadir}/themes/blondie/matchbox \
26 ${datadir}/themes/Default/matchbox \
27 ${datadir}/themes/MBOpus/matchbox"
28
29EXTRA_OECONF = "--enable-startup-notification --disable-xrm --enable-expat"
30
31do_install_prepend() {
32 install ${WORKDIR}/kbdconfig ${S}/data/kbdconfig
33}
34