summaryrefslogtreecommitdiffstats
path: root/meta/packages/matchbox-sato
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-04-09 10:32:10 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-04-09 10:32:10 +0000
commitc9ecfc0f2ec2438df7bd0a20d6d8b1a6acdd6af7 (patch)
treee10b957679b070e493046746304a3ef65aaf1b2f /meta/packages/matchbox-sato
parentac82765a4b5cbab72ec5b8de4e1ae9354dc389c3 (diff)
downloadpoky-c9ecfc0f2ec2438df7bd0a20d6d8b1a6acdd6af7.tar.gz
matchbox-session-sato: start Sato components
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4216 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/matchbox-sato')
-rw-r--r--meta/packages/matchbox-sato/matchbox-sato/matchbox-session24
-rw-r--r--[-rwxr-xr-x]meta/packages/matchbox-sato/matchbox-session-sato/session (renamed from meta/packages/matchbox-sato/matchbox-sato/etc/matchbox/session)0
-rw-r--r--meta/packages/matchbox-sato/matchbox-session-sato_0.1.bb (renamed from meta/packages/matchbox-sato/matchbox-sato_0.1.bb)24
3 files changed, 6 insertions, 42 deletions
diff --git a/meta/packages/matchbox-sato/matchbox-sato/matchbox-session b/meta/packages/matchbox-sato/matchbox-sato/matchbox-session
deleted file mode 100644
index 4d6caa0c5a..0000000000
--- a/meta/packages/matchbox-sato/matchbox-sato/matchbox-session
+++ /dev/null
@@ -1,24 +0,0 @@
1#!/bin/sh
2#
3# Very simple session manager for matchbox tools
4#
5
6# Uncomment below to enable parsing of debian menu entrys
7# export MB_USE_DEB_MENUS=1
8
9if [ -e $HOME/.matchbox/session ]
10then
11exec $HOME/.matchbox/session
12fi
13
14if [ -e /etc/matchbox/session ]
15then
16exec /etc/matchbox/session
17fi
18
19# Default files to run if $HOME/.matchbox/session or /etc/matchbox/session
20# dont exist.
21
22matchbox-desktop &
23matchbox-panel &
24exec matchbox-window-manager $@
diff --git a/meta/packages/matchbox-sato/matchbox-sato/etc/matchbox/session b/meta/packages/matchbox-sato/matchbox-session-sato/session
index 010772a8c4..010772a8c4 100755..100644
--- a/meta/packages/matchbox-sato/matchbox-sato/etc/matchbox/session
+++ b/meta/packages/matchbox-sato/matchbox-session-sato/session
diff --git a/meta/packages/matchbox-sato/matchbox-sato_0.1.bb b/meta/packages/matchbox-sato/matchbox-session-sato_0.1.bb
index b8d6d7151a..e1180ad301 100644
--- a/meta/packages/matchbox-sato/matchbox-sato_0.1.bb
+++ b/meta/packages/matchbox-sato/matchbox-session-sato_0.1.bb
@@ -1,27 +1,15 @@
1DESCRIPTION = "Custom MB session files for poky" 1DESCRIPTION = "Custom MB session files for poky"
2LICENSE = "GPL" 2LICENSE = "GPL"
3SECTION = "x11" 3SECTION = "x11"
4RDEPENDS = "formfactor gtk-sato-engine matchbox-theme-sato gtk-theme-sato matchbox-panel-2 matchbox-desktop-sato initscripts" 4RDEPENDS = "formfactor gtk-sato-engine matchbox-theme-sato gtk-theme-sato matchbox-panel-2 matchbox-desktop-sato initscripts matchbox-session"
5RCONFLICTS = "matchbox-common" 5PR = "r22"
6PR = "r21"
7 6
8SRC_URI = "file://etc file://matchbox-session" 7SRC_URI = "file://session"
9S = ${WORKDIR} 8S = "${WORKDIR}"
10
11inherit update-alternatives
12
13ALTERNATIVE_NAME = "x-session-manager"
14ALTERNATIVE_LINK = "${bindir}/x-session-manager"
15ALTERNATIVE_PATH = "${bindir}/matchbox-session"
16ALTERNATIVE_PRIORITY = "10"
17 9
18do_install() { 10do_install() {
19 install -d ${D}/${bindir} 11 install -d ${D}/${sysconfdir}/matchbox
20 install -m 0755 ${S}/matchbox-session ${D}/${bindir} 12 install -m 0755 ${S}/session ${D}/${sysconfdir}/matchbox/
21 cp -R ${S}/etc ${D}/etc
22 rm -fR ${D}/etc/.svn
23 rm -fR ${D}/etc/matchbox/.svn
24 chmod -R 755 ${D}/etc
25} 13}
26 14
27pkg_postinst_matchbox-sato () { 15pkg_postinst_matchbox-sato () {