summaryrefslogtreecommitdiffstats
path: root/meta/packages/matchbox-sato
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2007-07-05 13:30:44 +0000
committerRoss Burton <ross@openedhand.com>2007-07-05 13:30:44 +0000
commit09324bfcc9613a1bdb30382063ae9808fcb6936f (patch)
treeaef0b9f11af9167a0c80795ddbff0d1b0f74e307 /meta/packages/matchbox-sato
parentfcbafc8486106ac6c5dbf752a91afc5921c8541f (diff)
downloadpoky-09324bfcc9613a1bdb30382063ae9808fcb6936f.tar.gz
Don't depend on matchbox-common, but matchbox-desktop-sato. Also ship /usr/bin/matchbox-session here
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2112 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/matchbox-sato')
-rw-r--r--meta/packages/matchbox-sato/matchbox-sato/matchbox-session24
-rw-r--r--meta/packages/matchbox-sato/matchbox-sato_0.1.bb9
2 files changed, 30 insertions, 3 deletions
diff --git a/meta/packages/matchbox-sato/matchbox-sato/matchbox-session b/meta/packages/matchbox-sato/matchbox-sato/matchbox-session
new file mode 100644
index 0000000000..65f1ce72ca
--- /dev/null
+++ b/meta/packages/matchbox-sato/matchbox-sato/matchbox-session
@@ -0,0 +1,24 @@
1#!/bin/sh
2#
3# Very simple session manager for matchbox tools
4#
5
6# Uncomment below to enable parsing of debian menu entrys
7# export MB_USE_DEB_MENUS=1
8
9if [ -e $HOME/.matchbox/session ]
10then
11exec $HOME/.matchbox/session
12fi
13
14if [ -e /etc/matchbox/session ]
15then
16exec /etc/matchbox/session
17fi
18
19# Default files to run if $HOME/.matchbox/session or /etc/matchbox/session
20# dont exist.
21
22matchbox-desktop &
23matchbox-panel --orientation south &
24exec matchbox-window-manager $@
diff --git a/meta/packages/matchbox-sato/matchbox-sato_0.1.bb b/meta/packages/matchbox-sato/matchbox-sato_0.1.bb
index ff9144f6ab..dd03539f28 100644
--- a/meta/packages/matchbox-sato/matchbox-sato_0.1.bb
+++ b/meta/packages/matchbox-sato/matchbox-sato_0.1.bb
@@ -1,13 +1,16 @@
1DESCRIPTION = "Custom MB session files for poky" 1DESCRIPTION = "Custom MB session files for poky"
2LICENSE = "GPL" 2LICENSE = "GPL"
3SECTION = "x11" 3SECTION = "x11"
4RDEPENDS = "matchbox-common matchbox-applet-startup-monitor gtk-sato-engine matchbox-theme-sato gtk-theme-sato matchbox-panel-2" 4RDEPENDS = "matchbox-applet-startup-monitor gtk-sato-engine matchbox-theme-sato gtk-theme-sato matchbox-panel-2 matchbox-desktop-sato"
5PR = "r13" 5RCONFLICTS = "matchbox-common"
6PR = "r14"
6 7
7SRC_URI = "file://etc" 8SRC_URI = "file://etc file://matchbox-session"
8S = ${WORKDIR} 9S = ${WORKDIR}
9 10
10do_install() { 11do_install() {
12 install -d ${D}/${bindir}
13 install -m 0755 ${S}/matchbox-session ${D}/${bindir}
11 cp -R ${S}/etc ${D}/etc 14 cp -R ${S}/etc ${D}/etc
12 rm -fR ${D}/etc/.svn 15 rm -fR ${D}/etc/.svn
13 rm -fR ${D}/etc/matchbox/.svn 16 rm -fR ${D}/etc/matchbox/.svn