diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2010-08-27 15:14:24 +0100 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-08-27 15:29:45 +0100 |
commit | 29d6678fd546377459ef75cf54abeef5b969b5cf (patch) | |
tree | 8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/packages/matchbox-keyboard | |
parent | da49de6885ee1bc424e70bc02f21f6ab920efb55 (diff) | |
download | poky-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz |
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things
and is generally overwhelming. This commit splits it into several
logical sections roughly based on function, recipes.txt gives more
information about the classifications used.
The opportunity is also used to switch from "packages" to "recipes"
as used in OpenEmbedded as the term "packages" can be confusing to
people and has many different meanings.
Not all recipes have been classified yet, this is just a first pass
at separating things out. Some packages are moved to meta-extras as
they're no longer actively used or maintained.
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/matchbox-keyboard')
3 files changed, 0 insertions, 96 deletions
diff --git a/meta/packages/matchbox-keyboard/files/80matchboxkeyboard.shbg b/meta/packages/matchbox-keyboard/files/80matchboxkeyboard.shbg deleted file mode 100755 index 43c5d3ed6a..0000000000 --- a/meta/packages/matchbox-keyboard/files/80matchboxkeyboard.shbg +++ /dev/null | |||
@@ -1,23 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | . /etc/formfactor/config | ||
4 | |||
5 | CMD="" | ||
6 | |||
7 | if [ "$HAVE_KEYBOARD" = "0" ]; then | ||
8 | CMD="matchbox-keyboard -d" | ||
9 | elif [ "$DISPLAY_CAN_ROTATE" = "1" ]; then | ||
10 | if [ "$HAVE_KEYBOARD_PORTRAIT" = "1" -a "$HAVE_KEYBOARD_LANDSCAPE" = "0" ]; then | ||
11 | CMD="matchbox-keyboard -d -o landscape" | ||
12 | elif [ "$HAVE_KEYBOARD_LANDSCAPE" = "1" -a "$HAVE_KEYBOARD_PORTRAIT" = "0" ]; then | ||
13 | CMD="matchbox-keyboard -d -o portrait" | ||
14 | fi | ||
15 | fi | ||
16 | |||
17 | |||
18 | if [ "$CMD" ]; then | ||
19 | # Delay to make sure the window manager is active | ||
20 | # by waiting for the desktop to say its finished loading | ||
21 | dbus-wait org.matchbox_project.desktop Loaded | ||
22 | exec $CMD | ||
23 | fi | ||
diff --git a/meta/packages/matchbox-keyboard/files/configure_fix.patch b/meta/packages/matchbox-keyboard/files/configure_fix.patch deleted file mode 100644 index 52cea0e8f7..0000000000 --- a/meta/packages/matchbox-keyboard/files/configure_fix.patch +++ /dev/null | |||
@@ -1,13 +0,0 @@ | |||
1 | Index: matchbox-window-manager/configure.ac | ||
2 | =================================================================== | ||
3 | --- matchbox-window-manager.orig/configure.ac 2007-11-14 12:02:28.000000000 +0000 | ||
4 | +++ matchbox-window-manager/configure.ac 2007-11-14 12:18:55.000000000 +0000 | ||
5 | @@ -283,7 +283,7 @@ | ||
6 | yes) | ||
7 | |||
8 | case "$expat" in | ||
9 | - yes) | ||
10 | + yes|"") | ||
11 | EXPAT_LIBS="-lexpat" | ||
12 | ;; | ||
13 | *) | ||
diff --git a/meta/packages/matchbox-keyboard/matchbox-keyboard_svn.bb b/meta/packages/matchbox-keyboard/matchbox-keyboard_svn.bb deleted file mode 100644 index 0425fec78a..0000000000 --- a/meta/packages/matchbox-keyboard/matchbox-keyboard_svn.bb +++ /dev/null | |||
@@ -1,60 +0,0 @@ | |||
1 | DESCRIPTION = "Matchbox virtual keyboard for X11" | ||
2 | HOMEPAGE = "http://matchbox-project.org" | ||
3 | BUGTRACKER = "http://bugzilla.openedhand.com/" | ||
4 | |||
5 | LICENSE = "GPLv2+" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ | ||
7 | file://src/matchbox-keyboard.h;endline=20;md5=4ba16ff913ad245dd6d95a6c67f72526 \ | ||
8 | file://applet/applet.c;endline=20;md5=e9201b3efa0a81a160b88d6feb5cf75b" | ||
9 | |||
10 | DEPENDS = "libfakekey expat libxft gtk+ matchbox-panel-2" | ||
11 | RDEPENDS = "formfactor dbus-wait" | ||
12 | SECTION = "x11" | ||
13 | PV = "0.0+svnr${SRCREV}" | ||
14 | PR = "r4" | ||
15 | |||
16 | SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http \ | ||
17 | file://configure_fix.patch;patch=1;maxrev=1819 \ | ||
18 | file://80matchboxkeyboard.shbg" | ||
19 | |||
20 | S = "${WORKDIR}/${PN}" | ||
21 | |||
22 | inherit autotools pkgconfig gettext | ||
23 | |||
24 | EXTRA_OECONF = "--disable-cairo --enable-gtk-im --enable-applet" | ||
25 | |||
26 | PACKAGES += "matchbox-keyboard-im matchbox-keyboard-im-dbg \ | ||
27 | matchbox-keyboard-applet matchbox-keyboard-applet-dbg" | ||
28 | |||
29 | FILES_${PN} = "${bindir}/* \ | ||
30 | ${sysconfdir} \ | ||
31 | ${datadir}/applications \ | ||
32 | ${datadir}/pixmaps \ | ||
33 | ${datadir}/matchbox-keyboard" | ||
34 | |||
35 | FILES_matchbox-keyboard-im = "${libdir}/gtk-2.0/*/immodules/*.so" | ||
36 | FILES_matchbox-keyboard-im-dbg += "${libdir}/gtk-2.0/*/immodules/.debug" | ||
37 | |||
38 | FILES_matchbox-keyboard-applet = "${libdir}/matchbox-panel/*.so" | ||
39 | FILES_matchbox-keyboard-applet-dbg += "${libdir}/matchbox-panel/.debug" | ||
40 | |||
41 | do_install_append () { | ||
42 | install -d ${D}/${sysconfdir}/X11/Xsession.d/ | ||
43 | install -m 755 ${WORKDIR}/80matchboxkeyboard.shbg ${D}/${sysconfdir}/X11/Xsession.d/ | ||
44 | } | ||
45 | |||
46 | pkg_postinst_matchbox-keyboard-im () { | ||
47 | if [ "x$D" != "x" ]; then | ||
48 | exit 1 | ||
49 | fi | ||
50 | |||
51 | gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules | ||
52 | } | ||
53 | |||
54 | pkg_postrm_matchbox-keyboard-im () { | ||
55 | if [ "x$D" != "x" ]; then | ||
56 | exit 1 | ||
57 | fi | ||
58 | |||
59 | gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules | ||
60 | } | ||