summaryrefslogtreecommitdiffstats
path: root/meta/packages/maemo
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/packages/maemo
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadpoky-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/maemo')
-rw-r--r--meta/packages/maemo/nokia770-init/fixup-770.sh26
-rw-r--r--meta/packages/maemo/nokia770-init_1.0.bb38
-rw-r--r--meta/packages/maemo/xpext/auxdir.patch13
-rw-r--r--meta/packages/maemo/xpext_1.0-5.bb22
-rw-r--r--meta/packages/maemo/xsp_1.0.0-8.bb12
5 files changed, 0 insertions, 111 deletions
diff --git a/meta/packages/maemo/nokia770-init/fixup-770.sh b/meta/packages/maemo/nokia770-init/fixup-770.sh
deleted file mode 100644
index 0f1734d2ab..0000000000
--- a/meta/packages/maemo/nokia770-init/fixup-770.sh
+++ /dev/null
@@ -1,26 +0,0 @@
1#! /bin/sh
2case "$1" in
3 start)
4 echo -n "Unmounting virtual fs from initrd"
5 umount /mnt/initfs/sys
6 umount /mnt/initfs/proc
7 ln -s /dev/vc/0 /dev/tty0
8 ln -s /dev/vc/1 /dev/tty1
9 ln -s /dev/vc/2 /dev/tty2
10 ln -s /dev/vc/3 /dev/tty3
11 ln -s /dev/vc/4 /dev/tty4
12 ln -s /dev/vc/5 /dev/tty5
13 ln -s /dev/vc/6 /dev/tty6
14 ln -s /dev/vc/7 /dev/tty7
15 /sbin/ifconfig wlan0 up
16 ;;
17 stop)
18 ;;
19 *)
20 echo "Usage: $SCRIPTNAME {start|stop}" >&2
21 exit 1
22 ;;
23esac
24
25exit 0
26 \ No newline at end of file
diff --git a/meta/packages/maemo/nokia770-init_1.0.bb b/meta/packages/maemo/nokia770-init_1.0.bb
deleted file mode 100644
index 9075c016a6..0000000000
--- a/meta/packages/maemo/nokia770-init_1.0.bb
+++ /dev/null
@@ -1,38 +0,0 @@
1LICENSE = "GPL"
2PR = "r7"
3
4DEPENDS = "base-passwd"
5
6SRC_URI = "file://fixup-770.sh"
7
8COMPATIBLE_MACHINE = "(nokia770|nokia800)"
9
10inherit update-rc.d
11
12INITSCRIPT_NAME = "fixup-770.sh"
13INITSCRIPT_PARAMS = "defaults 01"
14
15FILES_${PN} = "${sysconfdir} ${libdir}"
16
17do_install () {
18 install -d ${D}${sysconfdir}/init.d
19 install -m 755 ${WORKDIR}/fixup-770.sh ${D}/${sysconfdir}/init.d/fixup-770.sh
20
21 install -d ${D}/lib/firmware
22}
23
24pkg_postinst () {
25#!/bin/sh
26
27# set up some links to firmware and modules in initrd
28 mkdir -p $D/lib/firmware
29 ln -sf /mnt/initfs/usr/lib/hotplug/firmware/3825.arm $D/lib/firmware/3825.arm
30 ln -sf /mnt/initfs/usr/lib/hotplug/firmware/3826.arm $D/lib/firmware/3826.arm
31 ln -sf /mnt/initfs/usr/lib/hotplug/firmware/bc4fw.bin $D/lib/firmware/bc4fw.bin
32 ln -sf /mnt/initfs/usr/lib/hotplug/firmware/brf6150fw.bin $D/lib/firmware/brf6150fw.bin
33 ln -sf /mnt/initfs/usr/lib/hotplug/firmware/mtlm3825.arm $D/lib/firmware/mtlm3825.arm
34 ln -sf /mnt/initfs/usr/lib/hotplug/firmware/mtlm3826.arm $D/lib/firmware/mtlm3826.arm
35
36# rm -rf $D/lib/modules
37# ln -s /mnt/initfs/lib/modules $D/lib/modules
38}
diff --git a/meta/packages/maemo/xpext/auxdir.patch b/meta/packages/maemo/xpext/auxdir.patch
deleted file mode 100644
index da5841a132..0000000000
--- a/meta/packages/maemo/xpext/auxdir.patch
+++ /dev/null
@@ -1,13 +0,0 @@
1--- configure.ac.old 2005-06-03 12:53:28.000000000 +0200
2+++ configure.ac 2005-06-03 12:54:29.000000000 +0200
3@@ -25,9 +25,9 @@
4
5 AC_PREREQ([2.57])
6 AC_INIT([spext], [1.0], [lauri.leukkunen@nokia.com], spext)
7+AC_CONFIG_AUX_DIR(.)
8 AM_INIT_AUTOMAKE([dist-bzip2])
9 AM_MAINTAINER_MODE
10-AC_CONFIG_AUX_DIR(.)
11
12 dnl PKG_CHECK_MODULES(FIXESEXT, fixesext)
13
diff --git a/meta/packages/maemo/xpext_1.0-5.bb b/meta/packages/maemo/xpext_1.0-5.bb
deleted file mode 100644
index 5be3d1c041..0000000000
--- a/meta/packages/maemo/xpext_1.0-5.bb
+++ /dev/null
@@ -1,22 +0,0 @@
1DESCRIPTION = "X Server Nokia 770 extensions library"
2LICENSE= "MIT"
3SECTION = "x11/libs"
4PRIORITY = "optional"
5DEPENDS = "virtual/libx11 libxext"
6PR = "r1"
7
8SRC_URI = "http://repository.maemo.org/pool/maemo/ossw/source/x/${PN}/${PN}_${PV}.tar.gz \
9 file://auxdir.patch;patch=1;pnum=0"
10S = "${WORKDIR}/xpext-1.0"
11
12# ${PN} is empty so we need to tweak -dev and -dbg package dependencies
13RDEPENDS_${PN}-dev = ""
14RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPV})"
15
16inherit autotools pkgconfig
17
18do_configure_prepend () {
19 cd ${S}
20 chmod +x ./autogen.sh
21 ./autogen.sh
22}
diff --git a/meta/packages/maemo/xsp_1.0.0-8.bb b/meta/packages/maemo/xsp_1.0.0-8.bb
deleted file mode 100644
index c722213c86..0000000000
--- a/meta/packages/maemo/xsp_1.0.0-8.bb
+++ /dev/null
@@ -1,12 +0,0 @@
1DESCRIPTION = "X Server Nokia 770 extensions library"
2SECTION = "x11/libs"
3PRIORITY = "optional"
4LICENSE= "MIT"
5DEPENDS = "virtual/libx11 libxext xpext"
6
7PR = "r1"
8
9SRC_URI = "http://repository.maemo.org/pool/maemo/ossw/source/x/xsp/${PN}_${PV}.tar.gz"
10S = "${WORKDIR}/Xsp"
11
12inherit autotools pkgconfig