summaryrefslogtreecommitdiffstats
path: root/meta/packages/linux
diff options
context:
space:
mode:
authorRobert Bradford <rob@openedhand.com>2008-01-10 10:48:43 +0000
committerRobert Bradford <rob@openedhand.com>2008-01-10 10:48:43 +0000
commit1ffa3184c3af6a961f1db16129a22a8b6a46266f (patch)
tree659668bb0677a7bcd112bf8c54b598a564c1f7d2 /meta/packages/linux
parent44611fd69c715d78113f8340c3a9c5c6ad1b1056 (diff)
downloadpoky-1ffa3184c3af6a961f1db16129a22a8b6a46266f.tar.gz
Add patch to allow newer NOR chip query table.
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3445 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/linux')
-rw-r--r--meta/packages/linux/linux-mx31-2.6.19.2/nor-query-table-fix.patch13
-rw-r--r--meta/packages/linux/linux-mx31_2.6.19.2.bb1
2 files changed, 14 insertions, 0 deletions
diff --git a/meta/packages/linux/linux-mx31-2.6.19.2/nor-query-table-fix.patch b/meta/packages/linux/linux-mx31-2.6.19.2/nor-query-table-fix.patch
new file mode 100644
index 0000000000..4408da0e40
--- /dev/null
+++ b/meta/packages/linux/linux-mx31-2.6.19.2/nor-query-table-fix.patch
@@ -0,0 +1,13 @@
1Index: linux-2.6.19.2/drivers/mtd/chips/cfi_cmdset_0001.c
2===================================================================
3--- linux-2.6.19.2.orig/drivers/mtd/chips/cfi_cmdset_0001.c 2008-01-10 11:06:29.000000000 +0000
4+++ linux-2.6.19.2/drivers/mtd/chips/cfi_cmdset_0001.c 2008-01-10 11:06:58.000000000 +0000
5@@ -263,7 +263,7 @@
6 return NULL;
7
8 if (extp->MajorVersion != '1' ||
9- (extp->MinorVersion < '0' || extp->MinorVersion > '4')) {
10+ (extp->MinorVersion < '0' || extp->MinorVersion > '5')) {
11 printk(KERN_ERR " Unknown Intel/Sharp Extended Query "
12 "version %c.%c.\n", extp->MajorVersion,
13 extp->MinorVersion);
diff --git a/meta/packages/linux/linux-mx31_2.6.19.2.bb b/meta/packages/linux/linux-mx31_2.6.19.2.bb
index 3f4f777125..dbfa580f14 100644
--- a/meta/packages/linux/linux-mx31_2.6.19.2.bb
+++ b/meta/packages/linux/linux-mx31_2.6.19.2.bb
@@ -221,6 +221,7 @@ SRC_URI_append_mx31phy = " \
221 file://linux-2.6.19.2-i2c_fix.patch;patch=1 \ 221 file://linux-2.6.19.2-i2c_fix.patch;patch=1 \
222 file://linux-2.6.19.2-clock_fix.patch;patch=1 \ 222 file://linux-2.6.19.2-clock_fix.patch;patch=1 \
223 file://linux-2.6.19.2-ipu_rgb_fix.patch;patch=1 \ 223 file://linux-2.6.19.2-ipu_rgb_fix.patch;patch=1 \
224 file://nor-query-table-fix.patch;patch=1 \
224 " 225 "
225 226
226S = "${WORKDIR}/linux-2.6.19.2" 227S = "${WORKDIR}/linux-2.6.19.2"