summaryrefslogtreecommitdiffstats
path: root/meta/packages/linux-libc-headers/linux-libc-headers_2.6.18.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-10-26 12:12:24 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-10-26 12:12:24 +0000
commit1bdfb7b626be9db29987eda26f505af5f2e3e433 (patch)
tree045147ed6518a10526dfb89a01dbde7aa859a6e2 /meta/packages/linux-libc-headers/linux-libc-headers_2.6.18.bb
parenta975511d0dd0bc62db13e6ca8ea226f65ee32ae7 (diff)
downloadpoky-1bdfb7b626be9db29987eda26f505af5f2e3e433.tar.gz
linux-libc-headers: sync with OE (mainly safer use of and blackfin support)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3002 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/linux-libc-headers/linux-libc-headers_2.6.18.bb')
-rw-r--r--meta/packages/linux-libc-headers/linux-libc-headers_2.6.18.bb22
1 files changed, 18 insertions, 4 deletions
diff --git a/meta/packages/linux-libc-headers/linux-libc-headers_2.6.18.bb b/meta/packages/linux-libc-headers/linux-libc-headers_2.6.18.bb
index 33cbb4ad28..3abf26f4ff 100644
--- a/meta/packages/linux-libc-headers/linux-libc-headers_2.6.18.bb
+++ b/meta/packages/linux-libc-headers/linux-libc-headers_2.6.18.bb
@@ -30,7 +30,7 @@ set_arch() {
30 30
31do_configure() { 31do_configure() {
32 set_arch 32 set_arch
33 oe_runmake allnoconfig ARCH=$ARCH 33 oe_runmake allnoconfig ARCH=${ARCH}
34} 34}
35 35
36do_compile () { 36do_compile () {
@@ -38,7 +38,7 @@ do_compile () {
38 38
39do_install() { 39do_install() {
40 set_arch 40 set_arch
41 oe_runmake headers_install INSTALL_HDR_PATH=${D}/usr ARCH=$ARCH 41 oe_runmake headers_install INSTALL_HDR_PATH=${D}/usr ARCH=${ARCH}
42} 42}
43 43
44do_install_append_arm() { 44do_install_append_arm() {
@@ -51,8 +51,8 @@ do_stage () {
51 set_arch 51 set_arch
52 rm -rf ${STAGE_TEMP} 52 rm -rf ${STAGE_TEMP}
53 mkdir -p ${STAGE_TEMP} 53 mkdir -p ${STAGE_TEMP}
54 oe_runmake headers_install INSTALL_HDR_PATH=${STAGE_TEMP}/usr ARCH=$ARCH 54 oe_runmake headers_install INSTALL_HDR_PATH=${STAGE_TEMP}/usr ARCH=${ARCH}
55 if [ "$ARCH" = "arm" ]; then 55 if [ "${ARCH}" == "arm" ]; then
56 cp include/asm-arm/procinfo.h ${STAGE_TEMP}${includedir}/asm 56 cp include/asm-arm/procinfo.h ${STAGE_TEMP}${includedir}/asm
57 fi 57 fi
58 install -d ${STAGING_INCDIR} 58 install -d ${STAGING_INCDIR}
@@ -60,4 +60,18 @@ do_stage () {
60 cp -pfLR ${STAGE_TEMP}${includedir}/linux ${STAGING_INCDIR}/ 60 cp -pfLR ${STAGE_TEMP}${includedir}/linux ${STAGING_INCDIR}/
61 cp -pfLR ${STAGE_TEMP}${includedir}/asm ${STAGING_INCDIR}/ 61 cp -pfLR ${STAGE_TEMP}${includedir}/asm ${STAGING_INCDIR}/
62 cp -pfLR ${STAGE_TEMP}${includedir}/asm-generic ${STAGING_INCDIR}/ 62 cp -pfLR ${STAGE_TEMP}${includedir}/asm-generic ${STAGING_INCDIR}/
63 # Add UTS_RELEASE to version.h. UTS_RELEASE was moved from version.h to
64 # utsrelease.h in order to avoid recompiling a kernel every time a localversion
65 # changed. Since the our headers are static and we're not compiling an
66 # actual kernel, re-adding UTS_RELEASE does't hurt, and it allows uclibc to
67 # compile with kernel headers that work with EABI on ARM
68 echo '#define UTS_RELEASE "2.6.18"' >> ${STAGING_INCDIR}/linux/version.h
63} 69}
70
71do_stage_append_nylon () {
72 cp -pPR include/asm-${ARCH}/* ${STAGING_INCDIR}/asm/
73 cp -pPR include/asm-${ARCH}/* ${CROSS_DIR}/${TARGET_SYS}/include/asm/
74 cp -pPR include/linux/* ${STAGING_INCDIR}/linux/
75 cp -pPR include/linux/* ${CROSS_DIR}/${TARGET_SYS}/include/linux/
76}
77