diff options
author | Kevin Tian <kevin.tian@intel.com> | 2010-07-20 19:39:57 +0800 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-07-21 21:44:37 +0100 |
commit | 8a251accbfd68078fbab23a96411b76928cf1063 (patch) | |
tree | ddbddfd81b7b0a3403ec69d17eeb2c11919e58d8 /meta/packages/libpng/libpng_1.2.20.bb | |
parent | d86e127ea046f5a150a5022c457c7a8dbf0a22f0 (diff) | |
download | poky-8a251accbfd68078fbab23a96411b76928cf1063.tar.gz |
libpng: upgrade to 1.2.44
although the latest version is 1.4.3, some API changes happen which are not
compatible to some packages (such as libmatchbox using png_check_sig which
is abandoned in 1.4 version). I didn't check fully about other broken places,
and then be conservative to choose 1.2.44 as the target instead atm.
[Patches]
REMOVE _makefile_fix.patch_: a specific fix for libtool2.2.2. with 2.2.10, it's
not required then
[Recipe]
- add license checksum
- remove old do_install and do_package
- clean up package split
- remove inherit pkgconfig_stage, since its own Makefile handles it well
Signed-off-by: Kevin Tian <kevin.tian@intel.com>
Diffstat (limited to 'meta/packages/libpng/libpng_1.2.20.bb')
-rw-r--r-- | meta/packages/libpng/libpng_1.2.20.bb | 42 |
1 files changed, 0 insertions, 42 deletions
diff --git a/meta/packages/libpng/libpng_1.2.20.bb b/meta/packages/libpng/libpng_1.2.20.bb deleted file mode 100644 index c6f9d2f649..0000000000 --- a/meta/packages/libpng/libpng_1.2.20.bb +++ /dev/null | |||
@@ -1,42 +0,0 @@ | |||
1 | DESCRIPTION = "PNG Library" | ||
2 | HOMEPAGE = "http://www.libpng.org/" | ||
3 | SECTION = "libs" | ||
4 | LICENSE = "libpng" | ||
5 | DEPENDS = "zlib" | ||
6 | PRIORITY = "required" | ||
7 | PR = "r9" | ||
8 | |||
9 | SRC_URI = "${SOURCEFORGE_MIRROR}/libpng/libpng-${PV}.tar.bz2 \ | ||
10 | file://makefile_fix.patch" | ||
11 | |||
12 | inherit autotools binconfig pkgconfig pkgconfig_stage | ||
13 | |||
14 | do_install() { | ||
15 | install -d ${D}${bindir} | ||
16 | install -d ${D}${mandir} | ||
17 | install -d ${D}${libdir} | ||
18 | install -d ${D}${includedir} | ||
19 | unset LDFLAGS | ||
20 | oe_runmake 'prefix=${prefix}' 'DESTDIR=${D}' \ | ||
21 | 'DB=${D}${bindir}' 'DI=${D}${includedir}' \ | ||
22 | 'DL=${D}${libdir}' 'DM=${D}${mandir}' \ | ||
23 | install | ||
24 | } | ||
25 | |||
26 | python do_package() { | ||
27 | if bb.data.getVar('DEBIAN_NAMES', d, 1): | ||
28 | bb.data.setVar('PKG_${PN}', 'libpng12', d) | ||
29 | bb.build.exec_func('package_do_package', d) | ||
30 | } | ||
31 | |||
32 | PACKAGES =+ "${PN}12-dbg ${PN}12 ${PN}12-dev" | ||
33 | |||
34 | FILES_${PN}12-dbg += "${libdir}/libpng12*.dbg" | ||
35 | FILES_${PN}12 = "${libdir}/libpng12${SOLIBS}" | ||
36 | FILES_${PN}12-dev = "${libdir}/libpng12.* ${includedir}/libpng12 ${libdir}/pkgconfig/libpng12.pc" | ||
37 | FILES_${PN} = "${libdir}/lib*${SOLIBS}" | ||
38 | FILES_${PN}-dev = "${includedir} ${libdir}/lib*${SOLIBSDEV} ${libdir}/*.la \ | ||
39 | ${libdir}/*.a ${libdir}/pkgconfig \ | ||
40 | ${datadir}/aclocal ${bindir} ${sbindir}" | ||
41 | |||
42 | BBCLASSEXTEND = "native" | ||