summaryrefslogtreecommitdiffstats
path: root/meta/packages/libowl
diff options
context:
space:
mode:
authorTomas Frydrych <tf@openedhand.com>2007-04-23 12:12:16 +0000
committerTomas Frydrych <tf@openedhand.com>2007-04-23 12:12:16 +0000
commit68d68db48f187a697dea5f46006c7c0fd13b180b (patch)
treeac99bb2013013950c8e78e948b6d2d31312bae16 /meta/packages/libowl
parent4efae4183550b9b4635eb2dbb9cbc4c3cfa0e3e7 (diff)
downloadpoky-68d68db48f187a697dea5f46006c7c0fd13b180b.tar.gz
added a recipe for staging static libowl
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1531 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/libowl')
-rw-r--r--meta/packages/libowl/libowl_svn.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/packages/libowl/libowl_svn.bb b/meta/packages/libowl/libowl_svn.bb
new file mode 100644
index 0000000000..3fca3732d4
--- /dev/null
+++ b/meta/packages/libowl/libowl_svn.bb
@@ -0,0 +1,42 @@
1# This recipe builds libowl and then stages the header and static lib;
2# it intentionally does not stage the shared lib and create a package.
3#
4# Libowl is currently a 'cut and paste' library; this package makes our
5# life a touch easier by not having to patch the source directly into
6# applications; instead we add -lowl to the linker cmdline. Also, when
7# we eventually make libowl into a normal shared library, this package
8# will make that transition rather simple.
9
10DESCRIPTION = "OpenedHand Widget Library"
11HOMEPAGE = "http://www.o-hand.com"
12LICENSE = "LGPL"
13SECTION = "libs"
14PR = "r1"
15
16DEPENDS = "gtk+ glib"
17PACKAGES = ""
18
19SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=${PN};proto=http"
20
21S = "${WORKDIR}/${PN}"
22
23inherit autotools pkgconfig
24
25do_compile_prepend() {
26 # have to unstage the library first so that the tests build
27 rm -f ${STAGING_LIBDIR}/libowl*
28 rm -f ${STAGING_INCDIR}/owl*
29}
30
31do_stage() {
32 headers=`eval ls libowl/owl*.h`
33 for header in $headers; do
34 hdr_base=`eval basename $header`
35 install -m 644 $header ${STAGING_INCDIR}/$hdr_base
36 done
37 install -m 644 libowl/.libs/libowl.a ${STAGING_LIBDIR}/
38 install -m 644 libowl/.libs/libowl.la ${STAGING_LIBDIR}/
39}
40
41do_install() {
42}