summaryrefslogtreecommitdiffstats
path: root/meta/packages/kern-tools
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2010-06-18 01:04:26 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2010-07-19 11:59:38 -0400
commit15624d13d0ee432a2ff28168ba58674c54550af0 (patch)
treeb8ad8b60e63518b006cb40b9430a3f650af3a6db /meta/packages/kern-tools
parent3e86c5e644584bea9ab8de1d002d7db2b7deb14a (diff)
downloadpoky-15624d13d0ee432a2ff28168ba58674c54550af0.tar.gz
kern_tools: wrs kernel manipulation tools
These tools are largely unused at the moment, but represent a baseline set of functionality for working with a Wind River Linux kernel. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta/packages/kern-tools')
-rw-r--r--meta/packages/kern-tools/kern-tools-native_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/packages/kern-tools/kern-tools-native_git.bb b/meta/packages/kern-tools/kern-tools-native_git.bb
new file mode 100644
index 0000000000..417bcb689b
--- /dev/null
+++ b/meta/packages/kern-tools/kern-tools-native_git.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "Scripts and utilities for managing Wind River kernels."
2LICENSE = "GPL"
3LIC_FILES_CHKSUM = "file://git/tools/kgit;beginline=5;endline=9;md5=e2bf4415f3d843f43d2e22b0d91a6fee"
4
5DEPENDS = "git-native"
6
7PR = r4
8PV = "0.1+git${SRCPV}"
9
10# needed until the native do_stage goes away
11NATIVE_INSTALL_WORKS=1
12
13inherit native
14
15SRC_URI = "git://git.pokylinux.org/wr-kernel-tools.git;protocol=git"
16S = "${WORKDIR}"
17
18kern_tools_LIST = kgit kgit-init kgit-meta \
19 kgit-checkpoint kgit-clean \
20 generate_cfg kconf_check configme
21
22do_compile() {
23 :
24}
25
26do_install() {
27 install -d ${D}${bindir}
28 for s in ${kern_tools_LIST}; do
29 install -m 0755 ${S}/git/tools/$s ${D}${bindir}
30 done
31}