summaryrefslogtreecommitdiffstats
path: root/meta/packages/hal
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-01-15 19:48:40 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2009-01-15 19:48:40 +0000
commitf3edcecf99257532ca04eb78262b7b173a0d1445 (patch)
treefaaf12e67b97033d0f4e2116432e24eb8cbdb865 /meta/packages/hal
parent29fd4733fdfe89d712bc555a63d85c2b15c5760f (diff)
downloadpoky-f3edcecf99257532ca04eb78262b7b173a0d1445.tar.gz
hal: Delete old hal and hal-info versions
Diffstat (limited to 'meta/packages/hal')
-rw-r--r--meta/packages/hal/hal-info_20070831.bb15
-rw-r--r--meta/packages/hal/hal_0.5.9.1.bb93
2 files changed, 0 insertions, 108 deletions
diff --git a/meta/packages/hal/hal-info_20070831.bb b/meta/packages/hal/hal-info_20070831.bb
deleted file mode 100644
index a253b74409..0000000000
--- a/meta/packages/hal/hal-info_20070831.bb
+++ /dev/null
@@ -1,15 +0,0 @@
1DESCRIPTION = "Hardware Abstraction Layer device information"
2HOMEPAGE = "http://freedesktop.org/Software/hal"
3SECTION = "unknown"
4LICENSE = "GPL AFL"
5
6SRC_URI = "git://anongit.freedesktop.org/hal-info/;protocol=git;tag=HAL_INFO_${PV}"
7
8S = "${WORKDIR}/git"
9
10inherit autotools pkgconfig
11
12EXTRA_OECONF = "--disable-recall --disable-video"
13
14PACKAGE_ARCH = "all"
15FILES_${PN} += "/usr/share/hal/"
diff --git a/meta/packages/hal/hal_0.5.9.1.bb b/meta/packages/hal/hal_0.5.9.1.bb
deleted file mode 100644
index 8e4ad23937..0000000000
--- a/meta/packages/hal/hal_0.5.9.1.bb
+++ /dev/null
@@ -1,93 +0,0 @@
1DESCRIPTION = "Hardware Abstraction Layer"
2HOMEPAGE = "http://freedesktop.org/Software/hal"
3SECTION = "unknown"
4LICENSE = "GPL LGPL AFL"
5
6DEPENDS = "virtual/kernel dbus-glib udev intltool-native expat libusb"
7RDEPENDS_${PN} += "udev hal-info"
8RRECOMMENDS_${PN} += "udev-utils"
9
10PR = "r6"
11
12SRC_URI = "http://freedesktop.org/~david/dist/hal-${PV}.tar.gz \
13 file://configure_fix.patch;patch=1 \
14 file://sg-inhibit.patch;patch=1 \
15 file://20hal \
16 file://99_hal"
17
18S = "${WORKDIR}/hal-${PV}"
19
20inherit autotools pkgconfig
21
22EXTRA_OECONF = "--with-hwdata=${datadir}/hwdata \
23 --with-expat=${STAGING_DIR_HOST}${layout_prefix} \
24 --with-dbus-sys=${sysconfdir}/dbus-1/system.d \
25 --with-hotplug=${sysconfdir}/hotplug.d \
26 --disable-docbook-docs \
27 --disable-policy-kit \
28 --disable-acpi --disable-acpi-acpid --disable-acpi-proc \
29 --disable-sonypic \
30 --disable-pmu --disable-pci \
31 --disable-pci-ids --disable-pnp-ids \
32 "
33
34do_install_append() {
35 install -d ${D}/etc/default/volatiles
36 install -m 0644 ${WORKDIR}/99_hal ${D}/etc/default/volatiles
37 install -d ${D}/etc/dbus-1/event.d
38 install -m 0755 ${WORKDIR}/20hal ${D}/etc/dbus-1/event.d
39}
40
41do_stage() {
42 autotools_stage_all
43 install -d ${STAGING_LIBDIR}
44 install -m 755 libhal/.libs/libhal.so.1.0.0 ${STAGING_LIBDIR}/libhal.so
45 install -m 755 libhal-storage/.libs/libhal-storage.so.1.0.0 ${STAGING_LIBDIR}/libhal-storage.so
46}
47
48# At the time the postinst runs, dbus might not be setup so only restart if running
49pkg_postinst_hal () {
50 # can not do this offline
51 if [ "x$D" != "x" ]; then
52 exit 1
53 fi
54
55 /etc/init.d/populate-volatile.sh update
56
57 grep haldaemon /etc/group || addgroup haldaemon
58 grep haldaemon /etc/passwd || adduser --disabled-password --system --home /var/run/hald --no-create-home haldaemon --ingroup haldaemon -g HAL
59
60 DBUSPID=`pidof dbus-daemon`
61
62 if [ "x$DBUSPID" != "x" ]; then
63 /etc/init.d/dbus-1 reload
64 fi
65}
66
67pkg_postrm_hal () {
68 deluser haldaemon || true
69 delgroup haldaemon || true
70}
71
72PACKAGES =+ "libhal libhal-storage"
73
74FILES_libhal = "${libdir}/libhal.so.*"
75FILES_libhal-storage = "${libdir}/libhal-storage.so.*"
76
77FILES_${PN} = "${sysconfdir} \
78 ${bindir}/lshal \
79 ${bindir}/hal-find-by-capability \
80 ${bindir}/hal-find-by-property \
81 ${bindir}/hal-device \
82 ${bindir}/hal-get-property \
83 ${bindir}/hal-set-property \
84 ${bindir}/hal-lock \
85 ${bindir}/hal-is-caller-locked-out \
86 ${bindir}/hal-disable-polling \
87 ${sbindir} \
88 ${libdir}/libhal.so.* \
89 ${libdir}/libhal-storage.so.* \
90 ${libdir}/hal \
91 ${libexecdir} \
92 ${datadir}/hal/fdi \
93 ${datadir}/hal/scripts"